*** empty log message ***
authorMike Baker <mbm@openwrt.org>
Sat, 12 Feb 2005 16:17:47 +0000 (16:17 +0000)
committerMike Baker <mbm@openwrt.org>
Sat, 12 Feb 2005 16:17:47 +0000 (16:17 +0000)
SVN-Revision: 244

openwrt/target/default/Makefile.in [new file with mode: 0644]
openwrt/target/default/openwrt.mk [new file with mode: 0644]

diff --git a/openwrt/target/default/Makefile.in b/openwrt/target/default/Makefile.in
new file mode 100644 (file)
index 0000000..872750d
--- /dev/null
@@ -0,0 +1 @@
+TARGETS+=openwrt-image
diff --git a/openwrt/target/default/openwrt.mk b/openwrt/target/default/openwrt.mk
new file mode 100644 (file)
index 0000000..89051cd
--- /dev/null
@@ -0,0 +1,10 @@
+openwrt-linux.trx: openwrt-trx
+       PATH=$(TARGET_PATH) trx -o openwrt-linux.trx $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).$(ROOTFS)
+
+openwrt-gs-code.bin: openwrt-addpattern openwrt-linux.trx
+       PATH=$(TARGET_PATH) addpattern -2 -i  openwrt-linux.trx -o openwrt-gs-code.bin -g
+
+openwrt-g-code.bin: openwrt-gs-code.bin
+       sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin > openwrt-g-code.bin
+
+openwrt-image: openwrt-g-code.bin