remove "-fno-rtti" c++ compiler flag preventing dynamic_cast use (closes: #3731)
authorNicolas Thill <nico@openwrt.org>
Sat, 26 Jul 2008 22:32:55 +0000 (22:32 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 26 Jul 2008 22:32:55 +0000 (22:32 +0000)
SVN-Revision: 11950

libs/libtorrent/Makefile
net/rtorrent/Makefile

index 5de0323026a3962a3918778f10287e4419ad6adf..2bc9f7101f16c8c06ad9f0564bf8e731dec69c0a 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtorrent
 PKG_VERSION:=0.11.9
 
 PKG_NAME:=libtorrent
 PKG_VERSION:=0.11.9
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://libtorrent.rakshasa.no/downloads/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://libtorrent.rakshasa.no/downloads/
@@ -44,9 +44,6 @@ CONFIGURE_ARGS+= \
        --disable-debug \
        --enable-openssl \
 
        --disable-debug \
        --enable-openssl \
 
-CONFIGURE_VARS += \
-       CXXFLAGS="$$$$CXXFLAGS -fno-rtti"  \
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
index cdcf604c9c70769d6cfbdbfd87452d1fff4c2b90..2c411a5662243f36fbdd357c4e2250395d3493a8 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rtorrent
 PKG_VERSION:=0.7.9
 
 PKG_NAME:=rtorrent
 PKG_VERSION:=0.7.9
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://libtorrent.rakshasa.no/downloads/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://libtorrent.rakshasa.no/downloads/
@@ -42,7 +42,6 @@ CONFIGURE_ARGS+= \
        --disable-debug \
 
 CONFIGURE_VARS += \
        --disable-debug \
 
 CONFIGURE_VARS += \
-       CXXFLAGS="$$$$CXXFLAGS -fno-rtti"  \
        LIBS="-lm" \
 
 define Build/Compile
        LIBS="-lm" \
 
 define Build/Compile