Update mtr to 0.73 (#3633)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 6 Jul 2008 12:25:09 +0000 (12:25 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 6 Jul 2008 12:25:09 +0000 (12:25 +0000)
SVN-Revision: 11699

net/mtr/Makefile
net/mtr/patches/001-fix_configure_am_path_gtk.patch [new file with mode: 0644]
net/mtr/patches/002-no_split_rej_file.patch [new file with mode: 0644]
net/mtr/patches/501-dns.patch

index 9da915ed4e2356c083a9825b92c538e76d013c73..874947d81c09edbbd62eefcfdca87ad02fff616f 100644 (file)
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mtr
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mtr
-PKG_VERSION:=0.69
+PKG_VERSION:=0.73
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.bitwizard.nl/mtr/
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.bitwizard.nl/mtr/
-PKG_MD5SUM:=58904d6d8d70114195cdeb653d56914c
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=52223cc34c72092a0392865356a3dc76
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,13 +27,13 @@ define Package/mtr
 endef
 
 define Package/mtr/description
 endef
 
 define Package/mtr/description
-       mtr combines the functionality of the 'traceroute' and 'ping' programs 
+       mtr combines the functionality of the 'traceroute' and 'ping' programs
        in a single network diagnostic tool.
        in a single network diagnostic tool.
-       As mtr starts, it investigates the network connection between the host 
-       mtr runs on and a user-specified destination host. After it 
-       determines the address of each network hop between the machines, 
-       it sends a sequence ICMP ECHO requests to each one to determine the 
-       quality of the link to each machine. As it does this, it prints 
+       As mtr starts, it investigates the network connection between the host
+       mtr runs on and a user-specified destination host. After it
+       determines the address of each network hop between the machines,
+       it sends a sequence ICMP ECHO requests to each one to determine the
+       quality of the link to each machine. As it does this, it prints
        running statistics about each machine.
 endef
 
        running statistics about each machine.
 endef
 
diff --git a/net/mtr/patches/001-fix_configure_am_path_gtk.patch b/net/mtr/patches/001-fix_configure_am_path_gtk.patch
new file mode 100644 (file)
index 0000000..2b116fd
--- /dev/null
@@ -0,0 +1,19 @@
+--- a/configure
++++ b/configure
+@@ -6739,15 +6739,13 @@
+   rm -f conf.gtktest
+         else
+-              AM_PATH_GTK(1.0.0, CFLAGS="$CFLAGS $GTK_CFLAGS"
+-                           LIBS="$LIBS $GTK_LIBS",
+                            { echo "$as_me:$LINENO: WARNING: Building without GTK+ display support" >&5
+ echo "$as_me: WARNING: Building without GTK+ display support" >&2;}
+                            cat >>confdefs.h <<\_ACEOF
+ #define NO_GTK 1
+ _ACEOF
+-                           GTK_OBJ="")
++                           GTK_OBJ=""
+       fi
+ else
+       cat >>confdefs.h <<\_ACEOF
diff --git a/net/mtr/patches/002-no_split_rej_file.patch b/net/mtr/patches/002-no_split_rej_file.patch
new file mode 100644 (file)
index 0000000..0c9c078
--- /dev/null
@@ -0,0 +1,54 @@
+diff -urN mtr-0.73/split.c.rej mtr-0.73.new/split.c.rej
+--- mtr-0.73/split.c.rej       2006-11-18 12:04:44.000000000 +0100
++++ mtr-0.73.new/split.c.rej   1970-01-01 01:00:00.000000000 +0100
+@@ -1,29 +0,0 @@
+-***************
+-*** 103,115 ****
+-        name = dns_lookup(addr);
+-        if(name != NULL) {
+-         /* May be we should test name's length */
+--        sprintf(newLine, "%s %d %d %d %d %d %d", name,
+-                 net_loss(at),
+-                 net_returned(at), net_xmit(at),
+-                 net_best(at) /1000, net_avg(at)/1000,
+-                 net_worst(at)/1000);
+-        } else {
+--        sprintf(newLine, "%s %d %d %d %d %d %d",
+-                 strlongip( addr ),
+-                 net_loss(at),
+-                 net_returned(at), net_xmit(at),
+---- 103,115 ----
+-        name = dns_lookup(addr);
+-        if(name != NULL) {
+-         /* May be we should test name's length */
+-+        snprintf(newLine,sizeof(newLine), "%s %d %d %d %d %d %d", name,
+-                 net_loss(at),
+-                 net_returned(at), net_xmit(at),
+-                 net_best(at) /1000, net_avg(at)/1000,
+-                 net_worst(at)/1000);
+-        } else {
+-+        snprintf(newLine,sizeof(newLine), "%s %d %d %d %d %d %d",
+-                 strlongip( addr ),
+-                 net_loss(at),
+-                 net_returned(at), net_xmit(at),
+diff -urN mtr-0.73/dns.c.rej mtr-0.73.new/dns.c.rej
+--- mtr-0.73/dns.c.rej 2006-06-14 07:00:56.000000000 +0200
++++ mtr-0.73.new/dns.c.rej     1970-01-01 01:00:00.000000000 +0100
+@@ -1,17 +0,0 @@
+-***************
+-*** 1357,1363 ****
+-  #ifdef ENABLE_IPV6
+-  /* Returns an ip6.arpa character string. */
+-  void addr2ip6arpa( ip_t * ip, char * buf ) {
+--   char * p = (char *) ip;
+-    char * b = buf;
+-    int i;
+-  
+---- 1357,1363 ----
+-  #ifdef ENABLE_IPV6
+-  /* Returns an ip6.arpa character string. */
+-  void addr2ip6arpa( ip_t * ip, char * buf ) {
+-+   unsigned char * p = (unsigned char *) ip;
+-    char * b = buf;
+-    int i;
+-  
index f1c915580d11199aabd191db4a34413d99b15bbc..f9110357a7dd081e550e1a369f79ca69de398fb9 100644 (file)
@@ -1,7 +1,6 @@
-diff -Naur mtr-0.69.old/dns.c mtr-0.69.new/dns.c
---- mtr-0.69.old/dns.c 2005-01-11 09:32:42.000000000 +0100
-+++ mtr-0.69.new/dns.c 2005-10-03 21:31:27.000000000 +0200
-@@ -853,6 +853,507 @@
+--- a/dns.c
++++ b/dns.c
+@@ -859,6 +859,507 @@
    fputs("\r",stderr);
  }
  
    fputs("\r",stderr);
  }