fix snort compile
authorFelix Fietkau <nbd@openwrt.org>
Sat, 24 Mar 2007 21:55:13 +0000 (21:55 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 24 Mar 2007 21:55:13 +0000 (21:55 +0000)
SVN-Revision: 6688

net/snort/Makefile

index 7dfc28b24a280bbdb14b78e7517b63aab2eab1b0..817768a727672694944f7c8cc1ae83d0dc301c37 100644 (file)
@@ -114,26 +114,38 @@ endef
 
 
 ifneq ($(CONFIG_PACKAGE_snort),)
-  $(eval $(call Compile/Template,basic, \
+  define Compile/snort
+    $(call Compile/Template,basic, \
                --without-mysql \
                --without-postgresql \
-  ))
-  $(eval $(call Install/Template,snort,basic))
+    )
+    $(call Install/Template,snort,basic)
+  endef
 endif
+$(eval $(Compile/snort))
+
 ifneq ($(CONFIG_PACKAGE_snort-mysql),)
-  $(eval $(call Compile/Template,mysql, \
+  define Compile/snort-mysql
+    $(call Compile/Template,mysql, \
                --with-mysql="$(STAGING_DIR)/usr" \
                --without-postgresql \
-  ))
-  $(eval $(call Install/Template,snort-mysql,mysql))
+    )
+    $(call Install/Template,snort-mysql,mysql)
+  endef
 endif
+$(eval $(Compile/snort-mysql))
+
+
 ifneq ($(CONFIG_PACKAGE_snort-pgsql),)
-  $(eval $(call Compile/Template,pgsql, \
+  define Compile/snort-pgsql
+    $(call Compile/Template,pgsql, \
                --without-mysql \
                --with-postgresql="$(STAGING_DIR)/usr" \
-  ))
-  $(eval $(call Install/Template,snort-pgsql,pgsql))
+    )
+    $(call Install/Template,snort-pgsql,pgsql)
+  endef
 endif
+$(eval $(Compile/snort-pgsql))
 
 define Build/Configure
 endef