[package] fix zlib linking failures with gcc-4.4+ (#6173)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 2 Jan 2010 19:45:50 +0000 (19:45 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 2 Jan 2010 19:45:50 +0000 (19:45 +0000)
SVN-Revision: 19012

package/zlib/Makefile

index 19457c1ac8db23756abcd42f82960aaa5bed3dc6..d8213b972dc83fe6ce2cd6afc7df84c2030a844c 100644 (file)
@@ -39,6 +39,7 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
+               LDSHARED="$(TARGET_CROSS)ld -shared" \
                CFLAGS="$(TARGET_CFLAGS) $(FPIC)" \
                libz.a libz.so
        mkdir -p $(PKG_INSTALL_DIR)