[PATCH] Baltic language support for samba 2
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 3 Aug 2009 22:41:17 +0000 (22:41 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 3 Aug 2009 22:41:17 +0000 (22:41 +0000)
Enable Baltic language support in samba2 package
Signed-off-by: zintis.petersons@e-mail.lv
SVN-Revision: 17117

net/samba/Makefile
net/samba/patches/103-cp775.patch [new file with mode: 0644]

index 7b239ae9a0826e69f899206e229814293e909c79..c47a8d41d93a31fbce8aeecc5622251fa83844b4 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
 PKG_VERSION:=2.0.10
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 PKG_MD5SUM:=54870482fe036b7e69dd48c90661eec6
 
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/samba/old-versions
diff --git a/net/samba/patches/103-cp775.patch b/net/samba/patches/103-cp775.patch
new file mode 100644 (file)
index 0000000..5242791
--- /dev/null
@@ -0,0 +1,40 @@
+--- ./source/lib/charcnv.c     2009-07-01 13:42:20.000000000 +0300
++++ ./source/lib.new/charcnv.c 2009-07-01 13:53:19.000000000 +0300
+@@ -166,6 +166,28 @@
+ update_map("\270\353\271\354\272\355\274\356\276\357\277\360");
+ }
++/* init for Baltic Rim */
++/* Patch from Zintis Petersons. */
++
++static void init_iso8859_13(void) {
++
++      setupmaps();
++
++        /* MSDOS Code Page 775 -> ISO-8859-13 */
++update_map("\240\377\241\246\242\226\243\234\244\237\245\367\246\247\247\365");
++update_map("\250\235\251\250\252\212\253\256\254\252\255\360\256\251\257\222");
++update_map("\260\370\261\361\262\375\263\374\264\362\265\346\266\364\267\372");
++update_map("\270\233\271\373\272\213\273\257\274\254\275\253\276\363\277\221");
++update_map("\300\265\301\275\302\240\303\200\304\216\305\217\306\267\307\355");
++update_map("\310\266\311\220\312\215\313\270\314\225\315\350\316\241\317\352");
++update_map("\320\276\321\343\322\356\323\340\324\342\325\345\326\231\327\236");
++update_map("\330\306\331\255\332\227\333\307\334\232\335\243\336\317\337\341");
++update_map("\340\320\341\324\342\203\343\207\344\204\345\206\346\322\347\211");
++update_map("\350\321\351\202\352\245\353\323\354\205\355\351\356\214\357\353");
++update_map("\360\325\361\347\362\354\363\242\364\223\365\344\366\224\367\366");
++update_map("\370\326\371\210\372\230\373\327\374\201\375\244\376\330\377\357");
++}
++
+ /* Init for russian language (koi8) */
+ static void init_koi8_r(void)
+@@ -306,6 +328,8 @@
+         init_iso8859_5();
+     } else if (strequal (str, "iso8859-7")) {
+         init_iso8859_7();
++    } else if (strequal (str, "iso8859-13")) {
++        init_iso8859_13();
+     } else if (strequal (str, "koi8-r")) {
+         init_koi8_r();
+     } else if (strequal (str, "1251u")) {