moved readline to libreadline to represent the package name correctly
authorJohn Crispin <john@openwrt.org>
Wed, 26 Sep 2007 16:20:41 +0000 (16:20 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 26 Sep 2007 16:20:41 +0000 (16:20 +0000)
SVN-Revision: 9037

libs/libreadline/Makefile [new file with mode: 0644]
libs/readline/Makefile [deleted file]

diff --git a/libs/libreadline/Makefile b/libs/libreadline/Makefile
new file mode 100644 (file)
index 0000000..c861141
--- /dev/null
@@ -0,0 +1,71 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 5624 2006-11-23 00:29:07Z nbd $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=readline
+PKG_VERSION:=5.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/readline
+PKG_MD5SUM:=7ee5a692db88b30ca48927a13fd60e46
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libreadline
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Command lines edition library
+  DESCRIPTION:=\
+       The Readline library provides a set of functions for use by applications \\\
+       that allow users to edit command lines as they are typed in. Both Emacs \\\
+       and vi editing modes are available. The Readline library includes \\\
+       additional functions to maintain a list of previously-entered command \\\
+       lines, to recall and perhaps reedit those lines, and perform csh-like \\\
+       history expansion on previous commands.
+  URL:=http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --enable-static \
+               --without-curses \
+       )
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Build/InstallDev
+       mkdir -p $(STAGING_DIR)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/readline $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{a,so*} $(STAGING_DIR)/usr/lib/
+endef
+
+define Build/UninstallDev
+       rm -rf \
+               $(STAGING_DIR)/usr/include/readline \
+               $(STAGING_DIR)/usr/lib/lib{history,readline}.{a,so*}
+endef
+
+define Package/libreadline/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libreadline))
diff --git a/libs/readline/Makefile b/libs/readline/Makefile
deleted file mode 100644 (file)
index d61f360..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=readline
-PKG_VERSION:=5.1
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@GNU/readline
-PKG_MD5SUM:=7ee5a692db88b30ca48927a13fd60e46
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libreadline
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=Command lines edition library
-  DESCRIPTION:=\
-       The Readline library provides a set of functions for use by applications \\\
-       that allow users to edit command lines as they are typed in. Both Emacs \\\
-       and vi editing modes are available. The Readline library includes \\\
-       additional functions to maintain a list of previously-entered command \\\
-       lines, to recall and perhaps reedit those lines, and perform csh-like \\\
-       history expansion on previous commands.
-  URL:=http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html
-endef
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --without-curses \
-       )
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/readline $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{a,so*} $(STAGING_DIR)/usr/lib/
-endef
-
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/readline \
-               $(STAGING_DIR)/usr/lib/lib{history,readline}.{a,so*}
-endef
-
-define Package/libreadline/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libreadline))