[package] add yaddns, patch from rhk
authorFlorian Fainelli <florian@openwrt.org>
Sun, 28 Mar 2010 16:58:19 +0000 (16:58 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 28 Mar 2010 16:58:19 +0000 (16:58 +0000)
SVN-Revision: 20545

net/yaddns/Makefile [new file with mode: 0644]

diff --git a/net/yaddns/Makefile b/net/yaddns/Makefile
new file mode 100644 (file)
index 0000000..c90c9e3
--- /dev/null
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=yaddns
+PKG_VERSION:=0.1.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/yaddns
+PKG_MD5SUM:=2708d3e47a486b1872ef9c5537cd2f0d
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/yaddns
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=
+  TITLE:=Yet Another DDNS client
+  URL:=http://patatrac.info/yaddns
+endef
+
+define Package/yaddns/description
+Yaddns is a small ddns client with multiple ddns server supports (dyndns, ...)
+and a high flexibility. Yaddns is particularly appropriate for embedded systems.
+endef
+
+define Package/yaddns/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/yaddns $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,yaddns))