Update gnutls to 2.4.0 (#3584)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 6 Jul 2008 16:52:34 +0000 (16:52 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 6 Jul 2008 16:52:34 +0000 (16:52 +0000)
SVN-Revision: 11722

libs/gnutls/Makefile
libs/gnutls/patches/001-no_doc_tests_po.patch
libs/gnutls/patches/002-disable_openpgp.patch [deleted file]

index 94372eee88c425502a2db390b0d6b97e0319232e..5009eaadefad6aa51e1934b18bd54291ad77ed75 100644 (file)
@@ -9,7 +9,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnutls
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnutls
-PKG_VERSION:=2.2.3
+PKG_VERSION:=2.4.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -17,7 +17,7 @@ PKG_SOURCE_URL:=http://www.mirrors.wiretapped.net/security/network-security/gnut
        ftp://ftp.gnutls.org/pub/gnutls/ \
        ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/ \
        http://josefsson.org/gnutls/releases/
        ftp://ftp.gnutls.org/pub/gnutls/ \
        ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/ \
        http://josefsson.org/gnutls/releases/
-PKG_MD5SUM:=71d9b7ec32a2a67854940a8848c2b229
+PKG_MD5SUM:=dce4000841ba5f80d310c4972b5f3efe
 
 PKG_FIXUP = libtool
 
 
 PKG_FIXUP = libtool
 
index 9697520747c23f05b754daef3b3b2073bf7662c5..ec8d0d34422808097358c2343f94b50da23bdd1e 100644 (file)
@@ -1,8 +1,6 @@
-Index: gnutls-2.2.3/Makefile.in
-===================================================================
---- gnutls-2.2.3.orig/Makefile.in      2008-05-08 21:18:29.000000000 +0200
-+++ gnutls-2.2.3/Makefile.in   2008-05-08 21:18:29.000000000 +0200
-@@ -537,7 +537,7 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -573,7 +573,7 @@
  top_builddir = @top_builddir@
  top_srcdir = @top_srcdir@
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
  top_builddir = @top_builddir@
  top_srcdir = @top_srcdir@
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
@@ -10,4 +8,4 @@ Index: gnutls-2.2.3/Makefile.in
 +SUBDIRS = lgl gl includes lib libextra src \
        $(am__append_1)
  ACLOCAL_AMFLAGS = -I m4 -I gl/m4 -I lgl/m4
 +SUBDIRS = lgl gl includes lib libextra src \
        $(am__append_1)
  ACLOCAL_AMFLAGS = -I m4 -I gl/m4 -I lgl/m4
- tag = $(PACKAGE)_`echo $(VERSION) | sed 's/\./_/g'`
+ EXTRA_DIST = cfg.mk maint.mk .clcopying
diff --git a/libs/gnutls/patches/002-disable_openpgp.patch b/libs/gnutls/patches/002-disable_openpgp.patch
deleted file mode 100644 (file)
index f8bb535..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-Index: gnutls-2.2.3/libextra/gnutls_extra.c
-===================================================================
---- gnutls-2.2.3.orig/libextra/gnutls_extra.c  2008-05-08 21:18:29.000000000 +0200
-+++ gnutls-2.2.3/libextra/gnutls_extra.c       2008-05-08 21:18:29.000000000 +0200
-@@ -137,6 +137,7 @@
-     }
- #endif
-+#ifdef ENABLE_OPENPGP
-   /* Register the openpgp functions. This is because some
-    * of them are defined to be NULL in the main library.
-    */
-@@ -152,6 +153,7 @@
-                                gnutls_openpgp_crt_deinit,
-                                gnutls_openpgp_keyring_deinit,
-                                gnutls_openpgp_privkey_deinit);
-+#endif
-   return 0;
- }