ramips: fix Argus ATP-52B board and image names
authorJohn Crispin <john@openwrt.org>
Mon, 17 Aug 2015 05:58:57 +0000 (05:58 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 17 Aug 2015 05:58:57 +0000 (05:58 +0000)
The following patch:
 * changes board name from "argus-atp52b" to "atp-52b"
 * changes dts filename
 * fixes LED names in dts file and base-files scripts
 * removes manufacturer name from image filename

for Argus ATP-52B device.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
SVN-Revision: 46621

target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/dts/ARGUS_ATP52B.dts [deleted file]
target/linux/ramips/dts/ATP-52B.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

index 44aebcf6e716ebc3ee11a9dcaefb8e8039ac092f..8f6c813b20732aded32e9261da563ddec158504c 100755 (executable)
@@ -161,7 +161,7 @@ ramips_setup_interfaces()
 
        awm002-evb | \
        awm003-evb | \
-       argus-atp52b | \
+       atp-52b | \
        dir-645 | \
        dir-860l-b1 | \
        f5d8235-v1 | \
index cb3d851941c2c38d56cc2fb73c9add9f48ab16f8..f8b7e89545993a66c4ad66bef22aa7a358a6cace 100644 (file)
@@ -27,8 +27,8 @@ get_status_led() {
        awapn2403)
                status_led="asiarf:green:wps"
                ;;
-       argus-atp52b)
-               status_led="argus-atp52b:green:run"
+       atp-52b)
+               status_led="atp-52b:green:run"
                ;;
        asl26555)
                status_led="asl26555:green:power"
index 9e7f4e59880cba163c92bcbaab4e9d5b482e6975..d25fa3adc64cf15c1fffc7a1739f045b27d24720 100755 (executable)
@@ -62,7 +62,7 @@ ramips_board_detect() {
                name="c20i"
                ;;
        *"Argus ATP-52B")
-               name="argus-atp52b"
+               name="atp-52b"
                ;;
        *"AsiaRF AWM002 EVB")
                name="awm002-evb"
diff --git a/target/linux/ramips/dts/ARGUS_ATP52B.dts b/target/linux/ramips/dts/ARGUS_ATP52B.dts
deleted file mode 100644 (file)
index f94d740..0000000
+++ /dev/null
@@ -1,96 +0,0 @@
-/dts-v1/;
-
-/include/ "rt3050.dtsi"
-
-/ {
-       compatible = "ARGUS_ATP52B", "ralink,rt3052-soc";
-       model = "Argus ATP-52B";
-
-       pinctrl {
-               state_default: pinctrl0 {
-                       gpio {
-                               ralink,group = "i2c", "jtag", "rgmii", "mdio", "uartf";
-                               ralink,function = "gpio";
-                       };
-               };
-       };
-
-       cfi@1f000000 {
-               compatible = "cfi-flash";
-               reg = <0x1f000000 0x800000>;
-               bank-width = <2>;
-               device-width = <2>;
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               partition@0 {
-                       label = "bootloader";
-                       reg = <0x0 0x30000>;
-                       read-only;
-               };
-
-               partition@30000 {
-                       label = "config";
-                       reg = <0x30000 0x10000>;
-               };
-
-               factory: partition@40000 {
-                       label = "factory";
-                       reg = <0x40000 0x10000>;
-               };
-
-               partition@50000 {
-                       label = "firmware";
-                       reg = <0x50000 0x7a0000>;
-               };
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               run {
-                       label = "argus-atp52b:green:run";
-                       gpios = <&gpio0 9 1>;
-               };
-
-               net {
-                       label = "argus-atp52b:amber:net";
-                       gpios = <&gpio0 13 1>;
-               };
-       };
-
-       gpio-keys-polled {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               wps {
-                       label = "wps";
-                       gpios = <&gpio0 0 1>;
-                       linux,code = <0x211>;
-               };
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 10 1>;
-                       linux,code = <0x198>;
-               };
-       };
-
-       ethernet@10100000 {
-               mtd-mac-address = <&factory 0x4>;
-       };
-
-       esw@10110000 {
-               ralink,portmap = <0x3e>;
-       };
-
-       wmac@10180000 {
-               ralink,mtd-eeprom = <&factory 0>;
-       };
-
-       otg@101c0000 {
-               status = "okay";
-       };
-};
diff --git a/target/linux/ramips/dts/ATP-52B.dts b/target/linux/ramips/dts/ATP-52B.dts
new file mode 100644 (file)
index 0000000..c3f42bf
--- /dev/null
@@ -0,0 +1,96 @@
+/dts-v1/;
+
+/include/ "rt3050.dtsi"
+
+/ {
+       compatible = "ATP-52B", "ralink,rt3052-soc";
+       model = "Argus ATP-52B";
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "jtag", "rgmii", "mdio", "uartf";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       cfi@1f000000 {
+               compatible = "cfi-flash";
+               reg = <0x1f000000 0x800000>;
+               bank-width = <2>;
+               device-width = <2>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "bootloader";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "config";
+                       reg = <0x30000 0x10000>;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+               };
+
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0x7a0000>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               run {
+                       label = "atp-52b:green:run";
+                       gpios = <&gpio0 9 1>;
+               };
+
+               net {
+                       label = "atp-52b:amber:net";
+                       gpios = <&gpio0 13 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 0 1>;
+                       linux,code = <0x211>;
+               };
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 10 1>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+       };
+
+       esw@10110000 {
+               ralink,portmap = <0x3e>;
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       otg@101c0000 {
+               status = "okay";
+       };
+};
index c8c60b06233144b3e7350ab2745fc06f6031d6cf..78fffcd6e6c41f8c1cfb9fa9ba5b6c69603dc063 100644 (file)
@@ -442,7 +442,7 @@ Image/Build/Profile/ALL5002=$(call BuildFirmware/CustomFlash/$(1),$(1),all5002,A
 Image/Build/Profile/ALL5003=$(call BuildFirmware/CustomFlash/$(1),$(1),all5003,ALL5003,$(allnet_all5002_mtd_size))
 
 argus_atp52b_mtd_size=7995392
-Image/Build/Profile/ARGUS_ATP52B=$(call BuildFirmware/CustomFlash/$(1),$(1),argus_atp52b,ARGUS_ATP52B,$(argus_atp52b_mtd_size))
+Image/Build/Profile/ATP-52B=$(call BuildFirmware/CustomFlash/$(1),$(1),atp-52b,ATP-52B,$(argus_atp52b_mtd_size))
 
 asl26555_8mb_mtd_size=7929856
 asl26555_16mb_mtd_size=16252928
@@ -699,8 +699,8 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/ALL0256N,$(1))
        $(call Image/Build/Profile/ALL5002,$(1))
        $(call Image/Build/Profile/ALL5003,$(1))
-       $(call Image/Build/Profile/ARGUS_ATP52B,$(1))
        $(call Image/Build/Profile/ASL26555,$(1))
+       $(call Image/Build/Profile/ATP-52B,$(1))
        $(call Image/Build/Profile/AWM002EVB,$(1))
        $(call Image/Build/Profile/AWAPN2403,$(1))
        $(call Image/Build/Profile/BC2,$(1))