[package] base-files: allow option dns to override dhcp assigned dns servers
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 19 Feb 2009 05:27:36 +0000 (05:27 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 19 Feb 2009 05:27:36 +0000 (05:27 +0000)
SVN-Revision: 14562

package/base-files/Makefile
package/base-files/files/usr/share/udhcpc/default.script

index 41dc3106786c8cf72e13f99a8f2384639fbd3493..437952d72fe1b2b842e611533e8a1677d62c1441 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=14
+PKG_RELEASE:=15
 
 PKG_FILE_DEPEND:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
 
 PKG_FILE_DEPEND:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index 0eb044c512549b4133e85a1bec41f0b82e9887b3..198ef13c0fb6b1a13d238923c331c24e42cb2244 100755 (executable)
@@ -14,12 +14,21 @@ hotplug_event() {
                config_get proto $ifc proto
                [ "$proto" = "dhcp" ] || continue
                [ ifup = "$1" ] && {
                config_get proto $ifc proto
                [ "$proto" = "dhcp" ] || continue
                [ ifup = "$1" ] && {
+                       config_get userdns "$ifc" dns
+                       [ -n "$userdns" ] && {
+                               for i in $userdns; do
+                                       echo "custom dns $i"
+                                       echo "nameserver $i" >> "${RESOLV_CONF}.tmp"
+                               done
+                               dns="$userdns"
+                       }
                        uci_set_state network "$ifc" ipaddr "$ip"
                        uci_set_state network "$ifc" netmask "${subnet:-255.255.255.0}"
                        uci_set_state network "$ifc" dnsdomain "$domain"
                        uci_set_state network "$ifc" dns "$dns"
                        uci_set_state network "$ifc" gateway "$router"
                }
                        uci_set_state network "$ifc" ipaddr "$ip"
                        uci_set_state network "$ifc" netmask "${subnet:-255.255.255.0}"
                        uci_set_state network "$ifc" dnsdomain "$domain"
                        uci_set_state network "$ifc" dns "$dns"
                        uci_set_state network "$ifc" gateway "$router"
                }
+               
                env -i ACTION="$1" INTERFACE="$ifc" DEVICE="$ifname" PROTO=dhcp /sbin/hotplug-call iface
        done
 }
                env -i ACTION="$1" INTERFACE="$ifc" DEVICE="$ifname" PROTO=dhcp /sbin/hotplug-call iface
        done
 }
@@ -45,16 +54,9 @@ case "$1" in
                        echo "deleting old routes"
                        $(route -n | awk '/^0.0.0.0\W{9}('$valid')\W/ {next} /^0.0.0.0/ {print "route del -net "$1" gw "$2";"}')
                }
                        echo "deleting old routes"
                        $(route -n | awk '/^0.0.0.0\W{9}('$valid')\W/ {next} /^0.0.0.0/ {print "route del -net "$1" gw "$2";"}')
                }
-               
-               [ -n "$dns" ] && {
+
+               [ -n "$dns" ] && \
                        echo -n > "${RESOLV_CONF}.tmp"
                        echo -n > "${RESOLV_CONF}.tmp"
-                       ${domain:+echo search $domain} >> "${RESOLV_CONF}.tmp"
-                       for i in $dns ; do
-                               echo "adding dns $i"
-                               echo "nameserver $i" >> "${RESOLV_CONF}.tmp"
-                       done
-                       mv "${RESOLV_CONF}.tmp" "$RESOLV_CONF"
-               }
                
                if [ "$1" = "renew" ]; then
                        hotplug_event update
                
                if [ "$1" = "renew" ]; then
                        hotplug_event update
@@ -62,6 +64,19 @@ case "$1" in
                        hotplug_event ifup
                fi
                
                        hotplug_event ifup
                fi
                
+               [ -n "$dns" ] && {
+                       [ -s "${RESOLV_CONF}.tmp" ] || {
+                               for i in $dns ; do
+                                       echo "adding dns $i"
+                                       echo "nameserver $i" >> "${RESOLV_CONF}.tmp"
+                               done
+                       }
+
+                       ${domain:+echo search $domain} >> "${RESOLV_CONF}.tmp"
+
+                       mv "${RESOLV_CONF}.tmp" "$RESOLV_CONF"
+               }
+               
                # user rules
                [ -f /etc/udhcpc.user ] && . /etc/udhcpc.user
        ;;
                # user rules
                [ -f /etc/udhcpc.user ] && . /etc/udhcpc.user
        ;;