Update dansguardian to 2.10.0.2 (stable), includes patches from #4281
authorFlorian Fainelli <florian@openwrt.org>
Tue, 2 Dec 2008 15:41:27 +0000 (15:41 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 2 Dec 2008 15:41:27 +0000 (15:41 +0000)
SVN-Revision: 13471

net/dansguardian/Makefile
net/dansguardian/patches/001-include_dir.patch
net/dansguardian/patches/002-2.10-uclibc++.patch [new file with mode: 0644]

index c668d75974fcb1cba8a08b1c339e55c8e666ad2c..9e4ffd767c536f343091aa00ca43108d6f4b22b7 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dansguardian
-PKG_VERSION:=2.9.9.2
+PKG_VERSION:=2.10.0.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://dansguardian.org/downloads/2/Beta
-PKG_MD5SUM:=7877ee4d34df6ac538e6522755cedaf6
+PKG_SOURCE_URL:=http://dansguardian.org/downloads/2/Stable
+PKG_MD5SUM:=0a6c6d35c9e0c82fbc4a2150e8ffe977
 
 PKG_FIXUP = libtool
 
index 256b834dba2c30635a965f48b7807ad4ce5042ec..e575feba4f773b24dd601898299e205418faee2b 100644 (file)
@@ -20,24 +20,6 @@ Index: dansguardian-2.9.9.2/configure
        if test "x$staticzlib" = "xtrue"; then
                LIBS="-Bstatic -L${withval} -lz -Bdynamic ${LIBS}"
        else
-@@ -9637,7 +9637,7 @@
-       PCRE_PREFIX=`pcre-config --prefix`
-       LIBS="${PCRE_LIBS} ${LIBS}"
--      CPPFLAGS="${CPPFLAGS} -I${PCRE_PREFIX}/include"
-+      CPPFLAGS="${CPPFLAGS}"
-       { echo "$as_me:$LINENO: checking for REG_DOTALL in pcreposix.h" >&5
- echo $ECHO_N "checking for REG_DOTALL in pcreposix.h... $ECHO_C" >&6; }
-@@ -10076,7 +10076,7 @@
-       CLAMAV_PREFIX=`clamav-config --prefix`
-       LIBS="${CLAMAV_LIBS} -lclamav ${LIBS}"
--              CPPFLAGS="${CPPFLAGS} -I${CLAMAV_PREFIX}/include"
-+              CPPFLAGS="${CPPFLAGS}"
- cat >>confdefs.h <<\_ACEOF
 @@ -10753,7 +10753,7 @@
  if test "${with_libiconv+set}" = set; then
    withval=$with_libiconv;  # check for header & func (in library) in given prefix
diff --git a/net/dansguardian/patches/002-2.10-uclibc++.patch b/net/dansguardian/patches/002-2.10-uclibc++.patch
new file mode 100644 (file)
index 0000000..27b4177
--- /dev/null
@@ -0,0 +1,11 @@
+--- dansguardian-2.10/src/IPList.cpp.orig      2008-11-19 07:45:54 +0000
++++ dansguardian-2.10/src/IPList.cpp   2008-11-19 07:46:44 +0000
+@@ -81,7 +81,7 @@
+                       hostnames.reset(new std::deque<String>);
+                       hostnames->push_back(*host);
+               }
+-              for (std::deque<String>::const_iterator i = hostnames->begin(); i != hostnames->end(); ++i) 
++              for (std::deque<String>::iterator i = hostnames->begin(); i != hostnames->end(); ++i) 
+               {
+                       if (std::binary_search(hostlist.begin(), hostlist.end(), *i))
+                       {