build: fix git prereq check to forcibly disable man pagers on the --help check
authorFelix Fietkau <nbd@openwrt.org>
Sat, 5 Mar 2016 13:37:02 +0000 (13:37 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 5 Mar 2016 13:37:02 +0000 (13:37 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 48927

include/prereq-build.mk

index 443b17399de7ec85e1eb84695e4a41a634e811aa..a93dd63ab5385535f507be41dfcc6aef774f56d1 100644 (file)
@@ -155,7 +155,7 @@ $(eval $(call SetupHostCommand,svn,Please install the Subversion client, \
        svn --version | grep Subversion))
 
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
-       git submodule --help 2>&1 | grep -q -- --recursive))
+       MANPAGER=cat git submodule --help 2>&1 | grep -q -- --recursive))
 
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
        file --version 2>&1 | grep file))