[package] update openssh to 5.3p1 (#6274)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 5 Dec 2009 01:07:01 +0000 (01:07 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 5 Dec 2009 01:07:01 +0000 (01:07 +0000)
SVN-Revision: 18655

net/openssh/Makefile
net/openssh/patches/130-implicit_memset_decl_fix.patch

index f8d621b275fb2081dd966b72f1e26ee54e8b4ff8..25ff989d66fccfcf78d6f02587b0808b2dec36e3 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssh
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssh
-PKG_VERSION:=5.2p1
+PKG_VERSION:=5.3p1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
                ftp://openbsd.wiretapped.net/pub/OpenBSD/OpenSSH/portable/ \
                ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
                ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
                ftp://openbsd.wiretapped.net/pub/OpenBSD/OpenSSH/portable/ \
                ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
                ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
-PKG_MD5SUM:=ada79c7328a8551bdf55c95e631e7dad
+PKG_MD5SUM:=13563dbf61f36ca9a1e4254260131041
 
 PKG_BUILD_DEPENDS:=libopenssl
 
 
 PKG_BUILD_DEPENDS:=libopenssl
 
@@ -184,12 +184,12 @@ if [ -z "$${IPKG_INSTROOT}" ]; then
 fi
 
 echo ""
 fi
 
 echo ""
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then 
+if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
        echo "adding group $$name to /etc/group"
        echo "adding group $$name to /etc/group"
-       echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group  
+       echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
 fi
 
 fi
 
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then 
+if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
        echo "adding user $$name to /etc/passwd"
        echo "$${name}:x:$${id}:$${id}:$${name}:/var/empty/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
 fi
        echo "adding user $$name to /etc/passwd"
        echo "$${name}:x:$${id}:$${id}:$${name}:/var/empty/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
 fi
index c4644df10a0296c82c6d8563c316a140f15a322d..a2229ee8174e97c2ef43fcf36f65c8afd6871bec 100644 (file)
@@ -1,6 +1,6 @@
 --- a/includes.h
 +++ b/includes.h
 --- a/includes.h
 +++ b/includes.h
-@@ -56,6 +56,9 @@
+@@ -57,6 +57,9 @@
  /*
   *-*-nto-qnx needs these headers for strcasecmp and LASTLOG_FILE respectively
   */
  /*
   *-*-nto-qnx needs these headers for strcasecmp and LASTLOG_FILE respectively
   */