[package] ahcpd: upstream release 0.52
authorGabriel Kerneis <kerneis@pps.jussieu.fr>
Mon, 8 Aug 2011 13:23:35 +0000 (13:23 +0000)
committerGabriel Kerneis <kerneis@pps.jussieu.fr>
Mon, 8 Aug 2011 13:23:35 +0000 (13:23 +0000)
INCOMPATIBLE CHANGE: client mode configuration cannot be done in
/etc/config/network anymore (at least for this release).  It will
be added back in the near future.

SVN-Revision: 27932

ipv6/ahcpd/Makefile
ipv6/ahcpd/files/ahcp.sh
ipv6/ahcpd/files/ahcpd.config
ipv6/ahcpd/patches/001-autoconf-prefixes.patch [deleted file]

index b417c60147b30d0dcf0fa12e580b9ea5d8beab28..60e49235922b3cc19f14ee17d1350bccedc07ae6 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ahcpd
-PKG_VERSION:=0.51
-PKG_RELEASE:=4
+PKG_VERSION:=0.52
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
-PKG_MD5SUM:=86b70d278dfb5a1e33cd1a1ceae9e715
+PKG_MD5SUM:=a354b55e775c9f7d26561de360309358
 
 
 include $(INCLUDE_DIR)/package.mk
index 805013c4c2ad97eee9d929794d6387a3b4140f36..5b7b55b2016ccc65e6ae7227e75d30896a5bcf2d 100644 (file)
@@ -71,21 +71,7 @@ ahcp_config() {
 setup_interface_ahcp() {
        local interface="$1"
        local config="$2"
-       local pid_file="/var/run/ahcpd-$interface.pid"
-       local id_file="/var/lib/ahcp-unique-id-$interface"
-       local log_file="/var/log/ahcpd-$interface.log"
-       unset args
 
-       mkdir -p /var/lib
-
-       ahcp_config "$config"
-       eval "/usr/sbin/ahcpd -D -I $pid_file -i $id_file -L $log_file $args $interface"
-}
-
-stop_interface_ahcp() {
-       local cfg="$1"
-       local interface
-       config_get interface "$cfg" device
-       local pid_file="/var/run/ahcpd-$interface.pid"
-       [ -f "$pid_file" ] && kill $(cat "$pid_file")
+    echo "WARNING: ahcp client cannot be configured in /etc/config/network anymore."
+    echo "Please add $interface to /etc/config/ahcpd instead."
 }
index b2187f28362b2b74bd5d4498a1387cd0157d102c..0996251cb2d5c07c223a32f61c22394d56c059e1 100644 (file)
@@ -1,11 +1,8 @@
 package ahcpd
 
-# This configuration file is used to set up ahcpd in server or forwarder
-# mode.  To use ahcpd in client mode, use 'proto' 'ahcp' in
-# /etc/config/network (see example below).
-
 config ahcpd
-       option 'mode' 'server' # or 'forwarder' but NOT 'client'
+       # Choose ahcp mode: client (default), server or forwarder
+       ## option 'mode' 'client'
        # Uncomment the following lines to enable ahcpd on the desired
        # interfaces.
        ## list 'interface' 'lan'
@@ -33,18 +30,3 @@ config ahcpd
        # option 'lease_time' '3666'
        # option 'debug' '1'
 
-# Sample client mode configuration
-# THIS MUST BE COPIED IN /etc/config/network.  Ahcpd will ignore it
-# otherwise.
-## config 'interface' 'wlan'
-##     option 'ifname' 'ath0'
-##     option 'proto' 'ahcp'
-##  # The following lines are optional
-##     option 'multicast_address' 'ff02::cca6:c0f9:e182:5359'
-##     option 'port' '5359'
-##     option 'ipv4_only' 'false'
-##     option 'ipv6_only' 'false'
-##     option 'no_dns' 'false'
-##     option 'lease_time' '3666'
-##     option 'debug' '1'
-##     option 'script' '/etc/ahcp/ahcp-config.sh'
diff --git a/ipv6/ahcpd/patches/001-autoconf-prefixes.patch b/ipv6/ahcpd/patches/001-autoconf-prefixes.patch
deleted file mode 100644 (file)
index e29dcf1..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-Tue Jul 20 00:25:27 CEST 2010  Juliusz Chroboczek <jch@pps.jussieu.fr>
-  * Fix typo -- ignore autoconf prefixes for plen > 64.
-  Thanks to Gabriel Kerneis.
---- old-ahcpd/configure.c      2010-07-20 09:31:19.000000000 +0200
-+++ new-ahcpd/configure.c      2010-07-20 09:31:19.000000000 +0200
-@@ -505,7 +505,7 @@
-         if(config->ipv6_address) {
-             config->our_ipv6_address = copy_prefix_list(config->ipv6_address);
-         } else if(config->ipv6_prefix && config->ipv6_prefix->n > 0 &&
--                  config->ipv6_prefix->l[0].plen >= 64) {
-+                  config->ipv6_prefix->l[0].plen <= 64) {
-             unsigned char address[16];
-             int have_address = 0;