[tools] automake: use symlinks instead of hardlinks to link aclocal versions
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 10 Dec 2010 16:03:27 +0000 (16:03 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 10 Dec 2010 16:03:27 +0000 (16:03 +0000)
SVN-Revision: 24425

tools/automake/Makefile

index 932d3ee847355b628e0c43cd55d939c972d184a8..ee7966aeebd5e6d7bc6e79d2efd7fc796253f78b 100644 (file)
@@ -29,10 +29,10 @@ define Host/Install
        $(MAKE) -C $(HOST_BUILD_DIR) install
        mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
        $(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
-       ln -f $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
-       ln -f $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
-       ln -f $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
-       ln -f $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.1
+       ln -sf $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
+       ln -sf $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
+       ln -sf $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
+       ln -sf $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.1
 endef
 
 define Host/Clean