[adm5120] rewrite image generation
authorGabor Juhos <juhosg@openwrt.org>
Tue, 11 Sep 2007 17:55:08 +0000 (17:55 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 11 Sep 2007 17:55:08 +0000 (17:55 +0000)
SVN-Revision: 8755

19 files changed:
target/linux/adm5120/image/Makefile
target/linux/adm5120/image/router_be.mk [new file with mode: 0644]
target/linux/adm5120/image/router_le.mk [new file with mode: 0644]
target/linux/adm5120/router_be/image/Makefile [deleted file]
target/linux/adm5120/router_be/image/lzma-loader [deleted symlink]
target/linux/adm5120/router_be/profiles/010-Generic.mk [new file with mode: 0644]
target/linux/adm5120/router_be/profiles/090-Zyxel.mk [deleted file]
target/linux/adm5120/router_be/profiles/100-Texas.mk
target/linux/adm5120/router_be/profiles/110-Atheros.mk
target/linux/adm5120/router_be/profiles/110-None.mk [deleted file]
target/linux/adm5120/router_be/profiles/200-ZyXEL.mk [new file with mode: 0644]
target/linux/adm5120/router_le/profiles/010-Generic.mk [new file with mode: 0644]
target/linux/adm5120/router_le/profiles/100-Atheros.mk
target/linux/adm5120/router_le/profiles/105-Texas.mk
target/linux/adm5120/router_le/profiles/110-Ralink.mk
target/linux/adm5120/router_le/profiles/200-None.mk [deleted file]
target/linux/adm5120/router_le/profiles/Cellvision.mk
target/linux/adm5120/router_le/profiles/Compex.mk [new file with mode: 0644]
target/linux/adm5120/router_le/profiles/RB1xx.mk

index 77b1c897542e520f95f1bb6b0764af0afcd33cff..ea13017b1262293a0def9f531042026646bd7e4b 100644 (file)
@@ -7,14 +7,11 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-IMGNAME = $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)
-LOADER_MAKE = $(NO_TRACE_MAKE) -C lzma-loader KDIR=$(KDIR)
+LOADER_MAKE := $(NO_TRACE_MAKE) -C lzma-loader KDIR=$(KDIR)
+IMGNAME := $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)
 
-define Image/Build/Loader
-       $(LOADER_MAKE) LOADER=loader-$(1).$(2) LOADER_DATA="" \
-               LZMA_TEXT_START=$(3) LZMA_STARTUP_ORG=$(4) \
-               CONFIG_PASS_KARGS=$(5) CONFIG_BOARD=$(6) \
-               compile loader.$(2)
+define imgname
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(patsubst jffs2-%,jffs2,$(1))-$(2)
 endef
 
 define Build/Clean
@@ -25,153 +22,62 @@ define Image/Prepare
        cat $(KDIR)/vmlinux | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
 endef
 
-define trxalign/jffs2-128k
--a 0x20000
-endef
-define trxalign/jffs2-64k
--a 0x10000
-endef
-define trxalign/squashfs
--a 1024
+define Image/Build/Loader
+       $(LOADER_MAKE) LOADER=loader-$(1).$(2) LOADER_DATA="" \
+               LZMA_TEXT_START=$(3) LZMA_STARTUP_ORG=$(4) \
+               CONFIG_PASS_KARGS=$(5) CONFIG_BOARD=$(6) \
+               compile loader.$(2)
 endef
 
-define Image/Build/TRX
-       $(STAGING_DIR_HOST)/bin/trx -o $(1) -f $(3) -f $(KDIR)/vmlinux.lzma \
-               $(call trxalign/$(2)) -f $(KDIR)/root.$(2)
+define Image/Build/LZMAKernel
+       $(LOADER_MAKE) TARGET_DIR=$(BIN_DIR) \
+               LOADER=openwrt-$(BOARD)-$(KERNEL)-ramfs-lzma-$(1).$(2) \
+               LOADER_DATA=$(KDIR)/vmlinux.lzma \
+               LZMA_TEXT_START=$(3) LZMA_STARTUP_ORG=$(4) \
+               CONFIG_PASS_KARGS=$(5) CONFIG_BOARD=$(6) \
+               compile loader.$(2)
 endef
 
-define Image/Build/TRXNoloader
-       $(STAGING_DIR_HOST)/bin/trx -o $(1) -f $(KDIR)/vmlinux.lzma \
-               $(call trxalign/$(2)) -f $(KDIR)/root.$(2)
+define Image/Build/LZMAKernel/Generic
+       $(call Image/Build/LZMAKernel,$(1),$(2),0x80500000,0)
 endef
 
-define Image/Build/Compex
-       $(call Image/Build/Loader,$(2),gz,0x80500000,0,y,$(2))
-       $(call Image/Build/TRX,$(IMGNAME)-$(3)-$(2).trx,$(1),$(KDIR)/loader-$(2).gz)
+define Image/Build/LZMAKernel/Admboot
+       $(call Image/Build/LZMAKernel,$(1),$(2),0x80500000,0x6D8,y,$(1))
 endef
 
-define Image/Build/Edimax
-       $(call Image/Build/Loader,$(2),gz,0x80500000,0x6D8,y,$(2))
-       $(call Image/Build/TRXNoloader,$(IMGNAME)-$(3)-$(2).trx,$(1))
-       $(STAGING_DIR_HOST)/bin/mkcsysimg -B $(2) -d -w \
-               -r $(KDIR)/loader-$(2).gz \
-               -x $(IMGNAME)-$(3)-$(2).trx \
-               $(IMGNAME)-$(3)-$(2).bin
+define Image/Build/LZMAKernel/KArgs
+       $(call Image/Build/LZMAKernel,$(1),$(2),0x80500000,0,y,$(1))
 endef
 
-define Image/Build/Infineon
-       $(call Image/Build/Loader,$(2),gz,0x80500000,0x6D8,y,$(2))
-       $(call Image/Build/TRXNoloader,$(IMGNAME)-$(3)-$(2).trx,$(1))
-       dd if=$(KDIR)/loader-$(2).gz of=$(IMGNAME)-$(3)-$(2).img bs=64k conv=sync
-       cat $(IMGNAME)-$(3)-$(2).trx >>$(IMGNAME)-$(3)-$(2).img
+define trxalign/jffs2-128k
+-a 0x20000 -f $(KDIR)/root.jffs2-128k
 endef
-
-define Image/Build/MyLoader
-       $(call Image/Build/Loader,$(2),gz,0x80500000,0)
-       $(call Image/Build/TRXNoloader,$(IMGNAME)-$(3)-$(2).trx,$(1))
-       $(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) \
-               -p0x20000:0x10000:ahp:0x80001000 \
-               -p0x30000:0 \
-               -b0x20000:0x10000:h:$(KDIR)/loader-$(2).gz \
-               -b0x30000:0::$(IMGNAME)-$(3)-$(2).trx \
-               $(IMGNAME)-$(3)-$(2).bin
+define trxalign/jffs2-64k
+-a 0x10000 -f $(KDIR)/root.jffs2-64k
 endef
-
-define Image/cmdline/yaffs2
-root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit
+define trxalign/squashfs
+-a 1024 -f $(KDIR)/root.squashfs
 endef
 
-define Image/Build/RouterBoard
-       $(CP) $(KDIR)/vmlinux.elf $(IMGNAME)-rb1xx-vmlinux
-       $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/yaffs2)) '
+define Image/Build/TRX
+       $(STAGING_DIR_HOST)/bin/trx -o $(1) -f $(3) -f $(KDIR)/vmlinux.lzma \
+               $(call trxalign/$(2))
 endef
 
-define Image/Build/jffs2-64k
-       $(call Image/Build/Compex,$(1),wp54g-wrt,$(patsubst jffs2-%,jffs2,$(1)))
-ifeq ($(CONFIG_DEVEL),y)
-       $(call Image/Build/Edimax,$(1),br-6104k,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/Edimax,$(1),br-6104kp,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/Edimax,$(1),br-6114wg,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/Edimax,$(1),br-6524k,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/Edimax,$(1),br-6524kp,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/Edimax,$(1),br-6541k,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/Edimax,$(1),br-6541kp,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/Edimax,$(1),ew-7207apg,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/Edimax,$(1),ps-1205uwg,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/Edimax,$(1),ps-3205u,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/Edimax,$(1),ps-3205uwg,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/Edimax,$(1),br-6524wg,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/Edimax,$(1),br-6524wp,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/Infineon,$(1),easy-5120p-ata,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/Infineon,$(1),easy-5120-rt,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/Infineon,$(1),easy-5120-wvoip,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/Infineon,$(1),easy-83000,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/MyLoader,$(1),np27g,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/MyLoader,$(1),np28g,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/MyLoader,$(1),np28ghs,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/MyLoader,$(1),wp54g,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/MyLoader,$(1),wp54ag,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/MyLoader,$(1),wpp54g,$(patsubst jffs2-%,jffs2,$(1)))
-       $(call Image/Build/MyLoader,$(1),wpp54ag,$(patsubst jffs2-%,jffs2,$(1)))
-endif
+define Image/Build/TRXNoloader
+       $(STAGING_DIR_HOST)/bin/trx -o $(1) -f $(KDIR)/vmlinux.lzma \
+               $(call trxalign/$(2))
 endef
 
-define Image/Build/squashfs
-$(call Image/Build/jffs2-64k,$(1))
-endef
+include $(SUBTARGET).mk
 
 define Image/Build
-$(call Image/Build/$(1),$(1))
-endef
-
-ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
-  define Image/BuildKernel
-       $(call Image/Build/RouterBoard)
-  endef
-endif
-
-define Image/Build/LZMAKernel
-       $(LOADER_MAKE) TARGET_DIR=$(BIN_DIR) \
-               LOADER=openwrt-$(BOARD)-$(KERNEL)-ramfs-lzma-$(1).$(2) \
-               LOADER_DATA=$(KDIR)/vmlinux.lzma \
-               LZMA_TEXT_START=$(3) LZMA_STARTUP_ORG=$(4) \
-               CONFIG_PASS_KARGS=$(5) CONFIG_BOARD=$(6) \
-               compile loader.$(2)
-endef
-
-define Image/Build/LZMAKernel/Compex
-       $(call Image/Build/LZMAKernel,$(1),$(2),0x80500000,0,y,$(1))
-endef
-
-define Image/Build/LZMAKernel/Generic
-       $(call Image/Build/LZMAKernel,$(1),$(2),0x80500000,0)
-endef
-
-define Image/Build/LZMAKernel/Admboot
-       $(call Image/Build/LZMAKernel,$(1),$(2),0x80500000,0x6D8,y,$(1))
-endef
-
-define Image/Build/Initramfs/RouterBoard
-       $(CP) $(KDIR)/vmlinux.elf $(IMGNAME)-ramfs-rb1xx.elf
+       $(call Image/Build/Profile/$(PROFILE),$(1))
 endef
 
 define Image/Build/Initramfs
-       $(call Image/Build/Initramfs/RouterBoard)
-       $(call Image/Build/LZMAKernel/Compex,wp54g-wrt,bin)
-ifeq ($(CONFIG_DEVEL),y)
-       $(call Image/Build/LZMAKernel/Generic,generic,bin)
-       $(call Image/Build/LZMAKernel/Generic,np27g,bin)
-       $(call Image/Build/LZMAKernel/Generic,wp54g,bin)
-       $(call Image/Build/LZMAKernel/Admboot,br-6104k,gz)
-       $(call Image/Build/LZMAKernel/Admboot,easy-5120,gz)
-       $(call Image/Build/LZMAKernel/Admboot,easy-83000,gz)
-       $(call Image/Build/LZMAKernel/Admboot,cas-630,gz)
-       $(call Image/Build/LZMAKernel/Admboot,cas-670,gz)
-       $(call Image/Build/LZMAKernel/Admboot,cas-700,gz)
-       $(call Image/Build/LZMAKernel/Admboot,cas-771,gz)
-       $(call Image/Build/LZMAKernel/Admboot,cas-790,gz)
-       $(call Image/Build/LZMAKernel/Admboot,cas-861,gz)
-endif
+       $(call Image/Build/Profile/$(PROFILE),Initramfs)
 endef
 
 $(eval $(call BuildImage))
diff --git a/target/linux/adm5120/image/router_be.mk b/target/linux/adm5120/image/router_be.mk
new file mode 100644 (file)
index 0000000..42e56fa
--- /dev/null
@@ -0,0 +1,79 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Image/Build/ZyXEL
+       $(call Image/Build/TRXNoloader,$(call imgname,$(1),$(2)).trx,$(1))
+endef
+
+#
+# ZyXEL Prestige 334WT
+#
+define Image/Build/Board/P-334WT
+       $(call Image/Build/ZyXEL,$(1),p-334wt)
+endef
+
+define Image/Build/Board/P-334WT/squashfs
+       $(call Image/Build/Board/P-334WT,squashfs)
+endef
+
+define Image/Build/Board/P-334WT/jffs2-64k
+       $(call Image/Build/Board/P-334WT,jffs2-64k)
+endef
+
+define Image/Build/Board/P-334WT/Initramfs
+       $(call Image/Build/LZMAKernel/KArgs,p-334wt,bin)
+endef
+
+#
+# ZyXEL Prestige 335WT
+#
+define Image/Build/Board/P-335WT
+       $(call Image/Build/ZyXEL,$(1),p-335wt)
+endef
+
+define Image/Build/Board/P-335WT/squashfs
+       $(call Image/Build/Board/P-335WT,$(1))
+endef
+
+define Image/Build/Board/P-335WT/jffs2-64k
+       $(call Image/Build/Board/P-335WT,$(1))
+endef
+
+define Image/Build/Board/P-335WT/Initramfs
+       $(call Image/Build/LZMAKernel/KArgs,p-335wt,bin)
+endef
+
+#
+# Groups
+#
+define Image/Build/Group/All
+       $(call Image/Build/Board/P-334WT/$(1))
+       $(call Image/Build/Board/P-335WT/$(1))
+endef
+
+#
+# Profiles
+#
+define Image/Build/Profile/Generic
+       $(call Image/Build/Group/All,$(1))
+endef
+
+define Image/Build/Profile/Atheros
+       $(call Image/Build/Group/All,$(1))
+endef
+
+define Image/Build/Profile/Texas
+       $(call Image/Build/Group/All,$(1))
+endef
+
+define Image/Build/Profile/P-334WT
+       $(call Image/Build/Board/P-334WT,$(1))
+endef
+
+define Image/Build/Profile/P-335WT
+       $(call Image/Build/Board/P-335WT,$(1))
+endef
diff --git a/target/linux/adm5120/image/router_le.mk b/target/linux/adm5120/image/router_le.mk
new file mode 100644 (file)
index 0000000..5d98e58
--- /dev/null
@@ -0,0 +1,332 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Image/Build/Compex
+       $(call Image/Build/Loader,$(2),gz,0x80500000,0,y,$(2))
+       $(call Image/Build/TRX,$(call imgname,$(1),$(2)).trx,$(1),$(KDIR)/loader-$(2).gz)
+endef
+
+define Image/Build/Edimax
+       $(call Image/Build/Loader,$(2),gz,0x80500000,0x6D8,y,$(2))
+       $(call Image/Build/TRXNoloader,$(call imgname,$(1),$(2)).trx,$(1))
+       $(STAGING_DIR_HOST)/bin/mkcsysimg -B $(2) -d -w \
+               -r $(KDIR)/loader-$(2).gz \
+               -x $(call imgname,$(1),$(2)).trx \
+               $(call imgname,$(1),$(2)).bin
+endef
+
+define Image/Build/Infineon
+       $(call Image/Build/Loader,$(2),gz,0x80500000,0x6D8,y,$(2))
+       $(call Image/Build/TRXNoloader,$(call imgname,$(1),$(2)).trx,$(1))
+       dd if=$(KDIR)/loader-$(2).gz of=$(call imgname,$(1),$(2)).img bs=64k conv=sync
+       cat $(call imgname,$(1),$(2)).trx >> $(call imgname,$(1),$(2)).img
+endef
+
+define Image/Build/MyLoader
+       $(call Image/Build/Loader,$(2),gz,0x80500000,0)
+       $(call Image/Build/TRXNoloader,$(call imgname,$(1),$(2)).trx,$(1))
+       $(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) \
+               -p0x20000:0x10000:ahp:0x80001000 \
+               -p0x30000:0 \
+               -b0x20000:0x10000:h:$(KDIR)/loader-$(2).gz \
+               -b0x30000:0::$(call imgname,$(1),$(2)).trx \
+               $(call imgname,$(1),$(2)).bin
+endef
+
+#
+# Cellvision CAS-771
+#
+define Image/Build/Board/CAS-771/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,cas-771,gz)
+endef
+
+#
+# Cellvision CAS-771W
+#
+define Image/Build/Board/CAS-771W/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,cas-771w,gz)
+endef
+
+#
+# Compex NP27G
+#
+define Image/Build/Board/NP27G
+       $(call Image/Build/MyLoader,$(1),np27g)
+endef
+
+define Image/Build/Board/NP27G/squashfs
+       $(call Image/Build/Board/NP27G,squashfs)
+endef
+
+define Image/Build/Board/NP27G/jffs2-64k
+       $(call Image/Build/Board/NP27G,jffs2-64k)
+endef
+
+define Image/Build/Board/NP27G/Initramfs
+       $(call Image/Build/LZMAKernel/Generic,np27g,bin)
+endef
+
+#
+# Compex NP28G
+#
+define Image/Build/Board/NP28G
+       $(call Image/Build/MyLoader,$(1),np28g)
+endef
+
+define Image/Build/Board/NP28G/squashfs
+       $(call Image/Build/Board/NP28G,squashfs)
+endef
+
+define Image/Build/Board/NP28G/jffs2-64k
+       $(call Image/Build/Board/NP28G,jffs2-64k)
+endef
+
+define Image/Build/Board/NP28G/Initramfs
+       $(call Image/Build/LZMAKernel/Generic,np28g,bin)
+endef
+
+#
+# Compex WP54G
+#
+define Image/Build/Board/WP54G
+       $(call Image/Build/MyLoader,$(1),wp54g)
+endef
+
+define Image/Build/Board/WP54G/squashfs
+       $(call Image/Build/Board/WP54G,squashfs)
+endef
+
+define Image/Build/Board/WP54G/jffs2-64k
+       $(call Image/Build/Board/WP54G,jffs2-64k)
+endef
+
+define Image/Build/Board/WP54G/Initramfs
+       $(call Image/Build/LZMAKernel/Generic,wp54g,bin)
+endef
+
+#
+# Compex WP54AG
+#
+define Image/Build/Board/WP54AG
+       $(call Image/Build/MyLoader,$(1),wp54ag)
+endef
+
+define Image/Build/Board/WP54AG/squashfs
+       $(call Image/Build/Board/WP54AG,squashfs)
+endef
+
+define Image/Build/Board/WP54AG/jffs2-64k
+       $(call Image/Build/Board/WP54AG,jffs2-64k)
+endef
+
+define Image/Build/Board/WP54AG/Initramfs
+       $(call Image/Build/LZMAKernel/Generic,wp54ag,bin)
+endef
+
+#
+# Compex WPP54G
+#
+define Image/Build/Board/WPP54G
+       $(call Image/Build/MyLoader,$(1),wpp54g)
+endef
+
+define Image/Build/Board/WPP54G/squashfs
+       $(call Image/Build/Board/WPP54G,squashfs)
+endef
+
+define Image/Build/Board/WPP54G/jffs2-64k
+       $(call Image/Build/Board/WPP54G,jffs2-64k)
+endef
+
+define Image/Build/Board/WPP54G/Initramfs
+       $(call Image/Build/LZMAKernel/Generic,wpp54g,bin)
+endef
+
+#
+# Compex WPP54AG
+#
+define Image/Build/Board/WPP54AG
+       $(call Image/Build/MyLoader,$(1),wpp54ag)
+endef
+
+define Image/Build/Board/WPP54AG/squashfs
+       $(call Image/Build/Board/WPP54AG,squashfs)
+endef
+
+define Image/Build/Board/WPP54AG/jffs2-64k
+       $(call Image/Build/Board/WPP54AG,jffs2-64k)
+endef
+
+define Image/Build/Board/WPP54AG/Initramfs
+       $(call Image/Build/LZMAKernel/Generic,wpp54ag,bin)
+endef
+
+#
+# Compex WP54G-WRT
+#
+define Image/Build/Board/WP54G-WRT
+       $(call Image/Build/Compex,$(1),wp54g-wrt)
+endef
+
+define Image/Build/Board/WP54G-WRT/squashfs
+       $(call Image/Build/Board/WP54G-WRT,squashfs)
+endef
+
+define Image/Build/Board/WP54G-WRT/jffs2-64k
+       $(call Image/Build/Board/WP54G-WRT,jffs2-64k)
+endef
+
+define Image/Build/Board/WP54G-WRT/Initramfs
+       $(call Image/Build/LZMAKernel/KArgs,wp54g-wrt,bin)
+endef
+
+#
+# Edimax BR-6104K/KP
+#
+define Image/Build/Board/BR-6104K
+       $(call Image/Build/Edimax,$(1),br-6104k)
+endef
+
+define Image/Build/Board/BR-6104K/squashfs
+       $(call Image/Build/BR-6104K,squashfs)
+endef
+
+define Image/Build/Board/BR-6104K/jffs2-64k
+       $(call Image/Build/BR-6104K,jffs2-64k)
+endef
+
+define Image/Build/Board/BR-6104K/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,br-6104k,gz)
+endef
+
+#
+# Infineon EASY 83000
+#
+define Image/Build/Board/EASY-83000
+       $(call Image/Build/Infineon,$(1),easy-83000)
+endef
+
+define Image/Build/Board/EASY-83000/squashfs
+       $(call Image/Build/Board/EASY-83000,squashfs)
+endef
+
+define Image/Build/Board/EASY-83000/jffs2-64k
+       $(call Image/Build/Board/EASY-83000,jffs2-64k)
+endef
+
+define Image/Build/Board/EASY-83000/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,easy-83000,gz)
+endef
+
+#
+# Mikrotik RB-1xx
+#
+define Image/Build/Board/RB1xx/Initramfs
+       $(CP) $(KDIR)/vmlinux.elf $(IMGNAME)-ramfs-rb1xx.elf
+endef
+
+#
+# Groups
+#
+define Image/Build/Group/Cellvision
+       $(call Image/Build/Board/CAS-771/$(1))
+       $(call Image/Build/Board/CAS-771W/$(1))
+endef
+
+define Image/Build/Group/WP54G
+       $(call Image/Build/Board/WP54G/$(1))
+       $(call Image/Build/Board/WP54AG/$(1))
+       $(call Image/Build/Board/WPP54G/$(1))
+       $(call Image/Build/Board/WPP54AG/$(1))
+       $(call Image/Build/Board/WP54G-WRT/$(1))
+endef
+
+define Image/Build/Group/Compex
+       $(call Image/Build/Board/NP27G/$(1))
+       $(call Image/Build/Board/NP28G/$(1))
+
+       $(call Image/Build/Group/WP54G,$(1))
+endef
+
+define Image/Build/Group/Edimax
+       $(call Image/Build/Board/BR-6104K/$(1))
+endef
+
+define Image/Build/Group/Infineon
+       $(call Image/Build/Board/EASY-83000/$(1))
+endef
+
+define Image/Build/Group/All
+       $(call Image/Build/Group/Cellvision,$(1))
+       $(call Image/Build/Group/Compex,$(1))
+       $(call Image/Build/Group/Edimax,$(1))
+       $(call Image/Build/Group/Cellvision,$(1))
+       $(call Image/Build/Group/Infineon,$(1))
+endef
+
+#
+# Profiles
+#
+define Image/Build/Profile/Generic
+       $(call Image/Build/Group/All,$(1))
+endef
+
+define Image/Build/Profile/Atheros
+       $(call Image/Build/AllBoards,$(1))
+endef
+
+define Image/Build/Profile/Texas
+       $(call Image/Build/AllBoards,$(1))
+endef
+
+define Image/Build/Profile/Ralink
+       $(call Image/Build/AllBoards,$(1))
+endef
+
+define Image/Build/Profile/WP54G
+       $(call Image/Build/Group/WP54G,$(1))
+endef
+
+define Image/Build/Profile/NP27G
+       $(call Image/Build/Group/NP27G,$(1))
+endef
+
+define Image/Build/Profile/NP28G
+       $(call Image/Build/Group/NP28G,$(1))
+endef
+
+define Image/Build/Profile/CAS-771
+       $(call Image/Build/Board/CAS-771,$(1))
+endef
+
+define Image/Build/Profile/CAS-771W
+       $(call Image/Build/Board/CAS-771W,$(1))
+endef
+
+define Image/Build/Profile/RouterBoard
+       $(call Image/Build/Board/RB1xx/$(1))
+endef
+
+ifeq ($(PROFILE),Routerboard)
+  define Image/cmdline/yaffs2
+       root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit
+  endef
+
+  define Image/BuildKernel/RouterBoard
+       $(CP) $(KDIR)/vmlinux.elf $(IMGNAME)-rb1xx-vmlinux
+       $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux.elf \
+               '$(strip $(call Image/cmdline/yaffs2))'
+  endef
+
+  ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+    define Image/BuildKernel
+       $(call Image/BuildKernel/RouterBoard)
+    endef
+  endif
+
+endif
+
diff --git a/target/linux/adm5120/router_be/image/Makefile b/target/linux/adm5120/router_be/image/Makefile
deleted file mode 100644 (file)
index f47b3ab..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-IMGNAME = $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)
-LOADER_MAKE = $(NO_TRACE_MAKE) -C lzma-loader KDIR=$(KDIR)
-
-define Image/Build/Loader
-       $(LOADER_MAKE) LOADER=loader-$(1).$(2) LOADER_DATA="" \
-               LZMA_TEXT_START=$(3) LZMA_STARTUP_ORG=$(4) \
-               CONFIG_PASS_KARGS=$(5) CONFIG_BOARD=$(6) \
-               compile loader.$(2)
-endef
-
-define Build/Clean
-       $(LOADER_MAKE) clean
-endef
-
-define Image/Prepare
-       cat $(KDIR)/vmlinux | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
-endef
-
-define trxalign/jffs2-128k
--a 0x20000
-endef
-define trxalign/jffs2-64k
--a 0x10000
-endef
-define trxalign/squashfs
--a 1024
-endef
-
-define Image/Build/TRX
-       $(STAGING_DIR_HOST)/bin/trx -o $(1) -f $(3) -f $(KDIR)/vmlinux.lzma \
-               $(call trxalign/$(2)) -f $(KDIR)/root.$(2)
-endef
-
-define Image/Build/TRXNoloader
-       $(STAGING_DIR_HOST)/bin/trx -o $(1) -f $(KDIR)/vmlinux.lzma \
-               $(call trxalign/$(2)) -f $(KDIR)/root.$(2)
-endef
-
-define Image/Build/ZyXEL
-       $(call Image/Build/Loader,loader-$(2),gz,0x80500000,0)
-       $(call Image/Build/TRXNoloader,$(IMGNAME)-$(3)-$(2).trx,$(1))
-       #TODO: firmware generation tool needed
-endef
-
-define Image/Build
-       #FIXME: No firmware images yet
-endef
-
-define Image/Build/LZMAKernel
-       $(LOADER_MAKE) TARGET_DIR=$(BIN_DIR) \
-               LOADER=openwrt-$(BOARD)-$(KERNEL)-ramfs-lzma-$(1).$(2) \
-               LOADER_DATA=$(KDIR)/vmlinux.lzma \
-               LZMA_TEXT_START=$(3) LZMA_STARTUP_ORG=$(4) \
-               CONFIG_PASS_KARGS=$(5) CONFIG_BOARD=$(6) \
-               compile loader.$(2)
-endef
-
-define Image/Build/LZMAKernel/ZyXEL
-       $(call Image/Build/LZMAKernel,$(1),$(2),0x80500000,0,y,$(1))
-endef
-
-define Image/Build/Initramfs
-# this line is here intentionally
-ifeq ($(CONFIG_DEVEL),y)
-       $(call Image/Build/LZMAKernel/ZyXEL,p-334wt,bin)
-       $(call Image/Build/LZMAKernel/ZyXEL,p-335,bin)
-endif
-endef
-
-$(eval $(call BuildImage))
-
diff --git a/target/linux/adm5120/router_be/image/lzma-loader b/target/linux/adm5120/router_be/image/lzma-loader
deleted file mode 120000 (symlink)
index f472e6b..0000000
+++ /dev/null
@@ -1 +0,0 @@
-../../adm5120/image/lzma-loader/
\ No newline at end of file
diff --git a/target/linux/adm5120/router_be/profiles/010-Generic.mk b/target/linux/adm5120/router_be/profiles/010-Generic.mk
new file mode 100644 (file)
index 0000000..1d47731
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+       NAME:=Generic (default)
+       PACKAGES:=
+endef
+
+define Profile/Generic/Description
+       Generic package set compatible with most boards.
+endef
+$(eval $(call Profile,Generic))
+
diff --git a/target/linux/adm5120/router_be/profiles/090-Zyxel.mk b/target/linux/adm5120/router_be/profiles/090-Zyxel.mk
deleted file mode 100644 (file)
index b0741e8..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Zyxel
-  NAME:=Zyxel Prestige P-334/335/335-WT (default)
-  PACKAGES:=kmod-acx kmod-usb-core kmod-usb-adm5120
-endef
-
-define Profile/Zyxel/Description
-       Package set compatible with the Zyxel prestige P-334/335/335-WT boards
-endef
-$(eval $(call Profile,Zyxel))
-
index 727a0c06489094b8c20f8fe5f02cca0f7f6ce81d..af17042b04887cd0ba6ca335a741a2b185d88658 100644 (file)
@@ -1,13 +1,13 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 define Profile/Texas
-  NAME:=Texas Instruments WiFi
-  PACKAGES:=kmod-acx
+       NAME:=Texas Instruments WiFi
+       PACKAGES:=kmod-acx
 endef
 
 define Profile/Texas/Description
index cc4a7044954fcdbfdc1279197fe935e7f7e049cf..fa95bf3b10c3df95ebab77aee9f6242e539882e2 100644 (file)
@@ -1,17 +1,17 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 define Profile/Atheros
-  NAME:=Atheros WiFi
-  PACKAGES:=kmod-madwifi
+       NAME:=Atheros WiFi
+       PACKAGES:=kmod-madwifi
 endef
 
 define Profile/Atheros/Description
-       Package set compatible with hardware using Atheros WiFi cards
+       Package set compatible with hardware using Atheros WiFi cards.
 endef
 $(eval $(call Profile,Atheros))
 
diff --git a/target/linux/adm5120/router_be/profiles/110-None.mk b/target/linux/adm5120/router_be/profiles/110-None.mk
deleted file mode 100644 (file)
index 2fcfacd..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/None
-  NAME:=No WiFi
-  PACKAGES:=
-endef
-
-define Profile/None/Description
-       Package set without WiFi support
-endef
-$(eval $(call Profile,None))
-
diff --git a/target/linux/adm5120/router_be/profiles/200-ZyXEL.mk b/target/linux/adm5120/router_be/profiles/200-ZyXEL.mk
new file mode 100644 (file)
index 0000000..0af5613
--- /dev/null
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/P-334WT
+       NAME:=ZyXEL Prestige P-334WT
+       PACKAGES:=kmod-acx
+endef
+
+define Profile/P-334WT/Description
+       Package set optimized for the ZyXEL Prestige P-334WT board.
+endef
+
+define Profile/P-335WT
+       NAME:=ZyXEL Prestige P-335WT
+       PACKAGES:=kmod-acx kmod-usb-core kmod-usb-adm5120
+endef
+
+define Profile/P-335WT/Description
+       Package set optimized for the ZyXEL Prestige P-335WT board.
+endef
+
+$(eval $(call Profile,P-334WT))
+$(eval $(call Profile,P-335WT))
diff --git a/target/linux/adm5120/router_le/profiles/010-Generic.mk b/target/linux/adm5120/router_le/profiles/010-Generic.mk
new file mode 100644 (file)
index 0000000..1d47731
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+       NAME:=Generic (default)
+       PACKAGES:=
+endef
+
+define Profile/Generic/Description
+       Generic package set compatible with most boards.
+endef
+$(eval $(call Profile,Generic))
+
index 029586848f1344e592f35d8d3484c232f2f92806..8ad626c0cf000c6f81926488e239704d965617d9 100644 (file)
@@ -1,17 +1,17 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 define Profile/Atheros
-  NAME:=Atheros WiFi (default)
-  PACKAGES:=kmod-madwifi
+       NAME:=Atheros WiFi
+       PACKAGES:=kmod-madwifi
 endef
 
 define Profile/Atheros/Description
-       Package set compatible with hardware using Atheros WiFi cards
+       Package set compatible with hardware using Atheros WiFi cards.
 endef
-$(eval $(call Profile,Atheros))
 
+$(eval $(call Profile,Atheros))
index 727a0c06489094b8c20f8fe5f02cca0f7f6ce81d..dff3baffc00b26f573f9b0a30ea8a0f044363d39 100644 (file)
@@ -1,17 +1,17 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 define Profile/Texas
-  NAME:=Texas Instruments WiFi
-  PACKAGES:=kmod-acx
+       NAME:=Texas Instruments WiFi
+       PACKAGES:=kmod-acx
 endef
 
 define Profile/Texas/Description
-       Package set compatible with hardware using Texas Instruments WiFi cards
+       Package set compatible with hardware using Texas Instruments WiFi cards.
 endef
 $(eval $(call Profile,Texas))
 
index d30ee739441f1197ae5f2bc500d909f19bf568a0..f0a457d923714a68c4011c48c1f9bd136ffedd85 100644 (file)
@@ -6,11 +6,11 @@
 #
 
 define Profile/Ralink
-  NAME:=Ralink WiFi
-  PACKAGES:=kmod-rt2500
+       NAME:=Ralink WiFi
+       PACKAGES:=kmod-rt2500
 endef
 
 define Profile/Ralink/Description
-        Package set compatible with hardware using Ralink WiFi cards
+       Package set compatible with hardware using Ralink WiFi cards.
 endef
 $(eval $(call Profile,Ralink))
diff --git a/target/linux/adm5120/router_le/profiles/200-None.mk b/target/linux/adm5120/router_le/profiles/200-None.mk
deleted file mode 100644 (file)
index 2fcfacd..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/None
-  NAME:=No WiFi
-  PACKAGES:=
-endef
-
-define Profile/None/Description
-       Package set without WiFi support
-endef
-$(eval $(call Profile,None))
-
index 6912f13e3e259459a94e69852223cdd8f05e0045..38f69354435ade7f8623df20070dfb1b1484b345 100644 (file)
@@ -5,12 +5,23 @@
 # See /LICENSE for more information.
 #
 
-define Profile/Cellvision
-  NAME:=Cellvision CAS-63x/77x cameras
-  PACKAGES:=kmod-rt2500 kmod-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
+define Profile/CAS-771
+       NAME:=Cellvision CAS-771 IP camera
+       PACKAGES:=kmod-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
 endef
 
-define Profile/Cellvision/Description
-  Package set compatible with the Cellvision CAS devices, including Wireless variants.
+define Profile/CAS-771/Description
+       Package set optimized for the Cellvision CAS-771 device.
 endef
-$(eval $(call Profile,Cellvision))
+
+define Profile/CAS-771W
+       NAME:=Cellvision CAS-771W IP camera
+       PACKAGES:=kmod-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500
+endef
+
+define Profile/CAS-771W/Description
+       Package set optimized for the Cellvision CAS-771W device.
+endef
+
+$(eval $(call Profile,CAS-771))
+$(eval $(call Profile,CAS-771W))
diff --git a/target/linux/adm5120/router_le/profiles/Compex.mk b/target/linux/adm5120/router_le/profiles/Compex.mk
new file mode 100644 (file)
index 0000000..fdfa83a
--- /dev/null
@@ -0,0 +1,37 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NP27G
+       NAME:=Compex NP27G
+       PACKAGES:=kmod-madwifi kmod-usb-core kmod-usb-adm5120
+endef
+
+define Profile/NP27G/Description
+       Package set optimized for the Compex NP27G.
+endef
+
+define Profile/NP28G
+       NAME:=Compex NP28G
+       PACKAGES:=kmod-madwifi
+endef
+
+define Profile/NP28G/Description
+       Package set optimized for the Compex NP28G.
+endef
+
+define Profile/WP54G
+       NAME:=Compex WP54G family
+       PACKAGES:=kmod-madwifi
+endef
+
+define Profile/WP54G/Description
+       Package set optimized for the Compex WP54G family.
+endef
+
+$(eval $(call Profile,NP27G))
+$(eval $(call Profile,NP28G))
+$(eval $(call Profile,WP54G))
index 9dd3de09735858fdfc322ab866a6a5d7688f8c7f..76e4ad87fb00277439c4537a4fd5475f964e062a 100644 (file)
@@ -1,17 +1,18 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 define Profile/RouterBoard
-  NAME:=RouterBoard RB1xx
-  PACKAGES:=kmod-madwifi
+       NAME:=Mikrotik RouterBoard 1xx family
+       PACKAGES:=kmod-madwifi
 endef
 
 define Profile/RouterBoard/Description
-  Package set compatible with the RouterBoard RB1xx devices. Contains RouterOS to OpenWrt\\\
-  installation scripts.
+       Package set compatible with the RouterBoard RB1xx devices. Contains RouterOS to OpenWrt\\\
+       installation scripts.
 endef
+
 $(eval $(call Profile,RouterBoard))