samba36: fix segmentation fault when trying to add non-existent users
authorJonas Gorski <jogo@openwrt.org>
Sat, 16 Feb 2013 11:39:42 +0000 (11:39 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sat, 16 Feb 2013 11:39:42 +0000 (11:39 +0000)
Based on a patch from НКВД. Closes #12962.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 35610

package/network/services/samba36/Makefile
package/network/services/samba36/patches/111-owrt_smbpasswd.patch

index f71d9092d9e3b586d6908c802c03ae9f8298c267..2842c982bf547e6420e413ca6791943497fa4419 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
 PKG_VERSION:=3.6.11
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
        http://ftp.samba.org/pub/samba/old-versions
index 25a9cb9bf05973ccd201b4dc89c8d44b50634d68..7d852c4c619ecc3e11a23058b5d681c6082e77dc 100644 (file)
 +      }
 +
 +      if (!find_passwd_line(fp, user, &p1)) {
-+              printf("User %s not found or invalid in /etc/passwd\n");
++              printf("User %s not found or invalid in /etc/passwd\n", user);
 +              goto out;
 +      }
 +