Port elhttp to -ng
authorFlorian Fainelli <florian@openwrt.org>
Tue, 1 Aug 2006 17:12:28 +0000 (17:12 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 1 Aug 2006 17:12:28 +0000 (17:12 +0000)
SVN-Revision: 4375

net/elhttp/Makefile [new file with mode: 0644]
net/elhttp/patches/01-cross-compile.patch [new file with mode: 0644]

diff --git a/net/elhttp/Makefile b/net/elhttp/Makefile
new file mode 100644 (file)
index 0000000..8c74f94
--- /dev/null
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=elhttp
+PKG_VERSION:=0.22
+PKG_RELEASE:=1
+PKG_MD5SUM:=b52f68c47f709e9fc9429250eb8f954c
+
+PKG_SOURCE_URL:=http://phadej.daug.net/files/ \
+       http://www.cr0.net:8040/code/network/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/elhttp
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=The extra-light http proxy server
+  DESCRIPTION:=The extra-light http proxy server. Features: keep-alive\\\
+       connections, http connect method, SSL/TLS support, ACLs\\\
+       and client requests logging.\\\
+  URL:=http://www.cr0.net:8040/code/network/
+endef
+
+
+define Build/Compile
+       mkdir -p $(PKG_INSTALL_DIR)/usr/sbin
+       $(MAKE) CC=$(TARGET_CC) CROSS=$(TARGET_CROSS) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/elhttp/install
+       mkdir -p $(1)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/ 
+endef
+
+$(eval $(call BuildPackage,elhttp))
diff --git a/net/elhttp/patches/01-cross-compile.patch b/net/elhttp/patches/01-cross-compile.patch
new file mode 100644 (file)
index 0000000..f1aba59
--- /dev/null
@@ -0,0 +1,21 @@
+--- elhttp-0.22.orig/Makefile  2004-06-18 15:32:17.000000000 +0200
++++ elhttp-0.22/Makefile       2006-02-13 23:11:35.000000000 +0100
+@@ -1,13 +1,7 @@
+-
++all: linux
+ linux:
+-      gcc -O -W -Wall -o elhttp elhttp.c
+-      strip elhttp
+-
+-sunos:
+-      gcc -O -W -Wall -o elhttp elhttp.c -lsocket -lnsl
+-      strip elhttp
+-
+-unix:
+-      cc -O -o elhttp elhttp.c
+-      strip elhttp
++      $(CC) -O -W -Wall -o elhttp elhttp.c
++install:
++      install -d -m0755 $(DESTDIR)/usr/sbin
++      install -m0755 elhttp $(DESTDIR)/usr/sbin/