kernel: fix compile error with gcc-4.8 and kernel 3.3
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 1 May 2014 13:07:44 +0000 (13:07 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 1 May 2014 13:07:44 +0000 (13:07 +0000)
With gcc-4.8 I get a compile error with kernel 3.3.
This patch fixes this problem by backporting a patch from a more recent kernel version.

  CC      arch/mips/mm/page.o
arch/mips/mm/page.c:89:6: error: 'clear_page' alias in between function and variable is not supported
 void clear_page(void *page) __attribute__((alias("clear_page_array")));
      ^
arch/mips/mm/page.c:84:12: error: 'clear_page_array' aliased declaration [-Werror]
 static u32 clear_page_array[0x120 / 4];
            ^
arch/mips/mm/page.c:108:6: error: 'copy_page' alias in between function and variable is not supported
 void copy_page(void *to, void *from) __attribute__((alias("copy_page_array")));
      ^
arch/mips/mm/page.c:102:12: error: 'copy_page_array' aliased declaration [-Werror]
 static u32 copy_page_array[0x540 / 4];
            ^
arch/mips/mm/page.c:108:6: error: 'copy_page' alias in between function and variable is not supported
 void copy_page(void *to, void *from) __attribute__((alias("copy_page_array")));
      ^
arch/mips/mm/page.c:102:12: error: 'copy_page_array' aliased declaration [-Werror]
 static u32 copy_page_array[0x540 / 4];
            ^
arch/mips/mm/page.c:89:6: error: 'clear_page' alias in between function and variable is not supported
 void clear_page(void *page) __attribute__((alias("clear_page_array")));
      ^
arch/mips/mm/page.c:84:12: error: 'clear_page_array' aliased declaration [-Werror]
 static u32 clear_page_array[0x120 / 4];
            ^
cc1: all warnings being treated as errors
make[7]: *** [arch/mips/mm/page.o] Error 1

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 40619

target/linux/generic/patches-3.3/001-ARM-7668-1-fix-memset-related-crashes-caused-by-rece.patch
target/linux/generic/patches-3.3/002-ARM-7668-1-fix-memset-related-crashes-caused-by-rece.patch
target/linux/generic/patches-3.3/003-MIPS-Refactor-clear_page-and-copy_page-functions.patch [new file with mode: 0644]
target/linux/generic/patches-3.3/a02-swconfig-revert-portid-snd_portid-usage.patch

index 03bc2e4d1ae83dd9b5b9232cbc1e7691ef3abbed..07061b0bbd556802700925ce96c4886193dd37cc 100644 (file)
@@ -96,8 +96,6 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
  arch/arm/lib/memset.S | 85 ++++++++++++++++++++++++++-------------------------
  1 file changed, 44 insertions(+), 41 deletions(-)
 
-diff --git a/arch/arm/lib/memset.S b/arch/arm/lib/memset.S
-index 650d5923ab83..d912e7397ecc 100644
 --- a/arch/arm/lib/memset.S
 +++ b/arch/arm/lib/memset.S
 @@ -19,9 +19,9 @@
@@ -250,6 +248,3 @@ index 650d5923ab83..d912e7397ecc 100644
 +      strneb  r1, [ip], #1
        mov     pc, lr
  ENDPROC(memset)
--- 
-1.8.3.2
-
index e3a0d7baeefe9e320504f423f5af2e150714b111..266e507e69f9ab8bfbdd726bf6b27b3cd934b83e 100644 (file)
@@ -24,8 +24,6 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
  arch/arm/lib/memset.S | 33 +++++++++++++--------------------
  1 file changed, 13 insertions(+), 20 deletions(-)
 
-diff --git a/arch/arm/lib/memset.S b/arch/arm/lib/memset.S
-index d912e7397ecc..94b0650ea98f 100644
 --- a/arch/arm/lib/memset.S
 +++ b/arch/arm/lib/memset.S
 @@ -14,31 +14,15 @@
@@ -78,6 +76,3 @@ index d912e7397ecc..94b0650ea98f 100644
 +      add     r2, r2, r3              @ 1 (r2 = r2 - (4 - r3))
 +      b       1b
  ENDPROC(memset)
--- 
-1.8.3.2
-
diff --git a/target/linux/generic/patches-3.3/003-MIPS-Refactor-clear_page-and-copy_page-functions.patch b/target/linux/generic/patches-3.3/003-MIPS-Refactor-clear_page-and-copy_page-functions.patch
new file mode 100644 (file)
index 0000000..da85701
--- /dev/null
@@ -0,0 +1,249 @@
+From c022630633624a75b3b58f43dd3c6cc896a56cff Mon Sep 17 00:00:00 2001
+From: "Steven J. Hill" <sjhill@mips.com>
+Date: Fri, 6 Jul 2012 21:56:01 +0200
+Subject: [PATCH] MIPS: Refactor 'clear_page' and 'copy_page' functions.
+
+Remove usage of the '__attribute__((alias("...")))' hack that aliased
+to integer arrays containing micro-assembled instructions. This hack
+breaks when building a microMIPS kernel. It also makes the code much
+easier to understand.
+
+[ralf@linux-mips.org: Added back export of the clear_page and copy_page
+symbols so certain modules will work again.  Also fixed build with
+CONFIG_SIBYTE_DMA_PAGEOPS enabled.]
+
+Signed-off-by: Steven J. Hill <sjhill@mips.com>
+Cc: linux-mips@linux-mips.org
+Patchwork: https://patchwork.linux-mips.org/patch/3866/
+Acked-by: David Daney <david.daney@cavium.com>
+Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
+---
+ arch/mips/kernel/mips_ksyms.c |    8 ++++-
+ arch/mips/mm/Makefile         |    4 +--
+ arch/mips/mm/page-funcs.S     |   50 ++++++++++++++++++++++++++++++
+ arch/mips/mm/page.c           |   67 +++++++++++------------------------------
+ 4 files changed, 77 insertions(+), 52 deletions(-)
+ create mode 100644 arch/mips/mm/page-funcs.S
+
+--- a/arch/mips/kernel/mips_ksyms.c
++++ b/arch/mips/kernel/mips_ksyms.c
+@@ -5,7 +5,7 @@
+  * License.  See the file "COPYING" in the main directory of this archive
+  * for more details.
+  *
+- * Copyright (C) 1996, 97, 98, 99, 2000, 01, 03, 04, 05 by Ralf Baechle
++ * Copyright (C) 1996, 97, 98, 99, 2000, 01, 03, 04, 05, 12 by Ralf Baechle
+  * Copyright (C) 1999, 2000, 01 Silicon Graphics, Inc.
+  */
+ #include <linux/interrupt.h>
+@@ -35,6 +35,12 @@ EXPORT_SYMBOL(memmove);
+ EXPORT_SYMBOL(kernel_thread);
+ /*
++ * Functions that operate on entire pages.  Mostly used by memory management.
++ */
++EXPORT_SYMBOL(clear_page);
++EXPORT_SYMBOL(copy_page);
++
++/*
+  * Userspace access stuff.
+  */
+ EXPORT_SYMBOL(__copy_user);
+--- a/arch/mips/mm/Makefile
++++ b/arch/mips/mm/Makefile
+@@ -3,8 +3,8 @@
+ #
+ obj-y                         += cache.o dma-default.o extable.o fault.o \
+-                                 gup.o init.o mmap.o page.o tlbex.o \
+-                                 tlbex-fault.o uasm.o
++                                 gup.o init.o mmap.o page.o page-funcs.o \
++                                 tlbex.o tlbex-fault.o uasm.o
+ obj-$(CONFIG_32BIT)           += ioremap.o pgtable-32.o
+ obj-$(CONFIG_64BIT)           += pgtable-64.o
+--- /dev/null
++++ b/arch/mips/mm/page-funcs.S
+@@ -0,0 +1,50 @@
++/*
++ * This file is subject to the terms and conditions of the GNU General Public
++ * License.  See the file "COPYING" in the main directory of this archive
++ * for more details.
++ *
++ * Micro-assembler generated clear_page/copy_page functions.
++ *
++ * Copyright (C) 2012  MIPS Technologies, Inc.
++ * Copyright (C) 2012  Ralf Baechle <ralf@linux-mips.org>
++ */
++#include <asm/asm.h>
++#include <asm/regdef.h>
++
++#ifdef CONFIG_SIBYTE_DMA_PAGEOPS
++#define cpu_clear_page_function_name  clear_page_cpu
++#define cpu_copy_page_function_name   copy_page_cpu
++#else
++#define cpu_clear_page_function_name  clear_page
++#define cpu_copy_page_function_name   copy_page
++#endif
++
++/*
++ * Maximum sizes:
++ *
++ * R4000 128 bytes S-cache:           0x058 bytes
++ * R4600 v1.7:                                0x05c bytes
++ * R4600 v2.0:                                0x060 bytes
++ * With prefetching, 16 word strides  0x120 bytes
++ */
++EXPORT(__clear_page_start)
++LEAF(cpu_clear_page_function_name)
++1:    j       1b              /* Dummy, will be replaced. */
++      .space 288
++END(cpu_clear_page_function_name)
++EXPORT(__clear_page_end)
++
++/*
++ * Maximum sizes:
++ *
++ * R4000 128 bytes S-cache:           0x11c bytes
++ * R4600 v1.7:                                0x080 bytes
++ * R4600 v2.0:                                0x07c bytes
++ * With prefetching, 16 word strides  0x540 bytes
++ */
++EXPORT(__copy_page_start)
++LEAF(cpu_copy_page_function_name)
++1:    j       1b              /* Dummy, will be replaced. */
++      .space 1344
++END(cpu_copy_page_function_name)
++EXPORT(__copy_page_end)
+--- a/arch/mips/mm/page.c
++++ b/arch/mips/mm/page.c
+@@ -6,6 +6,7 @@
+  * Copyright (C) 2003, 04, 05 Ralf Baechle (ralf@linux-mips.org)
+  * Copyright (C) 2007  Maciej W. Rozycki
+  * Copyright (C) 2008  Thiemo Seufer
++ * Copyright (C) 2012  MIPS Technologies, Inc.
+  */
+ #include <linux/init.h>
+ #include <linux/kernel.h>
+@@ -72,45 +73,6 @@ static struct uasm_reloc __cpuinitdata r
+ #define cpu_is_r4600_v1_x()   ((read_c0_prid() & 0xfffffff0) == 0x00002010)
+ #define cpu_is_r4600_v2_x()   ((read_c0_prid() & 0xfffffff0) == 0x00002020)
+-/*
+- * Maximum sizes:
+- *
+- * R4000 128 bytes S-cache:           0x058 bytes
+- * R4600 v1.7:                                0x05c bytes
+- * R4600 v2.0:                                0x060 bytes
+- * With prefetching, 16 word strides  0x120 bytes
+- */
+-
+-static u32 clear_page_array[0x120 / 4];
+-
+-#ifdef CONFIG_SIBYTE_DMA_PAGEOPS
+-void clear_page_cpu(void *page) __attribute__((alias("clear_page_array")));
+-#else
+-void clear_page(void *page) __attribute__((alias("clear_page_array")));
+-#endif
+-
+-EXPORT_SYMBOL(clear_page);
+-
+-/*
+- * Maximum sizes:
+- *
+- * R4000 128 bytes S-cache:           0x11c bytes
+- * R4600 v1.7:                                0x080 bytes
+- * R4600 v2.0:                                0x07c bytes
+- * With prefetching, 16 word strides  0x540 bytes
+- */
+-static u32 copy_page_array[0x540 / 4];
+-
+-#ifdef CONFIG_SIBYTE_DMA_PAGEOPS
+-void
+-copy_page_cpu(void *to, void *from) __attribute__((alias("copy_page_array")));
+-#else
+-void copy_page(void *to, void *from) __attribute__((alias("copy_page_array")));
+-#endif
+-
+-EXPORT_SYMBOL(copy_page);
+-
+-
+ static int pref_bias_clear_store __cpuinitdata;
+ static int pref_bias_copy_load __cpuinitdata;
+ static int pref_bias_copy_store __cpuinitdata;
+@@ -283,10 +245,15 @@ static inline void __cpuinit build_clear
+               }
+ }
++extern u32 __clear_page_start;
++extern u32 __clear_page_end;
++extern u32 __copy_page_start;
++extern u32 __copy_page_end;
++
+ void __cpuinit build_clear_page(void)
+ {
+       int off;
+-      u32 *buf = (u32 *)&clear_page_array;
++      u32 *buf = &__clear_page_start;
+       struct uasm_label *l = labels;
+       struct uasm_reloc *r = relocs;
+       int i;
+@@ -357,17 +324,17 @@ void __cpuinit build_clear_page(void)
+       uasm_i_jr(&buf, RA);
+       uasm_i_nop(&buf);
+-      BUG_ON(buf > clear_page_array + ARRAY_SIZE(clear_page_array));
++      BUG_ON(buf > &__clear_page_end);
+       uasm_resolve_relocs(relocs, labels);
+       pr_debug("Synthesized clear page handler (%u instructions).\n",
+-               (u32)(buf - clear_page_array));
++               (u32)(buf - &__clear_page_start));
+       pr_debug("\t.set push\n");
+       pr_debug("\t.set noreorder\n");
+-      for (i = 0; i < (buf - clear_page_array); i++)
+-              pr_debug("\t.word 0x%08x\n", clear_page_array[i]);
++      for (i = 0; i < (buf - &__clear_page_start); i++)
++              pr_debug("\t.word 0x%08x\n", (&__clear_page_start)[i]);
+       pr_debug("\t.set pop\n");
+ }
+@@ -428,7 +395,7 @@ static inline void build_copy_store_pref
+ void __cpuinit build_copy_page(void)
+ {
+       int off;
+-      u32 *buf = (u32 *)&copy_page_array;
++      u32 *buf = &__copy_page_start;
+       struct uasm_label *l = labels;
+       struct uasm_reloc *r = relocs;
+       int i;
+@@ -596,21 +563,23 @@ void __cpuinit build_copy_page(void)
+       uasm_i_jr(&buf, RA);
+       uasm_i_nop(&buf);
+-      BUG_ON(buf > copy_page_array + ARRAY_SIZE(copy_page_array));
++      BUG_ON(buf > &__copy_page_end);
+       uasm_resolve_relocs(relocs, labels);
+       pr_debug("Synthesized copy page handler (%u instructions).\n",
+-               (u32)(buf - copy_page_array));
++               (u32)(buf - &__copy_page_start));
+       pr_debug("\t.set push\n");
+       pr_debug("\t.set noreorder\n");
+-      for (i = 0; i < (buf - copy_page_array); i++)
+-              pr_debug("\t.word 0x%08x\n", copy_page_array[i]);
++      for (i = 0; i < (buf - &__copy_page_start); i++)
++              pr_debug("\t.word 0x%08x\n", (&__copy_page_start)[i]);
+       pr_debug("\t.set pop\n");
+ }
+ #ifdef CONFIG_SIBYTE_DMA_PAGEOPS
++extern void clear_page_cpu(void *page);
++extern void copy_page_cpu(void *to, void *from);
+ /*
+  * Pad descriptors to cacheline, since each is exclusively owned by a
index 5fca538bea89bae7d69410b719243ed30fe8110d..03f4685ce5fa44dbd48dbd28c76111b2ebc0b935 100644 (file)
@@ -1,7 +1,7 @@
 reverted:
 --- a/drivers/net/phy/swconfig.c
 +++ b/drivers/net/phy/swconfig.c
-@@ -377,7 +377,7 @@ swconfig_dump_attr(struct swconfig_callb
+@@ -378,7 +378,7 @@ swconfig_dump_attr(struct swconfig_callb
        int id = cb->args[0];
        void *hdr;
  
@@ -10,7 +10,7 @@ reverted:
                        NLM_F_MULTI, SWITCH_CMD_NEW_ATTR);
        if (IS_ERR(hdr))
                return -1;
-@@ -799,7 +799,7 @@ swconfig_get_attr(struct sk_buff *skb, s
+@@ -801,7 +801,7 @@ swconfig_get_attr(struct sk_buff *skb, s
        if (!msg)
                goto error;
  
@@ -19,7 +19,7 @@ reverted:
                        0, cmd);
        if (IS_ERR(hdr))
                goto nla_put_failure;
-@@ -902,7 +902,7 @@ static int swconfig_dump_switches(struct
+@@ -906,7 +906,7 @@ static int swconfig_dump_switches(struct
        list_for_each_entry(dev, &swdevs, dev_list) {
                if (++idx <= start)
                        continue;