Add support for bcm96348gw10 (Netgear DG834GT) (#4319)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 7 Dec 2008 20:34:48 +0000 (20:34 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 7 Dec 2008 20:34:48 +0000 (20:34 +0000)
SVN-Revision: 13540

target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
target/linux/brcm63xx/files/drivers/mtd/maps/bcm963xx-flash.c
target/linux/brcm63xx/image/Makefile

index 5623d79025829a70a3b2f3010b36aec6d1122fbe..42e0e9723107246a2d5682f5a72e74796aa42e1f 100644 (file)
@@ -50,6 +50,28 @@ static struct board_info __initdata board_96348r = {
        },
 };
 
+static struct board_info __initdata board_96348gw_10 = { 
+       .name                           = "96348GW-10",
+       .expected_cpu_id                = 0x6348,
+       
+       .has_enet0                      = 1,
+       .has_enet1                      = 1,
+       .has_pci                        = 1, 
+       
+       .enet0 = {
+               .has_phy                = 1,
+               .use_internal_phy       = 1,
+       },
+       .enet1 = {
+               .force_speed_100        = 1,
+               .force_duplex_full      = 1,
+       },
+       
+       .has_ohci0                      = 1,
+       .has_pccard                     = 1,
+       .has_ehci0                      = 1,
+}; 
+
 static struct board_info __initdata board_96348gw_11 = {
        .name                           = "96348GW-11",
        .expected_cpu_id                = 0x6348,
@@ -153,6 +175,7 @@ static const struct board_info __initdata *bcm963xx_boards[] = {
 #ifdef CONFIG_BCM63XX_CPU_6348
        &board_96348r,
        &board_96348gw,
+       &board_96348gw_10,
        &board_96348gw_11,
 #endif
 
index 6f74945e583260a38fb49662bfdacc5b0a6b1da5..6fb0ee1e080eeb9bab06d802b1a796465b4404a7 100644 (file)
@@ -156,13 +156,13 @@ static int bcm963xx_probe(struct platform_device *pdev)
        r = platform_get_resource(pdev, IORESOURCE_MEM, 0); 
        bcm963xx_map.phys = r->start;
        bcm963xx_map.size = (r->end - r->start);
-       bcm963xx_map.virt = ioremap(r->start, r->end - r->start);
+       bcm963xx_map.virt = ioremap(r->start, r->end - r->start + 1);
 
        if (!bcm963xx_map.virt) {
                printk(KERN_ERR PFX "Failed to ioremap\n");
                return -EIO;
        }
-       printk(KERN_INFO PFX "0x%08x at 0x%08x\n", (r->end - r->start) + 1, r->start);
+       printk(KERN_INFO PFX "0x%08x at 0x%08x\n", bcm963xx_map.size, bcm963xx_map.phys);
 
        simple_map_init(&bcm963xx_map);
 
index 516dee0e2ca9f45249ab751ec6edff6834405e3e..ac22fee4a0c8bd331e693a454bf750a68367db3c 100644 (file)
@@ -78,6 +78,8 @@ define Image/Build
        $(call Image/Build/CFE,$(1),96358VW,6358)
        # Comtrend 536
        $(call Image/Build/CFE,$(1),96348GW-11,6348)
+       # DG834G
+       $(call Image/Build/CFE,$(1),96348GW-10,6348)
 endef
 
 $(eval $(call BuildImage))