[kernel] refresh patches
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 14 Jun 2009 09:45:26 +0000 (09:45 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 14 Jun 2009 09:45:26 +0000 (09:45 +0000)
SVN-Revision: 16444

target/linux/generic-2.6/patches-2.6.28/023-mips_delay_gcc4.4.0.patch
target/linux/generic-2.6/patches-2.6.28/202-mips-freestanding.patch
target/linux/generic-2.6/patches-2.6.28/208-rtl8110sb_fix.patch
target/linux/generic-2.6/patches-2.6.28/980-vm_exports.patch
target/linux/generic-2.6/patches-2.6.30/020-mips_multi_machine_support.patch
target/linux/generic-2.6/patches-2.6.30/021-mips_simple_prom_emulator.patch
target/linux/generic-2.6/patches-2.6.30/024-mips_delay.patch

index ed95bcdc1cf7f505bdb0e8de212d9770a0944ff8..fcfa792806698b7fef574c80a25d403e367b9fa0 100644 (file)
@@ -21,11 +21,9 @@ Signed-off-by: Wu Zhangjin <wuzhangjin@gmail.com>
  arch/mips/include/asm/delay.h    |   58 +++++++++++++++++++++++++------------
  3 files changed, 57 insertions(+), 20 deletions(-)
 
  arch/mips/include/asm/delay.h    |   58 +++++++++++++++++++++++++------------
  3 files changed, 57 insertions(+), 20 deletions(-)
 
-diff --git a/arch/mips/Makefile b/arch/mips/Makefile
-index a25c2e5..1ee5504 100644
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -120,7 +120,14 @@ cflags-$(CONFIG_CPU_R4300)        += -march=r4300 -Wa,--trap
+@@ -119,7 +119,14 @@ cflags-$(CONFIG_CPU_R4300)        += -march=r43
  cflags-$(CONFIG_CPU_VR41XX)   += -march=r4100 -Wa,--trap
  cflags-$(CONFIG_CPU_R4X00)    += -march=r4600 -Wa,--trap
  cflags-$(CONFIG_CPU_TX49XX)   += -march=r4600 -Wa,--trap
  cflags-$(CONFIG_CPU_VR41XX)   += -march=r4100 -Wa,--trap
  cflags-$(CONFIG_CPU_R4X00)    += -march=r4600 -Wa,--trap
  cflags-$(CONFIG_CPU_TX49XX)   += -march=r4600 -Wa,--trap
@@ -41,8 +39,6 @@ index a25c2e5..1ee5504 100644
  cflags-$(CONFIG_CPU_MIPS32_R1)        += $(call cc-option,-march=mips32,-mips32 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
                        -Wa,-mips32 -Wa,--trap
  cflags-$(CONFIG_CPU_MIPS32_R2)        += $(call cc-option,-march=mips32r2,-mips32r2 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
  cflags-$(CONFIG_CPU_MIPS32_R1)        += $(call cc-option,-march=mips32,-mips32 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
                        -Wa,-mips32 -Wa,--trap
  cflags-$(CONFIG_CPU_MIPS32_R2)        += $(call cc-option,-march=mips32r2,-mips32r2 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
-diff --git a/arch/mips/include/asm/compiler.h b/arch/mips/include/asm/compiler.h
-index 71f5c5c..95256a8 100644
 --- a/arch/mips/include/asm/compiler.h
 +++ b/arch/mips/include/asm/compiler.h
 @@ -1,5 +1,6 @@
 --- a/arch/mips/include/asm/compiler.h
 +++ b/arch/mips/include/asm/compiler.h
 @@ -1,5 +1,6 @@
@@ -66,8 +62,6 @@ index 71f5c5c..95256a8 100644
 +#endif
 +
  #endif /* _ASM_COMPILER_H */
 +#endif
 +
  #endif /* _ASM_COMPILER_H */
-diff --git a/arch/mips/include/asm/delay.h b/arch/mips/include/asm/delay.h
-index b0bccd2..00d7969 100644
 --- a/arch/mips/include/asm/delay.h
 +++ b/arch/mips/include/asm/delay.h
 @@ -7,6 +7,7 @@
 --- a/arch/mips/include/asm/delay.h
 +++ b/arch/mips/include/asm/delay.h
 @@ -7,6 +7,7 @@
@@ -78,7 +72,7 @@ index b0bccd2..00d7969 100644
   */
  #ifndef _ASM_DELAY_H
  #define _ASM_DELAY_H
   */
  #ifndef _ASM_DELAY_H
  #define _ASM_DELAY_H
-@@ -48,6 +49,43 @@ static inline void __delay(unsigned long loops)
+@@ -48,6 +49,43 @@ static inline void __delay(unsigned long
                : "0" (loops), "r" (1));
  }
  
                : "0" (loops), "r" (1));
  }
  
@@ -122,7 +116,7 @@ index b0bccd2..00d7969 100644
  
  /*
   * Division by multiplication: you don't have to worry about
  
  /*
   * Division by multiplication: you don't have to worry about
-@@ -62,8 +100,6 @@ static inline void __delay(unsigned long loops)
+@@ -62,8 +100,6 @@ static inline void __delay(unsigned long
  
  static inline void __udelay(unsigned long usecs, unsigned long lpj)
  {
  
  static inline void __udelay(unsigned long usecs, unsigned long lpj)
  {
@@ -131,7 +125,7 @@ index b0bccd2..00d7969 100644
        /*
         * The rates of 128 is rounded wrongly by the catchall case
         * for 64-bit.  Excessive precission?  Probably ...
        /*
         * The rates of 128 is rounded wrongly by the catchall case
         * for 64-bit.  Excessive precission?  Probably ...
-@@ -77,23 +113,7 @@ static inline void __udelay(unsigned long usecs, unsigned long lpj)
+@@ -77,23 +113,7 @@ static inline void __udelay(unsigned lon
                                   0x80000000ULL) >> 32);
  #endif
  
                                   0x80000000ULL) >> 32);
  #endif
  
@@ -156,8 +150,3 @@ index b0bccd2..00d7969 100644
  }
  
  #define __udelay_val cpu_data[raw_smp_processor_id()].udelay_val
  }
  
  #define __udelay_val cpu_data[raw_smp_processor_id()].udelay_val
--- 
-1.6.0.4
-
-
-
index 34dd2b3e198cc7460bc1c4b4dc05a9a1a0037f8e..4844893f3bae4237fc9e99c7c10a64117a9dcb9e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -586,6 +586,9 @@ core-$(CONFIG_TOSHIBA_RBTX4927)    += arch/
+@@ -593,6 +593,9 @@ core-$(CONFIG_TOSHIBA_RBTX4927)    += arch/
  core-$(CONFIG_TOSHIBA_RBTX4938) += arch/mips/txx9/rbtx4938/
  core-$(CONFIG_TOSHIBA_RBTX4939) += arch/mips/txx9/rbtx4939/
  
  core-$(CONFIG_TOSHIBA_RBTX4938) += arch/mips/txx9/rbtx4938/
  core-$(CONFIG_TOSHIBA_RBTX4939) += arch/mips/txx9/rbtx4939/
  
index ca25aeda99033f10e81879c8042574ba5164c890..9d9ae5023e144548a7e6a1ed86bb05d925447fde 100644 (file)
@@ -27,7 +27,7 @@
                                  RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
                .napi_event     = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
                .features       = RTL_FEATURE_MSI
                                  RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
                .napi_event     = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
                .features       = RTL_FEATURE_MSI
-@@ -3554,10 +3554,12 @@ static irqreturn_t rtl8169_interrupt(int
+@@ -3555,10 +3555,12 @@ static irqreturn_t rtl8169_interrupt(int
                goto out;
        }
  
                goto out;
        }
  
index 8168742ebafd2a2d3cc46f3642a7633dd66e50ad..023bf295e7a59c8a3339d4047c8237cbb187d3d2 100644 (file)
@@ -67,7 +67,7 @@
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -5015,6 +5015,7 @@ int can_nice(const struct task_struct *p
+@@ -5064,6 +5064,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
                capable(CAP_SYS_NICE));
  }
        return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
                capable(CAP_SYS_NICE));
  }
index 6799fdbb8b3a83abdd2e832ddf58439f322d3f77..57dcc1dc43718a859f107763edef883fef3daead 100644 (file)
  
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
  
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -802,6 +802,9 @@ config MIPS_DISABLE_OBSOLETE_IDE
+@@ -803,6 +803,9 @@ config MIPS_DISABLE_OBSOLETE_IDE
  config SYNC_R4K
        bool
  
  config SYNC_R4K
        bool
  
index 463dbc60f180ecdcfb1e9ad01e1e044f66a491f1..49045fea319e1776c8dad88f5f6b0cde1daaa097 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -804,6 +804,9 @@ config SYNC_R4K
+@@ -805,6 +805,9 @@ config SYNC_R4K
  
  config MIPS_MACHINE
        def_bool n
  
  config MIPS_MACHINE
        def_bool n
index 0d22636ab683abf57b5e48da8bdf5a66aecd4149..128ed54ecb267056f178c5c4d2d03abc47daad91 100644 (file)
@@ -6,8 +6,6 @@ Signed-off-by: Atsushi Nemoto <anemo@mba.ocn.ne.jp>
  arch/mips/lib/delay.c |    4 ++--
  1 files changed, 2 insertions(+), 2 deletions(-)
 
  arch/mips/lib/delay.c |    4 ++--
  1 files changed, 2 insertions(+), 2 deletions(-)
 
-diff --git a/arch/mips/lib/delay.c b/arch/mips/lib/delay.c
-index f69c6b5..6b3b1de 100644
 --- a/arch/mips/lib/delay.c
 +++ b/arch/mips/lib/delay.c
 @@ -43,7 +43,7 @@ void __udelay(unsigned long us)
 --- a/arch/mips/lib/delay.c
 +++ b/arch/mips/lib/delay.c
 @@ -43,7 +43,7 @@ void __udelay(unsigned long us)
@@ -27,6 +25,3 @@ index f69c6b5..6b3b1de 100644
 +      __delay((ns * 0x00000005ull * HZ * lpj) >> 32);
  }
  EXPORT_SYMBOL(__ndelay);
 +      __delay((ns * 0x00000005ull * HZ * lpj) >> 32);
  }
  EXPORT_SYMBOL(__ndelay);
-
-
-