ubox: fix kmod loading for modules with varying dashes & underscores in names (#14182...
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 28 Sep 2013 13:12:42 +0000 (13:12 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 28 Sep 2013 13:12:42 +0000 (13:12 +0000)
Instead of canonicalizing module names in the internal avl tree simpyl use a
custom strcmp() variant for the avl tree key comparisation. The custom comperator
simply treats dashes and underscores the same, so "nls_iso8859-15" is equal to
"nls-iso8859-15".

This allows us to simplify the code considerably and makes manual "modprobe"
invocations more forgiving when looking up the given module name.

SVN-Revision: 38248

package/system/ubox/Makefile

index f96c91bd321fdf6f487ce4b8ba4b9e4f90e0a57f..021746d41bdf22379c58805ed55ab10ac9fd6f93 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ubox
-PKG_VERSION:=2013-09-17
+PKG_VERSION:=2013-09-28
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/ubox.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=cc07b0b7ac66d0e4a05470dd69a28305405cd7dd
+PKG_SOURCE_VERSION:=8baea575d7314f36649e7c85a90715e199dc0f46
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1