[packages] libiconv: declare api functions as extern "C", solves linking with C+...
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 4 Jan 2011 14:20:17 +0000 (14:20 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 4 Jan 2011 14:20:17 +0000 (14:20 +0000)
SVN-Revision: 24899

libs/libiconv/Makefile
libs/libiconv/src/include/iconv.h

index 5006226cda0a70c6693f9e5f3ebc40c4934b5c87..b230e6d84a1acd941315faf5ca506d00e1224d2d 100644 (file)
@@ -11,7 +11,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiconv
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiconv
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
index bfa08f346dd2ce67dee1d061d3bb6e450b0d5ce6..8296f466ed13b9f0c2b2929ea9f6598097b46186 100644 (file)
@@ -1,9 +1,14 @@
 #ifndef _ICONV_H
 #define _ICONV_H 1
 
 #ifndef _ICONV_H
 #define _ICONV_H 1
 
+#define _LIBICONV_VERSION 0x010B    /* version number: (major<<8) + minor */
+
 #include <stddef.h>
 
 #include <stddef.h>
 
-#define _LIBICONV_VERSION 0x010B    /* version number: (major<<8) + minor */
+#ifdef __cplusplus
+extern "C" {
+#endif
+
 extern int _libiconv_version; /* Likewise */
 
 typedef long iconv_t;
 extern int _libiconv_version; /* Likewise */
 
 typedef long iconv_t;
@@ -18,4 +23,8 @@ iconv(iconv_t cd, char **inbuf, size_t *inbytesleft,
 extern int
 iconv_close(iconv_t cd);
 
 extern int
 iconv_close(iconv_t cd);
 
+#ifdef __cplusplus
+}
+#endif
+
 #endif /* _ICONV_H */
 #endif /* _ICONV_H */