makefile cleanups, make sure that the build system cflags are used
authorFelix Fietkau <nbd@openwrt.org>
Mon, 2 Jun 2008 15:50:59 +0000 (15:50 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 2 Jun 2008 15:50:59 +0000 (15:50 +0000)
SVN-Revision: 11328

lang/luaposix/Makefile

index e563b6b3f51006a0961c66bb344b79c221cac648..d61d68488bf012935db73811f905590c8db9cb9a 100644 (file)
@@ -32,17 +32,8 @@ endef
 define Build/Configure
 endef
 
 define Build/Configure
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CROSS)gcc" \
-               LD="$(TARGET_CROSS)ld" \
-               AR="$(TARGET_CROSS)ar rcu" \
-               RANLIB="$(TARGET_CROSS)ranlib" \
-               INSTALL_ROOT=/usr \
-               LUAINC=$(STAGING_DIR)/usr/include \
-               OS=Linux
-       $(STRIP) $(PKG_BUILD_DIR)/posix.so
-endef
+MAKE_FLAGS += \
+       OS=Linux
 
 define Package/luaposix/install                
        $(INSTALL_DIR) $(1)/usr/lib/lua
 
 define Package/luaposix/install                
        $(INSTALL_DIR) $(1)/usr/lib/lua