don't generate a certificate during stunnel build - will make a default one later
authorFelix Fietkau <nbd@openwrt.org>
Tue, 21 Nov 2006 15:12:59 +0000 (15:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 21 Nov 2006 15:12:59 +0000 (15:12 +0000)
SVN-Revision: 5604

net/stunnel/Makefile

index c2a34e1a1c29be999258d7845f0aea15df971551..78479eb79c7192ef5d95b14dab792d06b9cf79a8 100644 (file)
@@ -34,6 +34,8 @@ define Build/Configure
 endef
 
 define Build/Compile   
+       mkdir -p $(PKG_INSTALL_DIR)/etc/stunnel
+       echo '#dummy' > $(PKG_INSTALL_DIR)/etc/stunnel/stunnel.pem
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
@@ -44,7 +46,6 @@ define Package/stunnel/install
        install -d -m0755 $(1)/etc/stunnel $(1)/etc/init.d
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/stunnel $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libstunnel.so $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/etc/stunnel/stunnel.pem $(1)/etc/stunnel/
        $(CP) ./files/stunnel.conf $(1)/etc/stunnel/stunnel.conf
        $(CP) ./files/stunnel.init $(1)/etc/init.d/S90stunnel
 endef