fix valgrind compile
authorFelix Fietkau <nbd@openwrt.org>
Tue, 5 Aug 2008 22:00:32 +0000 (22:00 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 5 Aug 2008 22:00:32 +0000 (22:00 +0000)
SVN-Revision: 12171

utils/valgrind/Makefile
utils/valgrind/patches/100-a_out_header.patch [new file with mode: 0644]

index 4db3d5a19cf7616245cdff8347f89e96d2b3f293..b52983ce1d4469e7d2cd5e6bdf1c557669eae16d 100644 (file)
@@ -53,6 +53,7 @@ DEFAULT_SUPP += "uclibc.supp"
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               CFLAGS="$(TARGET_CFLAGS)" \
                all install
 endef
 
diff --git a/utils/valgrind/patches/100-a_out_header.patch b/utils/valgrind/patches/100-a_out_header.patch
new file mode 100644 (file)
index 0000000..ad3de83
--- /dev/null
@@ -0,0 +1,10 @@
+--- valgrind-3.2.3.orig/coregrind/m_debuginfo/readstabs.c
++++ valgrind-3.2.3/coregrind/m_debuginfo/readstabs.c
+@@ -43,6 +43,7 @@
+ #include "priv_readstabs.h"        /* self */
+ /* --- !!! --- EXTERNAL HEADERS start --- !!! --- */
++#define CONFIG_ARCH_SUPPORTS_AOUT /* XXX */
+ #include <a.out.h> /* stabs defns */
+ /* --- !!! --- EXTERNAL HEADERS end --- !!! --- */