Revert [10668] was accidental
authorFlorian Fainelli <florian@openwrt.org>
Thu, 27 Mar 2008 15:51:02 +0000 (15:51 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 27 Mar 2008 15:51:02 +0000 (15:51 +0000)
SVN-Revision: 10669

target/linux/generic-2.6/image/lzma-loader/src/Makefile
target/linux/generic-2.6/image/lzma-loader/src/decompress.c

index d5f712a1db02e3c2da2210bcde0d62b8397f0ec5..910172c4f8963ba9d362f05620d3aaf5aa5b5d80 100644 (file)
@@ -49,7 +49,7 @@ lzma.bin: lzma.elf
 
 ifeq ($(IMAGE_COPY),1)
 LOADER_ENTRY ?= $(KERNEL_ENTRY)
-lzma.o: decompress.o LzmaDecode.o kernel.o print.o printf.o uart16550.o
+lzma.o: decompress.o LzmaDecode.o kernel.o
        sed -e 's,@LOADADDR@,$(LOADADDR),g' -e 's,@ENTRY@,entry,g' lzma.lds.in >lzma-stage2.lds
        $(LD) -static --no-warn-mismatch -e entry -Tlzma-stage2.lds -o temp-$@ $^
        $(OBJCOPY) temp-$@ lzma.tmp
@@ -60,7 +60,7 @@ lzma.elf: start.o lzma.o
        sed -e 's,@LOADADDR@,$(LOADER_ENTRY),g' lzma-copy.lds.in >lzma-copy.lds
        $(LD) -s -Tlzma-copy.lds -o $@ $^
 else
-lzma.elf: start.o decompress.o LzmaDecode.o kernel.o print.o printf.o uart16550.o
+lzma.elf: start.o decompress.o LzmaDecode.o kernel.o
        $(LD) -s -Tlzma.lds -o $@ $^
 endif
 
index e31f4183dbc0b215a6ac9bb4afe9bfaffb3d92da..45ac509cdc49a46c196aab591889195ffa28cf96 100644 (file)
@@ -145,7 +145,6 @@ void entry(unsigned long icache_size, unsigned long icache_lsize,
                get_byte();
 
        /* decompress kernel */
-       printf("Decompressing kernel\n");
        if ((i = LzmaDecode(&vs, &callback,
        (unsigned char*)KERNEL_ENTRY, osize, &osize)) == LZMA_RESULT_OK)
        {
@@ -153,8 +152,6 @@ void entry(unsigned long icache_size, unsigned long icache_lsize,
                blast_icache(icache_size, icache_lsize);
 
                /* Jump to load address */
-               printf("Jumping !\n");
                ((void (*)(int a0, int a1, int a2, int a3)) KERNEL_ENTRY)(arg0, arg1, arg2, arg3);
        }
-       printf("Failed to decompress !\n");
 }