kernel: update to 2.6.31.9 and 2.6.32.2, and refresh patches
authorGabor Juhos <juhosg@openwrt.org>
Fri, 1 Jan 2010 11:11:17 +0000 (11:11 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 1 Jan 2010 11:11:17 +0000 (11:11 +0000)
SVN-Revision: 18982

include/kernel-version.mk
target/linux/generic-2.6/patches-2.6.30/020-mips_multi_machine_support.patch
target/linux/generic-2.6/patches-2.6.31/020-mips_multi_machine_support.patch
target/linux/generic-2.6/patches-2.6.31/150-netfilter_imq.patch
target/linux/generic-2.6/patches-2.6.32/020-mips_multi_machine_support.patch
target/linux/generic-2.6/patches-2.6.32/510-yaffs_support.patch
target/linux/generic-2.6/patches-2.6.32/980-vm_exports.patch
target/linux/x86/Makefile

index 0a706cc29b93dac6c8bb12b5ebec1b064adb853b..3fe0780bfb8a07ebf6dd2cea57a92dfcf25ac9d7 100644 (file)
@@ -19,11 +19,11 @@ endif
 ifeq ($(LINUX_VERSION),2.6.30.10)
   LINUX_KERNEL_MD5SUM:=eb6be465f914275967a5602cb33662f5
 endif
-ifeq ($(LINUX_VERSION),2.6.31.7)
-  LINUX_KERNEL_MD5SUM:=ae93db04f169f35c98e786f25e84c237
+ifeq ($(LINUX_VERSION),2.6.31.9)
+  LINUX_KERNEL_MD5SUM:=e531261b99e34208eb823be63fb0ce91
 endif
-ifeq ($(LINUX_VERSION),2.6.32)
-  LINUX_KERNEL_MD5SUM:=260551284ac224c3a43c4adac7df4879
+ifeq ($(LINUX_VERSION),2.6.32.2)
+  LINUX_KERNEL_MD5SUM:=9809778a867dfd3d6811a2f929256334
 endif
 
 # disable the md5sum check for unknown kernel versions
index 28cc14931cb8587479a573c8e1c5e0eabe89f349..2c53f03e84dd16fa50253540a0437c31db161d20 100644 (file)
 +}
 --- a/arch/mips/kernel/Makefile
 +++ b/arch/mips/kernel/Makefile
-@@ -85,6 +85,7 @@
+@@ -85,6 +85,7 @@ obj-$(CONFIG_GPIO_TXX9)              += gpio_txx9.o
  
  obj-$(CONFIG_KEXEC)           += machine_kexec.o relocate_kernel.o
  obj-$(CONFIG_EARLY_PRINTK)    += early_printk.o
  
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -803,6 +803,9 @@
+@@ -803,6 +803,9 @@ config MIPS_DISABLE_OBSOLETE_IDE
  config SYNC_R4K
        bool
  
  
  unsigned int vced_count, vcei_count;
  
-@@ -33,8 +34,12 @@
+@@ -33,8 +34,12 @@ static int show_cpuinfo(struct seq_file 
        /*
         * For the first processor also print the system type
         */
index f602174c62ee0361dbeabf66652d9dff39bea4dc..9c41c3c1614e20b79a223e8f4f6dc5bcf74a6e69 100644 (file)
 +}
 --- a/arch/mips/kernel/Makefile
 +++ b/arch/mips/kernel/Makefile
-@@ -87,6 +87,7 @@
+@@ -87,6 +87,7 @@ obj-$(CONFIG_GPIO_TXX9)              += gpio_txx9.o
  
  obj-$(CONFIG_KEXEC)           += machine_kexec.o relocate_kernel.o
  obj-$(CONFIG_EARLY_PRINTK)    += early_printk.o
  
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -837,6 +837,9 @@
+@@ -837,6 +837,9 @@ config MIPS_DISABLE_OBSOLETE_IDE
  config SYNC_R4K
        bool
  
  
  unsigned int vced_count, vcei_count;
  
-@@ -31,8 +32,12 @@
+@@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file 
        /*
         * For the first processor also print the system type
         */
index cc9f5f263eb5de713c72d5ec2d32ba5f7f562cb4..026e9bdee990244f18f66ca800126e7a27428453 100644 (file)
  #include <linux/proc_fs.h>
  #include <linux/seq_file.h>
  #include <linux/stat.h>
-@@ -1686,7 +1689,11 @@ int dev_hard_start_xmit(struct sk_buff *
+@@ -1687,7 +1690,11 @@ int dev_hard_start_xmit(struct sk_buff *
        int rc;
  
        if (likely(!skb->next)) {
                        dev_queue_xmit_nit(skb, dev);
  
                if (netif_needs_gso(dev, skb)) {
-@@ -1771,8 +1778,7 @@ u16 skb_tx_hash(const struct net_device 
+@@ -1772,8 +1779,7 @@ u16 skb_tx_hash(const struct net_device 
  }
  EXPORT_SYMBOL(skb_tx_hash);
  
  {
        const struct net_device_ops *ops = dev->netdev_ops;
        u16 queue_index = 0;
-@@ -1785,6 +1791,7 @@ static struct netdev_queue *dev_pick_tx(
+@@ -1786,6 +1792,7 @@ static struct netdev_queue *dev_pick_tx(
        skb_set_queue_mapping(skb, queue_index);
        return netdev_get_tx_queue(dev, queue_index);
  }
        new->csum               = old->csum;
        new->local_df           = old->local_df;
        new->pkt_type           = old->pkt_type;
-@@ -2778,6 +2867,13 @@ void __init skb_init(void)
+@@ -2779,6 +2868,13 @@ void __init skb_init(void)
                                                0,
                                                SLAB_HWCACHE_ALIGN|SLAB_PANIC,
                                                NULL);
index 48b649195e3e1a1b011d82de3c444740e8f131f0..4c98b73f874c73011cbed9d9cdbe834e675089cd 100644 (file)
 +}
 --- a/arch/mips/kernel/Makefile
 +++ b/arch/mips/kernel/Makefile
-@@ -87,6 +87,7 @@
+@@ -87,6 +87,7 @@ obj-$(CONFIG_GPIO_TXX9)              += gpio_txx9.o
  
  obj-$(CONFIG_KEXEC)           += machine_kexec.o relocate_kernel.o
  obj-$(CONFIG_EARLY_PRINTK)    += early_printk.o
  
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -854,6 +854,9 @@
+@@ -854,6 +854,9 @@ config MIPS_DISABLE_OBSOLETE_IDE
  config SYNC_R4K
        bool
  
  
  unsigned int vced_count, vcei_count;
  
-@@ -31,8 +32,12 @@
+@@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file 
        /*
         * For the first processor also print the system type
         */
index fe549c30c10411ae1d8a8387ac25915d53db002f..e490452e58f25a8378a498eb17496c0cd3bed846 100644 (file)
@@ -10,7 +10,7 @@
  
 --- a/fs/Makefile
 +++ b/fs/Makefile
-@@ -126,3 +126,4 @@ obj-$(CONFIG_OCFS2_FS)             += ocfs2/
+@@ -125,3 +125,4 @@ obj-$(CONFIG_OCFS2_FS)             += ocfs2/
  obj-$(CONFIG_BTRFS_FS)                += btrfs/
  obj-$(CONFIG_GFS2_FS)           += gfs2/
  obj-$(CONFIG_EXOFS_FS)          += exofs/
index 91f85c2b6110c56f80f49f2740e45afa183a8050..724b1f030c48e400b75969976fdac740ac4ff5fb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/mm/shmem.c
 +++ b/mm/shmem.c
-@@ -2775,6 +2775,16 @@ int shmem_lock(struct file *file, int lo
+@@ -2608,6 +2608,16 @@ int shmem_lock(struct file *file, int lo
  
  /* common code */
  
@@ -17,7 +17,7 @@
  /**
   * shmem_file_setup - get an unlinked file living in tmpfs
   * @name: name for dentry (to be seen in /proc/<pid>/maps
-@@ -2854,9 +2864,6 @@ int shmem_zero_setup(struct vm_area_stru
+@@ -2687,9 +2697,6 @@ int shmem_zero_setup(struct vm_area_stru
        if (IS_ERR(file))
                return PTR_ERR(file);
  
@@ -68,7 +68,7 @@
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -6075,6 +6075,7 @@ int can_nice(const struct task_struct *p
+@@ -6095,6 +6095,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
                capable(CAP_SYS_NICE));
  }
index 9a1685d853fb8bbb43ab93b2fa0f643d0b8eaee8..69c6c5555414385c868efaa7dd66ea6629677d0d 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz
 SUBTARGETS=generic olpc
 
-LINUX_VERSION:=2.6.31.7
+LINUX_VERSION:=2.6.31.9
 
 include $(INCLUDE_DIR)/target.mk