brcm2708: fix mkdosfs command line options order
authorFelix Fietkau <nbd@openwrt.org>
Sun, 15 Mar 2015 05:18:50 +0000 (05:18 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 15 Mar 2015 05:18:50 +0000 (05:18 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
SVN-Revision: 44764

target/linux/brcm2708/image/Makefile

index ae977a613edb73ec87b1b93c449dbf7fcc690b0c..cb5acde48cdae331fdae171ad74fb77ec5ae7c82 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,7 +14,7 @@ FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FA
 define Image/Build/RaspberryPi
        rm -f $(KDIR)/boot.img
 
 define Image/Build/RaspberryPi
        rm -f $(KDIR)/boot.img
 
-       mkdosfs $(KDIR)/boot.img -C $(FAT32_BLOCKS)
+       mkdosfs -C $(KDIR)/boot.img $(FAT32_BLOCKS)
        # Raspberry Pi has no bootloader, instead the GPU loads and starts the kernel
        mcopy -i $(KDIR)/boot.img $(BUILD_DIR)/brcm2708-gpu-fw-boot/bootcode.bin ::
        mcopy -i $(KDIR)/boot.img $(BUILD_DIR)/brcm2708-gpu-fw-boot/COPYING.linux ::
        # Raspberry Pi has no bootloader, instead the GPU loads and starts the kernel
        mcopy -i $(KDIR)/boot.img $(BUILD_DIR)/brcm2708-gpu-fw-boot/bootcode.bin ::
        mcopy -i $(KDIR)/boot.img $(BUILD_DIR)/brcm2708-gpu-fw-boot/COPYING.linux ::