mrd6: remove invasive stuff from patch 001 and rename it, Makefile cleanup
authorNicolas Thill <nico@openwrt.org>
Mon, 3 Sep 2007 16:07:32 +0000 (16:07 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 3 Sep 2007 16:07:32 +0000 (16:07 +0000)
SVN-Revision: 8601

ipv6/mrd6/Makefile
ipv6/mrd6/patches/001-ceilf_replacement.patch [deleted file]
ipv6/mrd6/patches/001-dest_prefix.patch [new file with mode: 0644]

index 0dd6b7e4c7273e755428ac5070217ed810cf883d..e4d99415acd27306ecc67bfefbc84acfaf703081 100644 (file)
@@ -11,14 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=mrd6
 PKG_VERSION:=0.9.5
 PKG_RELEASE:=1
 PKG_NAME:=mrd6
 PKG_VERSION:=0.9.5
 PKG_RELEASE:=1
-PKG_MD5SUM:=24a08cf1407000d628a272b08a415dda
 
 PKG_SOURCE_URL:=http://hng.av.it.pt/mrd6/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 
 PKG_SOURCE_URL:=http://hng.av.it.pt/mrd6/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=24a08cf1407000d628a272b08a415dda
 
 PKG_BUILD_DEPENDS:=libnotimpl
 
 
 PKG_BUILD_DEPENDS:=libnotimpl
 
@@ -29,13 +25,6 @@ define Package/mrd6
   CATEGORY:=IPv6
   DEPENDS:=@LINUX_2_6 +uclibcxx
   TITLE:=IPv6 multicast routing daemon
   CATEGORY:=IPv6
   DEPENDS:=@LINUX_2_6 +uclibcxx
   TITLE:=IPv6 multicast routing daemon
-  DESCRIPTION:=Multicast is becoming a major component in next generation\\\
-               networks, used in several scenarios, from video broadcasting\\\
-               to multimedia conferencing. In order to be implemented, new\\\
-               technology needs supporting hardware and software across a set\\\
-               of devices and systems. MRD6 is an implementation of a modular\\\
-               IPv6 Multicast Routing Framework for the Linux operating system\\\
-               and provides MLDv2 (as well as MLDv1), PIM-SM and MBGP support.\\\
   URL:=http://artemis.av.it.pt/mrd6/
 endef
 
   URL:=http://artemis.av.it.pt/mrd6/
 endef
 
@@ -43,17 +32,26 @@ define Package/mrd6/conffiles
 /etc/mrd6.conf
 endef
 
 /etc/mrd6.conf
 endef
 
+define Package/mrd6/description
+ Multicast is becoming a major component in next generation networks, used 
+ in several scenarios, from video broadcasting to multimedia conferencing. 
+ In order to be implemented, new technology needs supporting hardware and 
+ software across a set of devices and systems. MRD6 is an implementation of 
+ a modular IPv6 Multicast Routing Framework for the Linux operating system 
+ and provides MLDv2 (as well as MLDv1), PIM-SM and MBGP support.
+endef
+
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR)/src \
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR)/src \
+               $(TARGET_CONFIGURE_OPTS) \
                OPTIMIZE=yes \
                SPACE_OPTIMIZE=yes \
                FULL_STATIC=no \
                OPTIMIZE=yes \
                SPACE_OPTIMIZE=yes \
                FULL_STATIC=no \
-               CFLAGS="$(TARGET_CFLAGS) -DNO_INET6_OPTION" \
-               CXX="$(TARGET_CROSS)g++" \
-               CC="$(TARGET_CC)" \
-               STAGING_DIR="$(STAGING_DIR)" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -DNO_INET6_OPTION -fno-builtin -fno-rtti" \
+               LDFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -luClibc++ -Wl,-Bstatic,-lstdc++,-Bdynamic -ldl -lm -lnotimpl" \
+               MODULE_CXX="\$$$$(CC) -shared \$$$$(CXXFLAGS) \$$$$(LDFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               PREFIX=/usr/ \
+               PREFIX="/usr/" \
                install
 endef
 
                install
 endef
 
diff --git a/ipv6/mrd6/patches/001-ceilf_replacement.patch b/ipv6/mrd6/patches/001-ceilf_replacement.patch
deleted file mode 100644 (file)
index cd6b3d4..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -urN mrd6-0.9.5/src/Makefile mrd6-0.9.5.new/src/Makefile
---- mrd6-0.9.5/src/Makefile    2005-12-18 19:15:04.000000000 +0100
-+++ mrd6-0.9.5.new/src/Makefile        2006-02-11 18:30:44.000000000 +0100
-@@ -43,7 +43,7 @@
-       CFLAGS += -DNO_INET6_OPTION
- endif
--DEST_PREFIX = $(DESTDIR)$(PREFIX)
-+DEST_PREFIX = $(DESTDIR)/$(PREFIX)
- ifeq ($(OPTIMIZE),yes)
-       ifeq ($(SPACE_OPTIMIZE),yes)
-@@ -97,7 +97,7 @@
-       endif
- endif
--LDFLAGS += -lm
-+LDFLAGS += -L$(STAGING_DIR)/usr/lib -lnotimpl -lm
- ifeq ($(PLATFORM),OS_LINUX)
-       LDFLAGS += -ldl
- endif
diff --git a/ipv6/mrd6/patches/001-dest_prefix.patch b/ipv6/mrd6/patches/001-dest_prefix.patch
new file mode 100644 (file)
index 0000000..c595630
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN mrd6-0.9.5/src/Makefile mrd6-0.9.5.new/src/Makefile
+--- mrd6-0.9.5/src/Makefile    2005-12-18 19:15:04.000000000 +0100
++++ mrd6-0.9.5.new/src/Makefile        2006-02-11 18:30:44.000000000 +0100
+@@ -43,7 +43,7 @@
+       CFLAGS += -DNO_INET6_OPTION
+ endif
+-DEST_PREFIX = $(DESTDIR)$(PREFIX)
++DEST_PREFIX = $(DESTDIR)/$(PREFIX)
+ ifeq ($(OPTIMIZE),yes)
+       ifeq ($(SPACE_OPTIMIZE),yes)