dropbear: use -ffunction-sections, -fdata-sections and --gc-sections, saves 19k uncom...
authorFelix Fietkau <nbd@openwrt.org>
Wed, 2 Mar 2011 12:47:52 +0000 (12:47 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 2 Mar 2011 12:47:52 +0000 (12:47 +0000)
SVN-Revision: 25826

package/dropbear/Makefile

index 5bcc5fb9b01cc847bcaa99aac42c06d6197e8126..bb1230cefcc37957803a88615fe6948659d2c12c 100644 (file)
@@ -65,7 +65,8 @@ CONFIGURE_ARGS += \
        --disable-pututxline \
        --disable-zlib
 
-TARGET_CFLAGS += -DARGTYPE=3
+TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
 
 define Build/Configure
        $(SED) 's,^/\* #define PKG_MULTI.*,#define PKG_MULTI,g' $(PKG_BUILD_DIR)/options.h