lsof: use environment variables correctly to prime Configure
authorFelix Fietkau <nbd@openwrt.org>
Fri, 29 Jun 2012 18:30:10 +0000 (18:30 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 29 Jun 2012 18:30:10 +0000 (18:30 +0000)
Rewrite of the configure and compile stages as per the suggestions in the packages 00XCONFIG instructions.

Note that this is required to get eglibc working, as eglibc doesn't include the RPC functions as part of libc.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
SVN-Revision: 32529

utils/lsof/Makefile

index dd070b05d2d3fa2acb1eb69d98ff1a012a167d45..bcf6b8045c2c5a3509060c113020b6c2ae4d7a8f 100644 (file)
@@ -20,7 +20,6 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)+dfsg.orig
 
 include $(INCLUDE_DIR)/package.mk
 
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
 TARGET_LDFLAGS += $(LIBRPC)
 
 define Package/lsof
@@ -35,17 +34,17 @@ define Build/Configure
        cd $(PKG_BUILD_DIR); \
                LINUX_CLIB="-DGLIBCV=2" \
                LSOF_CC="$(TARGET_CC)" \
+               LSOF_INCLUDE="-I$(STAGING_DIR)/usr/include" \
                LSOF_VSTR="$(LINUX_VERSION)" \
+               LSOF_CFGC="$(TARGET_CFLAGS)" \
+               LSOF_CFGL="$(TARGET_LDFLAGS)" \
+               LSOF_AR="$(TARGET_CROSS)ar cr" \
+               LSOF_RANLIB="$(TARGET_CROSS)ranlib" \
                ./Configure -n linux
 endef
 
 define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               AR="$(TARGET_CROSS)ar cr" \
-               RANLIB="$(TARGET_CROSS)ranlib" \
-               DEBUG="$(TARGET_CFLAGS)" \
-               LDFLAGS="$(TARGET_LDFLAGS)" 
+       $(MAKE) -C $(PKG_BUILD_DIR)
 endef
 
 define Package/lsof/install