Generate squashfs images as well
authorFlorian Fainelli <florian@openwrt.org>
Sun, 1 Apr 2007 17:10:03 +0000 (17:10 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 1 Apr 2007 17:10:03 +0000 (17:10 +0000)
SVN-Revision: 6800

target/linux/rdc-2.6/image/Makefile

index 6c733087c262622bf23045aa6e651a923e8de8b1..7cb4e043fb955f7c75dbd1309fd7b5b1550074d3 100644 (file)
@@ -11,9 +11,23 @@ define Image/Prepare
        $(CP) $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/bzImage
 endef
 
+define trxalign/jffs2-128k
+-a 0x20000
+endef
+define trxalign/jffs2-64k
+-a 0x10000
+endef
+define trxalign/squashfs
+-a 1024
+endef
+
 define Image/Build/Airlink
        touch $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).img
+ifneq ($(1),squashfs)
        $(STAGING_DIR)/bin/airlink -b 1 -j 64 $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).img
+else
+       $(STAGING_DIR)/bin/airlink -b 1 $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).img
+endif
 endef
 
 define Image/Build