[ar71xx] build firmware image for the Atlantis-Land A02-RB-W300N
authorGabor Juhos <juhosg@openwrt.org>
Sun, 1 Mar 2009 11:50:05 +0000 (11:50 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 1 Mar 2009 11:50:05 +0000 (11:50 +0000)
SVN-Revision: 14711

target/linux/ar71xx/image/Makefile
target/linux/ar71xx/profiles/atlantis.mk [new file with mode: 0644]

index e32a1978258b4650020f0e2438c89c718b361e7f..fabe8de0b095094559a7abd011e1851415ea7e71 100644 (file)
@@ -166,6 +166,10 @@ define Image/Build/Profile/TEW652BRP
        $(call Image/Build/Template/AP81/$(1),tew-652brp,board=TEW-632BRP,"AP81-AR9130-RT-080609-05")
 endef
 
+define Image/Build/Profile/A02RBW300N
+       $(call Image/Build/Template/AP81/$(1),a02-rb-w300n,board=TEW-632BRP,"AP81-AR9130-RT-070614-03")
+endef
+
 define Image/Build/Profile/UBNTRS
        $(call Image/Build/Template/UBNT/$(1),rs,board=UBNT-RS,RS,RSx)
 endef
@@ -179,6 +183,7 @@ define Image/Build/Profile/TLWR941NDV2
 endef
 
 define Image/Build/Profile/Default
+       $(call Image/Build/Profile/A02RBW300N,$(1))
        $(call Image/Build/Profile/DIR615C1,$(1))
        $(call Image/Build/Profile/MZKW04NU,$(1))
        $(call Image/Build/Profile/TEW632BRP,$(1))
diff --git a/target/linux/ar71xx/profiles/atlantis.mk b/target/linux/ar71xx/profiles/atlantis.mk
new file mode 100644 (file)
index 0000000..c756bdd
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/A02RBW300N
+       NAME:=Atlantis-Land A02-RB-W300N
+       PACKAGES:=kmod-ath9k hostapd-mini
+endef
+
+define Profile/A02RBW300N/Description
+       Package set optimized for the Atlantis-Land A02-RB-W300N.
+endef
+
+$(eval $(call Profile,A02RBW300N))