kernel: refresh generic patches
authorJonas Gorski <jogo@openwrt.org>
Sun, 19 Apr 2015 11:38:46 +0000 (11:38 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sun, 19 Apr 2015 11:38:46 +0000 (11:38 +0000)
Refresh patches to remove the trailing whitespaces caused by an old
diffutils version on osx.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 45506

33 files changed:
target/linux/generic/patches-3.18/077-10-bgmac-simplify-dma-init-cleanup.patch
target/linux/generic/patches-3.18/077-12-bgmac-drop-ring-num_slots.patch
target/linux/generic/patches-3.18/600-netfilter_conntrack_flush.patch
target/linux/generic/patches-3.18/610-netfilter_match_bypass_default_checks.patch
target/linux/generic/patches-3.18/615-netfilter_add_xt_id_match.patch
target/linux/generic/patches-3.18/643-bridge_remove_ipv6_dependency.patch
target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch
target/linux/generic/patches-3.18/653-disable_netlink_trim.patch
target/linux/generic/patches-3.18/657-qdisc_reduce_truesize.patch
target/linux/generic/patches-3.18/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
target/linux/generic/patches-3.18/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
target/linux/generic/patches-3.18/750-hostap_txpower.patch
target/linux/generic/patches-3.18/773-bgmac-add-srab-switch.patch
target/linux/generic/patches-3.18/810-pci_disable_common_quirks.patch
target/linux/generic/patches-3.18/821-usb-dwc2-dualrole.patch
target/linux/generic/patches-3.18/902-debloat_proc.patch
target/linux/generic/patches-3.18/941-ocf_20120127.patch
target/linux/generic/patches-4.0/110-jffs2-use-.rename2-and-add-RENAME_WHITEOUT-support.patch
target/linux/generic/patches-4.0/600-netfilter_conntrack_flush.patch
target/linux/generic/patches-4.0/610-netfilter_match_bypass_default_checks.patch
target/linux/generic/patches-4.0/615-netfilter_add_xt_id_match.patch
target/linux/generic/patches-4.0/643-bridge_remove_ipv6_dependency.patch
target/linux/generic/patches-4.0/645-bridge_multicast_to_unicast.patch
target/linux/generic/patches-4.0/653-disable_netlink_trim.patch
target/linux/generic/patches-4.0/657-qdisc_reduce_truesize.patch
target/linux/generic/patches-4.0/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
target/linux/generic/patches-4.0/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
target/linux/generic/patches-4.0/721-phy_packets.patch
target/linux/generic/patches-4.0/750-hostap_txpower.patch
target/linux/generic/patches-4.0/773-bgmac-add-srab-switch.patch
target/linux/generic/patches-4.0/810-pci_disable_common_quirks.patch
target/linux/generic/patches-4.0/902-debloat_proc.patch
target/linux/generic/patches-4.0/941-ocf_20120127.patch

index ed03db069e839aee93d4f1cc8c07d7b4fd0403b9..f8d792115943fbae81eb8fe44293b27fda714d71 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  }
  
  static int bgmac_dma_alloc(struct bgmac *bgmac)
-@@ -621,8 +629,6 @@ static int bgmac_dma_alloc(struct bgmac 
+@@ -621,8 +629,6 @@ static int bgmac_dma_alloc(struct bgmac
        }
  
        for (i = 0; i < BGMAC_MAX_RX_RINGS; i++) {
@@ -53,7 +53,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
                ring = &bgmac->rx_ring[i];
                ring->num_slots = BGMAC_RX_RING_SLOTS;
                ring->mmio_base = ring_base[i];
-@@ -645,15 +651,6 @@ static int bgmac_dma_alloc(struct bgmac 
+@@ -645,15 +651,6 @@ static int bgmac_dma_alloc(struct bgmac
                        ring->index_base = lower_32_bits(ring->dma_base);
                else
                        ring->index_base = 0;
@@ -82,7 +82,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  
        for (i = 0; i < BGMAC_MAX_TX_RINGS; i++) {
                ring = &bgmac->tx_ring[i];
-@@ -698,8 +695,13 @@ static void bgmac_dma_init(struct bgmac 
+@@ -698,8 +695,13 @@ static void bgmac_dma_init(struct bgmac
                if (ring->unaligned)
                        bgmac_dma_rx_enable(bgmac, ring);
  
@@ -97,7 +97,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  
                bgmac_write(bgmac, ring->mmio_base + BGMAC_DMA_RX_INDEX,
                            ring->index_base +
-@@ -708,6 +710,12 @@ static void bgmac_dma_init(struct bgmac 
+@@ -708,6 +710,12 @@ static void bgmac_dma_init(struct bgmac
                ring->start = 0;
                ring->end = 0;
        }
@@ -141,7 +141,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  
        bgmac_enable(bgmac);
  }
-@@ -1274,23 +1270,27 @@ static int bgmac_open(struct net_device 
+@@ -1274,23 +1270,27 @@ static int bgmac_open(struct net_device
        int err = 0;
  
        bgmac_chip_reset(bgmac);
@@ -174,7 +174,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  }
  
  static int bgmac_stop(struct net_device *net_dev)
-@@ -1306,6 +1306,7 @@ static int bgmac_stop(struct net_device 
+@@ -1306,6 +1306,7 @@ static int bgmac_stop(struct net_device
        free_irq(bgmac->core->irq, net_dev);
  
        bgmac_chip_reset(bgmac);
index 90f3e6d1dfb655fed986ee85e5d28b6fb0e0ba75..4cd2e3f80cf5a99caf879b278b91bccfc4deea34 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        dma_free_coherent(dma_dev, size, ring->cpu_base,
                          ring->dma_base);
  }
-@@ -590,10 +591,12 @@ static void bgmac_dma_free(struct bgmac 
+@@ -590,10 +591,12 @@ static void bgmac_dma_free(struct bgmac
        int i;
  
        for (i = 0; i < BGMAC_MAX_TX_RINGS; i++)
@@ -80,7 +80,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  }
  
  static int bgmac_dma_alloc(struct bgmac *bgmac)
-@@ -616,11 +619,10 @@ static int bgmac_dma_alloc(struct bgmac 
+@@ -616,11 +619,10 @@ static int bgmac_dma_alloc(struct bgmac
  
        for (i = 0; i < BGMAC_MAX_TX_RINGS; i++) {
                ring = &bgmac->tx_ring[i];
@@ -93,7 +93,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
                ring->cpu_base = dma_zalloc_coherent(dma_dev, size,
                                                     &ring->dma_base,
                                                     GFP_KERNEL);
-@@ -642,11 +644,10 @@ static int bgmac_dma_alloc(struct bgmac 
+@@ -642,11 +644,10 @@ static int bgmac_dma_alloc(struct bgmac
  
        for (i = 0; i < BGMAC_MAX_RX_RINGS; i++) {
                ring = &bgmac->rx_ring[i];
index cc428580a19f4c7127384b17820f89a57d18741b..bc6ed3e5d7538d3597a8497b627cad2a492474b0 100644 (file)
@@ -8,7 +8,7 @@
  #include <net/net_namespace.h>
  #ifdef CONFIG_SYSCTL
  #include <linux/sysctl.h>
-@@ -262,10 +263,66 @@ static int ct_open(struct inode *inode, 
+@@ -262,10 +263,66 @@ static int ct_open(struct inode *inode,
                        sizeof(struct ct_iter_state));
  }
  
index f652dafd188b2e41f26d7a84f73444b7abac1018..358d64b1a17e8ed10b61fec068a640d58cb6540c 100644 (file)
  
        counters = alloc_counters(table);
        if (IS_ERR(counters))
-@@ -966,6 +995,14 @@ copy_entries_to_user(unsigned int total_
+@@ -965,6 +994,14 @@ copy_entries_to_user(unsigned int total_
+                       ret = -EFAULT;
                        goto free_counters;
                }
++
 +              flags = e->ip.flags & IPT_F_MASK;
 +              if (copy_to_user(userptr + off
 +                               + offsetof(struct ipt_entry, ip.flags),
@@ -87,7 +88,6 @@
 +                      ret = -EFAULT;
 +                      goto free_counters;
 +              }
-+
                for (i = sizeof(struct ipt_entry);
                     i < e->target_offset;
-                    i += m->u.match_size) {
index cbb9b2b8bd6fdd81dc36a22e89e925b1879bc184..45f59a2a69dbf880fba97415a62c3adfd4b669ba 100644 (file)
@@ -37,7 +37,7 @@
        depends on NETFILTER_ADVANCED
 --- a/net/netfilter/Makefile
 +++ b/net/netfilter/Makefile
-@@ -143,6 +143,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_ESP) += 
+@@ -143,6 +143,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_ESP) +=
  obj-$(CONFIG_NETFILTER_XT_MATCH_HASHLIMIT) += xt_hashlimit.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_HELPER) += xt_helper.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_HL) += xt_hl.o
index b1a40152b0243f7ad0494f07a128cc0aa048e38d..3f0dcd3ae27fe42f548e8968ad17697d0fc40f78 100644 (file)
@@ -25,7 +25,7 @@
          Ethernet bridge, which means that the different Ethernet segments it
 --- a/net/ipv6/Makefile
 +++ b/net/ipv6/Makefile
-@@ -45,6 +45,7 @@ obj-y += addrconf_core.o exthdrs_core.o 
+@@ -45,6 +45,7 @@ obj-y += addrconf_core.o exthdrs_core.o
  obj-$(CONFIG_INET) += output_core.o protocol.o $(ipv6-offload)
  
  obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_hashtables.o
index d870dc5d5f2f7c7b47ad5c9d21b4643b3b61fd63..5acfea6c3aa9df732eb58300225b02fef8133f29 100644 (file)
  }
  #endif
  
-@@ -1556,6 +1584,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1556,6 +1584,7 @@ static int br_multicast_ipv4_rcv(struct
                                 struct sk_buff *skb,
                                 u16 vid)
  {
        struct sk_buff *skb2 = skb;
        const struct iphdr *iph;
        struct igmphdr *ih;
-@@ -1629,7 +1658,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1629,7 +1658,7 @@ static int br_multicast_ipv4_rcv(struct
        case IGMP_HOST_MEMBERSHIP_REPORT:
        case IGMPV2_HOST_MEMBERSHIP_REPORT:
                BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
                break;
        case IGMPV3_HOST_MEMBERSHIP_REPORT:
                err = br_ip4_multicast_igmp3_report(br, port, skb2, vid);
-@@ -1638,7 +1667,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1638,7 +1667,7 @@ static int br_multicast_ipv4_rcv(struct
                err = br_ip4_multicast_query(br, port, skb2, vid);
                break;
        case IGMP_HOST_LEAVE_MESSAGE:
                break;
        }
  
-@@ -1656,6 +1685,7 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1656,6 +1685,7 @@ static int br_multicast_ipv6_rcv(struct
                                 struct sk_buff *skb,
                                 u16 vid)
  {
        struct sk_buff *skb2;
        const struct ipv6hdr *ip6h;
        u8 icmp6_type;
-@@ -1765,7 +1795,8 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1765,7 +1795,8 @@ static int br_multicast_ipv6_rcv(struct
                }
                mld = (struct mld_msg *)skb_transport_header(skb2);
                BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
                break;
            }
        case ICMPV6_MLD2_REPORT:
-@@ -1782,7 +1813,7 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1782,7 +1813,7 @@ static int br_multicast_ipv6_rcv(struct
                        goto out;
                }
                mld = (struct mld_msg *)skb_transport_header(skb2);
index dfe9c2f2557dbd405ab01815103b995af50d51d4..5732596792912ff7fd6d24633110dc69e1b08700 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netlink/af_netlink.c
 +++ b/net/netlink/af_netlink.c
-@@ -1695,27 +1695,7 @@ void netlink_detachskb(struct sock *sk, 
+@@ -1695,27 +1695,7 @@ void netlink_detachskb(struct sock *sk,
  
  static struct sk_buff *netlink_trim(struct sk_buff *skb, gfp_t allocation)
  {
index 72b3dfc04d3612fc56c34ebea703fca0c0d42061..6777eecf5ab4016564c6635a037c666b106b68fd 100644 (file)
@@ -24,7 +24,7 @@ commont qdiscs.
        }
 --- a/net/sched/sch_fifo.c
 +++ b/net/sched/sch_fifo.c
-@@ -29,17 +29,21 @@ static int bfifo_enqueue(struct sk_buff 
+@@ -29,17 +29,21 @@ static int bfifo_enqueue(struct sk_buff
  
  static int pfifo_enqueue(struct sk_buff *skb, struct Qdisc *sch)
  {
index 8bf4b3b29461f7820e9ea11bfc3a02d75fbc0d73..000665f047655e583018b44496d11f90873d3b08 100644 (file)
@@ -308,7 +308,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        err = ip6_tnl_xmit2(skb, dev, dsfield, &fl6, encap_limit, &mtu);
        if (err != 0) {
                /* XXX: send ICMP error even if DF is not set. */
-@@ -1263,6 +1413,14 @@ ip6_tnl_change(struct ip6_tnl *t, const 
+@@ -1263,6 +1413,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
        t->parms.flowinfo = p->flowinfo;
        t->parms.link = p->link;
        t->parms.proto = p->proto;
index b059fbe5c7b9dd8a349c27c26d159c4c62b90db3..bc163cb2512f771f80e4a7947c5266dd4afaccb4 100644 (file)
@@ -55,7 +55,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  
 --- a/net/ipv4/fib_semantics.c
 +++ b/net/ipv4/fib_semantics.c
-@@ -138,6 +138,10 @@ const struct fib_prop fib_props[RTN_MAX 
+@@ -138,6 +138,10 @@ const struct fib_prop fib_props[RTN_MAX
                .error  = -EINVAL,
                .scope  = RT_SCOPE_NOWHERE,
        },
index fc032a93c974de8eced6aadee70efb3c9c2f9824..768c80f73bab5bf819782682c5c8d26dbd10ee9c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/hostap/hostap_ap.c
 +++ b/drivers/net/wireless/hostap/hostap_ap.c
-@@ -2403,13 +2403,13 @@ int prism2_ap_get_sta_qual(local_info_t 
+@@ -2403,13 +2403,13 @@ int prism2_ap_get_sta_qual(local_info_t
                addr[count].sa_family = ARPHRD_ETHER;
                memcpy(addr[count].sa_data, sta->addr, ETH_ALEN);
                if (sta->last_rx_silence == 0)
index 3b2751f529cc9702f98f6deffe762ffb664122ea..b883d73af3ae953ecd2e0ef7b954740570185e6a 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
  #include <bcm47xx_nvram.h>
  
  static const struct bcma_device_id bgmac_bcma_tbl[] = {
-@@ -1538,6 +1539,17 @@ static void bgmac_mii_unregister(struct 
+@@ -1538,6 +1539,17 @@ static void bgmac_mii_unregister(struct
        mdiobus_free(mii_bus);
  }
  
index f6639f124244b0ffdb60a842093da4df3f68ff4b..b6c0b38e72517c4ba04541fecf47954f89c628ba 100644 (file)
@@ -15,7 +15,7 @@
        default y
 --- a/drivers/pci/quirks.c
 +++ b/drivers/pci/quirks.c
-@@ -41,6 +41,7 @@ static void quirk_mmio_always_on(struct 
+@@ -41,6 +41,7 @@ static void quirk_mmio_always_on(struct
  DECLARE_PCI_FIXUP_CLASS_EARLY(PCI_ANY_ID, PCI_ANY_ID,
                                PCI_CLASS_BRIDGE_HOST, 8, quirk_mmio_always_on);
  
index 71a0cb20b068dd282ba0489705aa18661b46d702..9e841cb6426534b5ab1c300ac819e366f8837b4e 100644 (file)
 +config USB_DWC2_PERIPHERAL
 +      bool "Gadget only mode"
 +      depends on USB_GADGET=y || USB_GADGET=USB_DWC2
-       help
--        The Designware USB2.0 platform interface module for
--        controllers directly connected to the CPU. This is only
--        used for host mode.
++      help
 +        The Designware USB2.0 high-speed gadget controller
 +        integrated into many SoCs. Select this option if you want the
 +        driver to operate in Peripheral-only mode. This option requires
 +config USB_DWC2_DUAL_ROLE
 +      bool "Dual Role mode"
 +      depends on (USB=y || USB=USB_DWC2) && (USB_GADGET=y || USB_GADGET=USB_DWC2)
-+      help
+       help
+-        The Designware USB2.0 platform interface module for
+-        controllers directly connected to the CPU. This is only
+-        used for host mode.
 +        Select this option if you want the driver to work in a dual-role
 +        mode. In this mode both host and gadget features are enabled, and
 +        the role will be determined by the cable that gets plugged-in. This
index 43885ad90b1f1c61d8551dd8e0e5896d0397c7bc..8b3a5d43f042a8550778498480a62a93a13c017d 100644 (file)
                         &fib_triestat_fops))
                goto out2;
  
-@@ -2503,17 +2505,21 @@ int __net_init fib_proc_init(struct net 
+@@ -2503,17 +2505,21 @@ int __net_init fib_proc_init(struct net
        return 0;
  
  out3:
index 7f3f996f0d6d24f7fb9157473223d7a26c25313a..ee36f1ee49d5645789caa1dc77be7ad86c91b535 100644 (file)
@@ -24,7 +24,7 @@
   * All of these routines try to estimate how many bits of randomness a
   * particular randomness source.  They do this by keeping track of the
   * first and second order deltas of the event timings.
-@@ -938,6 +948,63 @@ void add_disk_randomness(struct gendisk 
+@@ -938,6 +948,63 @@ void add_disk_randomness(struct gendisk
  EXPORT_SYMBOL_GPL(add_disk_randomness);
  #endif
  
index 4ffa3c26fecbe6b6f0a9873138707f65758c1e0d..9d32777feaf42d45006c52b74370441877ec907f 100644 (file)
@@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
         * file over a directory and vice versa, but if it's a directory,
         * the VFS can't check whether the victim is empty. The filesystem
 @@ -828,9 +850,14 @@ static int jffs2_rename (struct inode *o
-       if (S_ISDIR(old_dentry->d_inode->i_mode) && !victim_f)
+       if (d_is_dir(old_dentry) && !victim_f)
                inc_nlink(new_dir_i);
  
 -      /* Unlink the original */
index e987de22241ae4bcca3c3c934a77fd5a41109572..bd7a7ffdefc15d3ed12d5fa730bc661c4bc8d01c 100644 (file)
@@ -8,7 +8,7 @@
  #include <net/net_namespace.h>
  #ifdef CONFIG_SYSCTL
  #include <linux/sysctl.h>
-@@ -259,10 +260,66 @@ static int ct_open(struct inode *inode, 
+@@ -259,10 +260,66 @@ static int ct_open(struct inode *inode,
                        sizeof(struct ct_iter_state));
  }
  
index f652dafd188b2e41f26d7a84f73444b7abac1018..358d64b1a17e8ed10b61fec068a640d58cb6540c 100644 (file)
  
        counters = alloc_counters(table);
        if (IS_ERR(counters))
-@@ -966,6 +995,14 @@ copy_entries_to_user(unsigned int total_
+@@ -965,6 +994,14 @@ copy_entries_to_user(unsigned int total_
+                       ret = -EFAULT;
                        goto free_counters;
                }
++
 +              flags = e->ip.flags & IPT_F_MASK;
 +              if (copy_to_user(userptr + off
 +                               + offsetof(struct ipt_entry, ip.flags),
@@ -87,7 +88,6 @@
 +                      ret = -EFAULT;
 +                      goto free_counters;
 +              }
-+
                for (i = sizeof(struct ipt_entry);
                     i < e->target_offset;
-                    i += m->u.match_size) {
index 1eee646169eba9149cb338d0c57fdb1fb396d42e..50607cafd70230813ed79d526bcbf6873ac1ee8d 100644 (file)
@@ -37,7 +37,7 @@
        depends on NETFILTER_ADVANCED
 --- a/net/netfilter/Makefile
 +++ b/net/netfilter/Makefile
-@@ -145,6 +145,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_ESP) += 
+@@ -145,6 +145,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_ESP) +=
  obj-$(CONFIG_NETFILTER_XT_MATCH_HASHLIMIT) += xt_hashlimit.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_HELPER) += xt_helper.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_HL) += xt_hl.o
index 6fed2e1c7a4c9e4ebe4f9268e9c8ed9bf4f2963b..50e4fe4b10d9ece4ac993ea44dc97016c534c870 100644 (file)
@@ -25,7 +25,7 @@
          Ethernet bridge, which means that the different Ethernet segments it
 --- a/net/ipv6/Makefile
 +++ b/net/ipv6/Makefile
-@@ -45,6 +45,7 @@ obj-y += addrconf_core.o exthdrs_core.o 
+@@ -45,6 +45,7 @@ obj-y += addrconf_core.o exthdrs_core.o
  obj-$(CONFIG_INET) += output_core.o protocol.o $(ipv6-offload)
  
  obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_hashtables.o
index 6d00df40f833b9c8c9b2eb54a6648ce2099bbf66..f09875c02c14745009fdb3be29849b28a1d6b6f5 100644 (file)
  }
  #endif
  
-@@ -1556,6 +1584,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1556,6 +1584,7 @@ static int br_multicast_ipv4_rcv(struct
                                 struct sk_buff *skb,
                                 u16 vid)
  {
        struct sk_buff *skb2 = skb;
        const struct iphdr *iph;
        struct igmphdr *ih;
-@@ -1629,7 +1658,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1629,7 +1658,7 @@ static int br_multicast_ipv4_rcv(struct
        case IGMP_HOST_MEMBERSHIP_REPORT:
        case IGMPV2_HOST_MEMBERSHIP_REPORT:
                BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
                break;
        case IGMPV3_HOST_MEMBERSHIP_REPORT:
                err = br_ip4_multicast_igmp3_report(br, port, skb2, vid);
-@@ -1638,7 +1667,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1638,7 +1667,7 @@ static int br_multicast_ipv4_rcv(struct
                err = br_ip4_multicast_query(br, port, skb2, vid);
                break;
        case IGMP_HOST_LEAVE_MESSAGE:
                break;
        }
  
-@@ -1656,6 +1685,7 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1656,6 +1685,7 @@ static int br_multicast_ipv6_rcv(struct
                                 struct sk_buff *skb,
                                 u16 vid)
  {
        struct sk_buff *skb2;
        const struct ipv6hdr *ip6h;
        u8 icmp6_type;
-@@ -1765,7 +1795,8 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1765,7 +1795,8 @@ static int br_multicast_ipv6_rcv(struct
                }
                mld = (struct mld_msg *)skb_transport_header(skb2);
                BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
                break;
            }
        case ICMPV6_MLD2_REPORT:
-@@ -1782,7 +1813,7 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1782,7 +1813,7 @@ static int br_multicast_ipv6_rcv(struct
                        goto out;
                }
                mld = (struct mld_msg *)skb_transport_header(skb2);
index 3325462e0f43088f01bfc3d94ca10db14316cec7..68b8d5834dfd455f9c367a83a738860a0ce02555 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netlink/af_netlink.c
 +++ b/net/netlink/af_netlink.c
-@@ -1712,27 +1712,7 @@ void netlink_detachskb(struct sock *sk, 
+@@ -1712,27 +1712,7 @@ void netlink_detachskb(struct sock *sk,
  
  static struct sk_buff *netlink_trim(struct sk_buff *skb, gfp_t allocation)
  {
index 72b3dfc04d3612fc56c34ebea703fca0c0d42061..6777eecf5ab4016564c6635a037c666b106b68fd 100644 (file)
@@ -24,7 +24,7 @@ commont qdiscs.
        }
 --- a/net/sched/sch_fifo.c
 +++ b/net/sched/sch_fifo.c
-@@ -29,17 +29,21 @@ static int bfifo_enqueue(struct sk_buff 
+@@ -29,17 +29,21 @@ static int bfifo_enqueue(struct sk_buff
  
  static int pfifo_enqueue(struct sk_buff *skb, struct Qdisc *sch)
  {
index d75a02e4f80ee73e57faa12aeb41a3a9580ae0ed..41454c945bd052dfc9bdb6dc0e9338f75d2a8e3b 100644 (file)
@@ -322,7 +322,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        err = ip6_tnl_xmit2(skb, dev, dsfield, &fl6, encap_limit, &mtu);
        if (err != 0) {
                /* XXX: send ICMP error even if DF is not set. */
-@@ -1318,6 +1468,14 @@ ip6_tnl_change(struct ip6_tnl *t, const 
+@@ -1318,6 +1468,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
        t->parms.flowinfo = p->flowinfo;
        t->parms.link = p->link;
        t->parms.proto = p->proto;
index e03e45c577252d9f79b5d3c0fea59bb801663e94..5be1a5225b5033cb18951029e0f37fdf7d4d6837 100644 (file)
@@ -55,7 +55,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  
 --- a/net/ipv4/fib_semantics.c
 +++ b/net/ipv4/fib_semantics.c
-@@ -138,6 +138,10 @@ const struct fib_prop fib_props[RTN_MAX 
+@@ -138,6 +138,10 @@ const struct fib_prop fib_props[RTN_MAX
                .error  = -EINVAL,
                .scope  = RT_SCOPE_NOWHERE,
        },
index 988753edc90b407c5b27cca56e4f9c3310b8c46b..0f9e2f1c12f5d33befd3c789cbd9f358fbb7a6b9 100644 (file)
  
  #include <net/protocol.h>
  #include <net/dst.h>
-@@ -550,6 +551,22 @@ struct sk_buff *__napi_alloc_skb(struct 
+@@ -550,6 +551,22 @@ struct sk_buff *__napi_alloc_skb(struct
  }
  EXPORT_SYMBOL(__napi_alloc_skb);
  
index fc032a93c974de8eced6aadee70efb3c9c2f9824..768c80f73bab5bf819782682c5c8d26dbd10ee9c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/hostap/hostap_ap.c
 +++ b/drivers/net/wireless/hostap/hostap_ap.c
-@@ -2403,13 +2403,13 @@ int prism2_ap_get_sta_qual(local_info_t 
+@@ -2403,13 +2403,13 @@ int prism2_ap_get_sta_qual(local_info_t
                addr[count].sa_family = ARPHRD_ETHER;
                memcpy(addr[count].sa_data, sta->addr, ETH_ALEN);
                if (sta->last_rx_silence == 0)
index 9e1b8d04c7de4994600febc817e7304be252aeab..0a8b4512476f4cba5b8732ed75492a92baa9b04c 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
  #include <bcm47xx_nvram.h>
  
  static const struct bcma_device_id bgmac_bcma_tbl[] = {
-@@ -1432,6 +1433,17 @@ static void bgmac_mii_unregister(struct 
+@@ -1432,6 +1433,17 @@ static void bgmac_mii_unregister(struct
        mdiobus_free(mii_bus);
  }
  
index 2b67ae18e3c084aa4beac3c6a8829c63dff3f0da..eee15517e0318a789773ea38cc1a3e61deb3f179 100644 (file)
@@ -15,7 +15,7 @@
        default y
 --- a/drivers/pci/quirks.c
 +++ b/drivers/pci/quirks.c
-@@ -41,6 +41,7 @@ static void quirk_mmio_always_on(struct 
+@@ -41,6 +41,7 @@ static void quirk_mmio_always_on(struct
  DECLARE_PCI_FIXUP_CLASS_EARLY(PCI_ANY_ID, PCI_ANY_ID,
                                PCI_CLASS_BRIDGE_HOST, 8, quirk_mmio_always_on);
  
index 93078ccc7ae352d0aad4f380bbec45c2341530f6..ca9fd91efce5974b24c7ca3f216970a6efd5afe1 100644 (file)
                         &fib_triestat_fops))
                goto out2;
  
-@@ -2503,17 +2505,21 @@ int __net_init fib_proc_init(struct net 
+@@ -2503,17 +2505,21 @@ int __net_init fib_proc_init(struct net
        return 0;
  
  out3:
index cd7d02475811b03349000e0ac11973b08c1d35af..fad7acf3223cdf125edba92b805d8be49223cc02 100644 (file)
@@ -24,7 +24,7 @@
   * All of these routines try to estimate how many bits of randomness a
   * particular randomness source.  They do this by keeping track of the
   * first and second order deltas of the event timings.
-@@ -938,6 +948,63 @@ void add_disk_randomness(struct gendisk 
+@@ -938,6 +948,63 @@ void add_disk_randomness(struct gendisk
  EXPORT_SYMBOL_GPL(add_disk_randomness);
  #endif