clean up a bit and use plain xorg.conf-files as long as the uci x11 parser is not...
authorMirko Vogt <mirko@openwrt.org>
Mon, 4 May 2009 13:04:57 +0000 (13:04 +0000)
committerMirko Vogt <mirko@openwrt.org>
Mon, 4 May 2009 13:04:57 +0000 (13:04 +0000)
SVN-Revision: 15584

14 files changed:
Xorg/xorg/xserver/xorg-server/Makefile
Xorg/xorg/xserver/xorg-server/files/config.uci/generic [new file with mode: 0644]
Xorg/xorg/xserver/xorg-server/files/config.uci/olpc [new file with mode: 0644]
Xorg/xorg/xserver/xorg-server/files/config.uci/om_gta02 [new file with mode: 0644]
Xorg/xorg/xserver/xorg-server/files/config.xorg/generic [new file with mode: 0644]
Xorg/xorg/xserver/xorg-server/files/config.xorg/olpc [new file with mode: 0644]
Xorg/xorg/xserver/xorg-server/files/config.xorg/om_gta02 [new file with mode: 0644]
Xorg/xorg/xserver/xorg-server/files/config/generic [deleted file]
Xorg/xorg/xserver/xorg-server/files/config/olpc [deleted file]
Xorg/xorg/xserver/xorg-server/files/config/om_gta02 [deleted file]
Xorg/xorg/xserver/xorg-server/files/tmp/xorg-olpc.conf [deleted file]
Xorg/xorg/xserver/xorg-server/files/tmp/xorg-om_gta02.conf [deleted file]
Xorg/xorg/xserver/xorg-server/files/tmp/xorg.conf [deleted file]
Xorg/xorg/xserver/xorg-server/files/x.init

index f9b43bd2bff0bf70d8bcb31b6608fd7e865ba0fb..c90457477cb1bd78974f75e16d79ec70d19690a0 100644 (file)
@@ -111,15 +111,20 @@ define Build/Configure
 endef
 
 define Package/xserver-common/install
-       $(INSTALL_DIR) $(1)/etc/{init.d,config}
+       $(INSTALL_DIR) $(1)/etc/{init.d,config,X11}
        $(INSTALL_BIN) \
                ./files/x.init \
                $(1)/etc/init.d/x11
-       $(if $(X_CONFIG), \
+       $(INSTALL_DATA) ./files/tmp/x11.uci \
+               $(1)/etc/config/x11
+       test -f ./files/config.xorg/$(X_CONFIG) && \
                $(INSTALL_DATA) \
-                       ./files/config/$(X_CONFIG) \
-                       $(1)/etc/config/x11 \
-       )
+                       ./files/config.xorg/$(X_CONFIG) \
+                       $(1)/etc/X11/xorg.conf
+#      test -f ./files/config.uci/$(X_CONFIG) && \
+#              $(INSTALL_DATA) \
+#                      ./files/config.uci/$(X_CONFIG) \
+#                      $(1)/etc/config/x11
 endef
 
 define Package/xserver-xorg/install
diff --git a/Xorg/xorg/xserver/xorg-server/files/config.uci/generic b/Xorg/xorg/xserver/xorg-server/files/config.uci/generic
new file mode 100644 (file)
index 0000000..da66f66
--- /dev/null
@@ -0,0 +1,17 @@
+# Copyright (C) 2006 OpenWrt.org
+
+config screen
+       option  resolution      800x600
+       option  dpi     285
+
+config graphic
+       option  device  /dev/fb0
+
+config input mouse
+       option  device  /dev/psaux
+       option  driver  mouse
+
+config input keybd
+       option  driver  keyboard
+
+config 'desktop'
diff --git a/Xorg/xorg/xserver/xorg-server/files/config.uci/olpc b/Xorg/xorg/xserver/xorg-server/files/config.uci/olpc
new file mode 100644 (file)
index 0000000..49b7f2d
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright (C) 2006 OpenWrt.org
+
+config screen
+       option  resolution      1200x900
+       option  dpi     285
+
+config graphic
+       option  device  /dev/fb0
+
+config input mouse
+       option  device  /dev/event1
+       option  driver  tslib
+
+config 'desktop'
diff --git a/Xorg/xorg/xserver/xorg-server/files/config.uci/om_gta02 b/Xorg/xorg/xserver/xorg-server/files/config.uci/om_gta02
new file mode 100644 (file)
index 0000000..296599f
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright (C) 2006 OpenWrt.org
+
+config screen
+       option  resolution      480x640
+       option  dpi     285
+
+config graphic
+       option  device  /dev/fb0
+
+config input mouse
+       option  device  /dev/event1
+       option  driver  tslib
+
+config 'desktop'
diff --git a/Xorg/xorg/xserver/xorg-server/files/config.xorg/generic b/Xorg/xorg/xserver/xorg-server/files/config.xorg/generic
new file mode 100644 (file)
index 0000000..d9db82f
--- /dev/null
@@ -0,0 +1,64 @@
+# xorg configuration
+
+Section "ServerLayout"
+       Identifier     "Default Layout"
+       Screen      0  "Screen0" 0 0
+       InputDevice    "Mouse0" "CorePointer"
+       InputDevice    "Mouse1" "CorePointer"
+       InputDevice    "Keyboard0" "CoreKeyboard"
+EndSection
+
+Section "Module"
+       Load  "dbe"
+       Load  "extmod"
+       Load  "fbdevhw"
+#      Load  "glx"
+       Load  "record"
+       Load  "freetype"
+       Load  "type1"
+EndSection
+
+Section "InputDevice"
+       Identifier  "Keyboard0"
+       Driver      "keyboard"
+EndSection
+
+Section "InputDevice"
+       Identifier  "Mouse0"
+       Driver      "mouse"
+       Option      "Protocol" "PS/2"
+       Option      "Device" "/dev/psaux"
+EndSection
+
+Section "InputDevice"
+       Identifier  "Mouse1"
+       Driver      "mouse"
+       Option      "Protocol" "IMPS/2"
+       Option      "Device" "/dev/input/mice"
+EndSection
+
+Section "Monitor"
+       Identifier   "Monitor0"
+       VendorName   "Monitor Vendor"
+       ModelName    "OWRT"
+       Option       "dpms"
+EndSection
+
+Section "Device"
+       Identifier  "Videocard0"
+       Driver      "vesa"
+       VendorName  "Videocard vendor"
+       BoardName   "Vesa driver"
+EndSection
+
+Section "Device"
+       Identifier  "FBDev"
+       Driver      "fbdev"
+EndSection
+
+Section "Screen"
+    Identifier "Screen0"
+    Device     "Videocard0"
+    Monitor    "Monitor0"
+EndSection
+
diff --git a/Xorg/xorg/xserver/xorg-server/files/config.xorg/olpc b/Xorg/xorg/xserver/xorg-server/files/config.xorg/olpc
new file mode 100644 (file)
index 0000000..0bbb1ae
--- /dev/null
@@ -0,0 +1,78 @@
+# xorg configuration
+
+Section "ServerLayout"
+       Identifier     "Default Layout"
+       Screen      0  "Screen0" 0 0
+       InputDevice    "Mouse0" "CorePointer"
+       InputDevice    "Keyboard0" "CoreKeyboard"
+EndSection
+
+Section "Files"
+       FontPath     "/usr/lib/X11/fonts/misc"
+EndSection
+
+Section "Module"
+       Load  "dbe"
+       Load  "extmod"
+       Load  "fbdevhw"
+#      Load  "glx"
+       Load  "record"
+       Load  "freetype"
+       Load  "type1"
+EndSection
+
+Section "InputDevice"
+       Identifier  "Keyboard0"
+       Driver      "keyboard"
+       Option      "XkbModel" "pc105"
+       Option      "XkbLayout" "us"
+EndSection
+
+Section "InputDevice"
+       Identifier  "Mouse0"
+       Driver      "mouse"
+#      Option      "Protocol" "PS/2"
+       Option      "Protocol" "IMPS/2"
+#      Option      "Device" "/dev/psaux"
+       Option      "Device" "/dev/mice"
+#      Option      "ZAxisMapping" "4 5"
+#      Option      "Emulate3Buttons" "yes"
+EndSection
+
+Section "Monitor"
+       Identifier   "Monitor0"
+       HorizSync    30-67
+       VertRefresh  48-52
+       DisplaySize  152 114
+       Mode "1200x900"
+               DotClock 57.275
+               HTimings 1200 1208 1216 1240
+               VTimings 900 905 908 912
+               Flags    "-HSync" "-VSync"
+       EndMode
+EndSection
+
+Section "Device"
+       Identifier  "Videocard0"
+       Driver      "geode"
+       Option      "PanelGeometry" "1200x900"
+EndSection
+
+Section "Screen"
+    Identifier "Screen0"
+    Device     "Videocard0"
+    Monitor    "Monitor0"
+    DefaultDepth 16
+
+    SubSection "Display"
+        Depth          16
+        Modes          "1200x900"
+    EndSubsection
+
+EndSection
+
+Section "DRI"
+       Group        0
+       Mode         0666
+EndSection
+
diff --git a/Xorg/xorg/xserver/xorg-server/files/config.xorg/om_gta02 b/Xorg/xorg/xserver/xorg-server/files/config.xorg/om_gta02
new file mode 100644 (file)
index 0000000..1e84135
--- /dev/null
@@ -0,0 +1,34 @@
+# xorg configuration
+
+Section "ServerLayout"
+        Identifier     "Default Layout"
+        Screen      0  "Screen0" 0 0
+        InputDevice    "Mouse0" "CorePointer"
+EndSection
+
+Section "InputDevice"
+        Identifier  "Mouse0"
+        Driver      "tslib"
+        Option      "Device" "/dev/event1"
+        Option      "Width" "480"
+        Option      "Height" "640"
+EndSection
+
+Section "Monitor"
+        Identifier   "Monitor0"
+        VendorName   "Monitor Vendor"
+        ModelName    "OWRT"
+        Option       "dpms"
+EndSection
+
+Section "Device"
+        Identifier  "Videocard0"
+        Driver      "glamo"
+EndSection
+
+Section "Screen"
+    Identifier  "Screen0"
+    Device      "Videocard0"
+    Monitor     "Monitor0"
+    DefaultDepth 16
+EndSection
diff --git a/Xorg/xorg/xserver/xorg-server/files/config/generic b/Xorg/xorg/xserver/xorg-server/files/config/generic
deleted file mode 100644 (file)
index da66f66..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright (C) 2006 OpenWrt.org
-
-config screen
-       option  resolution      800x600
-       option  dpi     285
-
-config graphic
-       option  device  /dev/fb0
-
-config input mouse
-       option  device  /dev/psaux
-       option  driver  mouse
-
-config input keybd
-       option  driver  keyboard
-
-config 'desktop'
diff --git a/Xorg/xorg/xserver/xorg-server/files/config/olpc b/Xorg/xorg/xserver/xorg-server/files/config/olpc
deleted file mode 100644 (file)
index 49b7f2d..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright (C) 2006 OpenWrt.org
-
-config screen
-       option  resolution      1200x900
-       option  dpi     285
-
-config graphic
-       option  device  /dev/fb0
-
-config input mouse
-       option  device  /dev/event1
-       option  driver  tslib
-
-config 'desktop'
diff --git a/Xorg/xorg/xserver/xorg-server/files/config/om_gta02 b/Xorg/xorg/xserver/xorg-server/files/config/om_gta02
deleted file mode 100644 (file)
index 296599f..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright (C) 2006 OpenWrt.org
-
-config screen
-       option  resolution      480x640
-       option  dpi     285
-
-config graphic
-       option  device  /dev/fb0
-
-config input mouse
-       option  device  /dev/event1
-       option  driver  tslib
-
-config 'desktop'
diff --git a/Xorg/xorg/xserver/xorg-server/files/tmp/xorg-olpc.conf b/Xorg/xorg/xserver/xorg-server/files/tmp/xorg-olpc.conf
deleted file mode 100644 (file)
index 0bbb1ae..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-# xorg configuration
-
-Section "ServerLayout"
-       Identifier     "Default Layout"
-       Screen      0  "Screen0" 0 0
-       InputDevice    "Mouse0" "CorePointer"
-       InputDevice    "Keyboard0" "CoreKeyboard"
-EndSection
-
-Section "Files"
-       FontPath     "/usr/lib/X11/fonts/misc"
-EndSection
-
-Section "Module"
-       Load  "dbe"
-       Load  "extmod"
-       Load  "fbdevhw"
-#      Load  "glx"
-       Load  "record"
-       Load  "freetype"
-       Load  "type1"
-EndSection
-
-Section "InputDevice"
-       Identifier  "Keyboard0"
-       Driver      "keyboard"
-       Option      "XkbModel" "pc105"
-       Option      "XkbLayout" "us"
-EndSection
-
-Section "InputDevice"
-       Identifier  "Mouse0"
-       Driver      "mouse"
-#      Option      "Protocol" "PS/2"
-       Option      "Protocol" "IMPS/2"
-#      Option      "Device" "/dev/psaux"
-       Option      "Device" "/dev/mice"
-#      Option      "ZAxisMapping" "4 5"
-#      Option      "Emulate3Buttons" "yes"
-EndSection
-
-Section "Monitor"
-       Identifier   "Monitor0"
-       HorizSync    30-67
-       VertRefresh  48-52
-       DisplaySize  152 114
-       Mode "1200x900"
-               DotClock 57.275
-               HTimings 1200 1208 1216 1240
-               VTimings 900 905 908 912
-               Flags    "-HSync" "-VSync"
-       EndMode
-EndSection
-
-Section "Device"
-       Identifier  "Videocard0"
-       Driver      "geode"
-       Option      "PanelGeometry" "1200x900"
-EndSection
-
-Section "Screen"
-    Identifier "Screen0"
-    Device     "Videocard0"
-    Monitor    "Monitor0"
-    DefaultDepth 16
-
-    SubSection "Display"
-        Depth          16
-        Modes          "1200x900"
-    EndSubsection
-
-EndSection
-
-Section "DRI"
-       Group        0
-       Mode         0666
-EndSection
-
diff --git a/Xorg/xorg/xserver/xorg-server/files/tmp/xorg-om_gta02.conf b/Xorg/xorg/xserver/xorg-server/files/tmp/xorg-om_gta02.conf
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/Xorg/xorg/xserver/xorg-server/files/tmp/xorg.conf b/Xorg/xorg/xserver/xorg-server/files/tmp/xorg.conf
deleted file mode 100644 (file)
index ee03228..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
-# xorg configuration
-
-Section "ServerLayout"
-       Identifier     "Default Layout"
-       Screen      0  "Screen0" 0 0
-       InputDevice    "Mouse0" "CorePointer"
-       InputDevice    "Keyboard0" "CoreKeyboard"
-EndSection
-
-Section "Files"
-       FontPath     "/usr/lib/X11/fonts/misc"
-EndSection
-
-Section "Module"
-       Load  "dbe"
-       Load  "extmod"
-       Load  "fbdevhw"
-#      Load  "glx"
-       Load  "record"
-       Load  "freetype"
-       Load  "type1"
-EndSection
-
-Section "InputDevice"
-       Identifier  "Keyboard0"
-       Driver      "keyboard"
-       Option      "XkbModel" "pc105"
-       Option      "XkbLayout" "us"
-EndSection
-
-Section "InputDevice"
-       Identifier  "Mouse0"
-       Driver      "mouse"
-       Option      "Protocol" "PS/2"
-#      Option      "Protocol" "IMPS/2"
-       Option      "Device" "/dev/psaux"
-#      Option      "Device" "/dev/input/mice"
-       Option      "ZAxisMapping" "4 5"
-       Option      "Emulate3Buttons" "yes"
-EndSection
-
-Section "Monitor"
-       Identifier   "Monitor0"
-       VendorName   "Monitor Vendor"
-       ModelName    "OWRT"
-       Option       "dpms"
-EndSection
-
-Section "Device"
-       Identifier  "Videocard0"
-       Driver      "vesa"
-       VendorName  "Videocard vendor"
-       BoardName   "Vesa driver"
-EndSection
-
-Section "Device"
-       Identifier  "FBDev"
-       Driver      "fbdev"
-       #Option     "shadowfb" "off"
-       VideoRam    4096
-EndSection
-
-Section "Screen"
-    Identifier "Screen0"
-    Device     "Videocard0"
-    Monitor    "Monitor0"
-#    DefaultDepth 8
-    DefaultDepth 16
-#    DefaultDepth 24
-
-    SubSection "Display"
-        Depth          8
-        Modes          "1024x768" "800x600" "640x480"
-    EndSubsection
-
-    SubSection "Display"
-        Depth          16
-        Modes          "1024x768" "800x600" "640x480"
-    EndSubsection
-
-    SubSection "Display"
-        Depth          24
-       FbBpp           32
-        Modes          "1024x768" "800x600" "640x480"
-    EndSubsection
-
-EndSection
-
-Section "DRI"
-       Group        0
-       Mode         0666
-EndSection
-
index 6571696e516000ef0eff90f721427466174f988d..ac2e982d6529731f364e268dd4e921eab56b61d4 100755 (executable)
@@ -4,28 +4,28 @@ START=99
 
 ARGS=""
 
-screen() {
-       local cfg="$1"
-       config_get resolution $cfg resolution
-       config_get dpi $cfg dpi
-       [ -n "$resolution" ] && ARGS="$ARGS -screen $resolution"
-       [ -n "$dpi" ] && ARGS="$ARGS -dpi $dpi"
-}
-
-graphic() {
-       local cfg="$1"
-       config_get device $cfg device
-       [ -n "$device" ] && ARGS="$ARGS -fb $device"
-}
-
-input() {
-       local cfg="$1"
-       config_get device $cfg device
-       config_get driver $cfg driver
-       #[ -n "$device" ] || return 0
-       [ -n "$driver" ] || return 0
-       ARGS="$ARGS -$cfg $driver,,device=$device"
-}
+#screen() {
+#      local cfg="$1"
+#      config_get resolution $cfg resolution
+#      config_get dpi $cfg dpi
+#      [ -n "$resolution" ] && ARGS="$ARGS -screen $resolution"
+#      [ -n "$dpi" ] && ARGS="$ARGS -dpi $dpi"
+#}
+#
+#graphic() {
+#      local cfg="$1"
+#      config_get device $cfg device
+#      [ -n "$device" ] && ARGS="$ARGS -fb $device"
+#}
+#
+#input() {
+#      local cfg="$1"
+#      config_get device $cfg device
+#      config_get driver $cfg driver
+#      #[ -n "$device" ] || return 0
+#      [ -n "$driver" ] || return 0
+#      ARGS="$ARGS -$cfg $driver,,device=$device"
+#}
 
 desktop() {
        local cfg="$1"
@@ -38,14 +38,14 @@ desktop() {
 start() {
        export DISPLAY=":0"
        config_load x11
-       config_foreach screen screen
-       config_foreach graphic graphic
-       config_foreach input input
+#      config_foreach screen screen
+#      config_foreach graphic graphic
+#      config_foreach input input
        Xorg $ARGS &
        sleep 1 # give the xserver some time get initialized
        config_foreach desktop desktop
        test -d /etc/xdg/autostart || exit
-       sleep 1 # give the first x11 application some time to get present - afterwars we'll start the x11 autostart applications
+       sleep 1 # give the first x11 application some time to get present - afterwards we'll start the x11 autostart applications
        for elem in `ls /etc/xdg/autostart/`; do
                if grep "^Hidden=true" "/etc/xdg/autostart/$elem" > /dev/null; then
                        continue