kernel: update 3.14 to 3.14.10
authorLuka Perkov <luka@openwrt.org>
Sun, 6 Jul 2014 18:10:49 +0000 (18:10 +0000)
committerLuka Perkov <luka@openwrt.org>
Sun, 6 Jul 2014 18:10:49 +0000 (18:10 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 41533

include/kernel-version.mk
target/linux/generic/patches-3.14/645-bridge_multicast_to_unicast.patch
target/linux/generic/patches-3.14/811-pci_disable_usb_common_quirks.patch
target/linux/generic/patches-3.14/996-zsmalloc_allow_module_build.patch
target/linux/mvebu/Makefile
target/linux/x86_64/Makefile

index 21b501176c4e3eae1ce0dcf42b286539866bd6d9..4fc48bf9c19f4da4e2452e2bde4239278f80b914 100644 (file)
@@ -23,8 +23,8 @@ endif
 ifeq ($(LINUX_VERSION),3.13.7)
   LINUX_KERNEL_MD5SUM:=370adced5e5c1cb1d0d621c2dae2723f
 endif
-ifeq ($(LINUX_VERSION),3.14.9)
-  LINUX_KERNEL_MD5SUM:=62b80f9ab490db3bfe0b308a0d3f6f1f
+ifeq ($(LINUX_VERSION),3.14.10)
+  LINUX_KERNEL_MD5SUM:=3ca34a93c59a788d7f573b2660eb5342
 endif
 
 # disable the md5sum check for unknown kernel versions
index b550120b7bec170eea76ddd1f2f770da3fb3afc0..a9612f05592f87ece52d031c08ed4872dde374c1 100644 (file)
  }
  #endif
  
-@@ -1465,6 +1492,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1465,6 +1492,7 @@ static int br_multicast_ipv4_rcv(struct
                                 struct sk_buff *skb,
                                 u16 vid)
  {
        struct sk_buff *skb2 = skb;
        const struct iphdr *iph;
        struct igmphdr *ih;
-@@ -1538,7 +1566,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1538,7 +1566,7 @@ static int br_multicast_ipv4_rcv(struct
        case IGMP_HOST_MEMBERSHIP_REPORT:
        case IGMPV2_HOST_MEMBERSHIP_REPORT:
                BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
                break;
        case IGMPV3_HOST_MEMBERSHIP_REPORT:
                err = br_ip4_multicast_igmp3_report(br, port, skb2, vid);
-@@ -1547,7 +1575,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1547,7 +1575,7 @@ static int br_multicast_ipv4_rcv(struct
                err = br_ip4_multicast_query(br, port, skb2, vid);
                break;
        case IGMP_HOST_LEAVE_MESSAGE:
                break;
        }
  
-@@ -1565,6 +1593,7 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1565,6 +1593,7 @@ static int br_multicast_ipv6_rcv(struct
                                 struct sk_buff *skb,
                                 u16 vid)
  {
        struct sk_buff *skb2;
        const struct ipv6hdr *ip6h;
        u8 icmp6_type;
-@@ -1674,7 +1703,8 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1674,7 +1703,8 @@ static int br_multicast_ipv6_rcv(struct
                }
                mld = (struct mld_msg *)skb_transport_header(skb2);
                BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
                break;
            }
        case ICMPV6_MLD2_REPORT:
-@@ -1691,7 +1721,7 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1691,7 +1721,7 @@ static int br_multicast_ipv6_rcv(struct
                        goto out;
                }
                mld = (struct mld_msg *)skb_transport_header(skb2);
index 352c814b5412e1d834afc7aee6659e358f2d0578..b85ac69580eb57a2f5d9bf15596479f75e4f23d0 100644 (file)
@@ -39,7 +39,7 @@
  static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
  {
        u16 cmd;
-@@ -1070,3 +1085,4 @@ static void quirk_usb_early_handoff(stru
+@@ -1083,3 +1098,4 @@ static void quirk_usb_early_handoff(stru
  }
  DECLARE_PCI_FIXUP_CLASS_FINAL(PCI_ANY_ID, PCI_ANY_ID,
                        PCI_CLASS_SERIAL_USB, 8, quirk_usb_early_handoff);
index ea6d4449f65ab80622da7c69290dd4cae3ea1e09..8ff2b691e9a4c82ef7e65cec3be08e73c7995abb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/mm/Kconfig
 +++ b/mm/Kconfig
-@@ -554,7 +554,7 @@ config MEM_SOFT_DIRTY
+@@ -557,7 +557,7 @@ config MEM_SOFT_DIRTY
          See Documentation/vm/soft-dirty.txt for more details.
  
  config ZSMALLOC
index 177107c5c7404616545616395904ab0c0d3b2ff3..0252849c06083ae0255f318055397452a4025cca 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.14.9
+LINUX_VERSION:=3.14.10
 
 include $(INCLUDE_DIR)/target.mk
 
index f5aa422a81340a90aa9646894f42b1e2f861948e..600401207d44d0b296d39a8e35f7c267f3ce5cee 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86_64
 FEATURES:=ext4 vdi vmdk targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.14.9
+LINUX_VERSION:=3.14.10
 
 KERNELNAME:=bzImage