rename glib package from liblib1 to glib1 and fix dependencies on it
authorNicolas Thill <nico@openwrt.org>
Tue, 8 Aug 2006 01:13:52 +0000 (01:13 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 8 Aug 2006 01:13:52 +0000 (01:13 +0000)
SVN-Revision: 4514

libs/glib/Makefile
net/bitlbee/Makefile
net/irssi/Makefile
net/nocatsplash/Makefile

index 82691af6176f7b5619eb2ff542346de55040007e..b60f5f05a600821d1ceecf821583358d11355ff1 100644 (file)
@@ -25,7 +25,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/libglib1
+define Package/glib1
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=+libpthread
@@ -94,7 +94,7 @@ define Build/Compile
                install
 endef
 
-define Package/libglib1/install
+define Package/glib1/install
        install -m0755 -d $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libg{lib,module,thread}-1.2.so.* $(1)/usr/lib/
 endef
@@ -123,4 +123,4 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/lib/pkgconfig/g{lib,module,thread}.pc
 endef
 
-$(eval $(call BuildPackage,libglib1))
+$(eval $(call BuildPackage,glib1))
index 57598c2490ff489418cb078f4865de143259045d..a11831a7ca6dd98ddc33389bc41d822d21355096 100644 (file)
@@ -29,7 +29,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/bitlbee
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libopenssl +libglib1 +libiconv
+  DEPENDS:=+libopenssl +glib1 +libiconv
   TITLE:=IRC gateway to IM chat networks
   DESCRIPTION:=IRC gateway to IM chat networks
   URL:=http://www.bitlbee.org/
index 7613a42eac44a555960322126db3dd718506e7df..3f815fe0e7ec62339b9e1a141f0e5e7ba2d6a9fc 100644 (file)
@@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/irssi
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+glib +libncurses
+  DEPENDS:=+glib1 +libncurses
   TITLE:=console irc client
   DESCRIPTION:=IRC client for the text console
   URL:=http://irssi.org
index 2dd588425709d7d81d988501047068e88f499b83..5cd7d05b31f7fdb5035748496b70794c2f492c9a 100644 (file)
@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/nocatsplash
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+glib
+  DEPENDS:=+glib1
   TITLE:=Open public network gateway daemon
   DESCRIPTION:=NoCatSplash is an Open Public Network Gateway Daemon.\\\
        It performs as a [captive/open/active] portal. When run on a gateway/router\\\