Update kernel configuration and add profiles and per-profile kernel configuration...
authorFlorian Fainelli <florian@openwrt.org>
Tue, 28 Oct 2008 18:54:35 +0000 (18:54 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 28 Oct 2008 18:54:35 +0000 (18:54 +0000)
SVN-Revision: 13064

target/linux/rdc/config-2.6.24
target/linux/rdc/config/profile-ar525w [new file with mode: 0644]
target/linux/rdc/config/profile-wl153 [new file with mode: 0644]
target/linux/rdc/profiles/AMIT.mk [new file with mode: 0644]
target/linux/rdc/profiles/G-570S.mk [new file with mode: 0644]

index a033d5d3662dff559ab28fc53e92e90bcfeedc2a..277198516576d911c8664803bd3e75c12017fa6d 100644 (file)
@@ -23,6 +23,7 @@ CONFIG_BITREVERSE=y
 CONFIG_BLK_DEV_IDE=m
 CONFIG_BLK_DEV_IDEDISK=m
 # CONFIG_BLK_DEV_IDEDMA is not set
 CONFIG_BLK_DEV_IDE=m
 CONFIG_BLK_DEV_IDEDISK=m
 # CONFIG_BLK_DEV_IDEDMA is not set
+# CONFIG_BLK_DEV_INITRD is not set
 CONFIG_BLK_DEV_RAM=y
 CONFIG_BLK_DEV_RAM_BLOCKSIZE=1024
 CONFIG_BLK_DEV_RAM_COUNT=16
 CONFIG_BLK_DEV_RAM=y
 CONFIG_BLK_DEV_RAM_BLOCKSIZE=1024
 CONFIG_BLK_DEV_RAM_COUNT=16
@@ -106,7 +107,6 @@ CONFIG_IDE_ARCH_OBSOLETE_INIT=y
 # CONFIG_IDE_ARM is not set
 # CONFIG_IDE_GENERIC is not set
 # CONFIG_IDE_PROC_FS is not set
 # CONFIG_IDE_ARM is not set
 # CONFIG_IDE_GENERIC is not set
 # CONFIG_IDE_PROC_FS is not set
-CONFIG_INITRAMFS_SOURCE=""
 CONFIG_INPUT=m
 # CONFIG_INPUT_GPIO_BUTTONS is not set
 CONFIG_INPUT_MISC=y
 CONFIG_INPUT=m
 # CONFIG_INPUT_GPIO_BUTTONS is not set
 CONFIG_INPUT_MISC=y
@@ -119,7 +119,9 @@ CONFIG_ISA_DMA_API=y
 # CONFIG_IT8712F_WDT is not set
 # CONFIG_ITCO_WDT is not set
 CONFIG_JFS_FS=m
 # CONFIG_IT8712F_WDT is not set
 # CONFIG_ITCO_WDT is not set
 CONFIG_JFS_FS=m
+CONFIG_KALLSYMS=y
 CONFIG_KEXEC=y
 CONFIG_KEXEC=y
+# CONFIG_KPROBES is not set
 CONFIG_KTIME_SCALAR=y
 # CONFIG_KVM is not set
 CONFIG_LBD=y
 CONFIG_KTIME_SCALAR=y
 # CONFIG_KVM is not set
 CONFIG_LBD=y
@@ -170,7 +172,7 @@ CONFIG_MTD_CFI_I2=y
 # CONFIG_MTD_CFI_STAA is not set
 CONFIG_MTD_CFI_UTIL=y
 CONFIG_MTD_CHAR=y
 # CONFIG_MTD_CFI_STAA is not set
 CONFIG_MTD_CFI_UTIL=y
 CONFIG_MTD_CHAR=y
-CONFIG_MTD_CMDLINE_PARTS=y
+# CONFIG_MTD_CMDLINE_PARTS is not set
 # CONFIG_MTD_COMPLEX_MAPPINGS is not set
 CONFIG_MTD_CONCAT=y
 # CONFIG_MTD_DEBUG is not set
 # CONFIG_MTD_COMPLEX_MAPPINGS is not set
 CONFIG_MTD_CONCAT=y
 # CONFIG_MTD_DEBUG is not set
@@ -190,17 +192,15 @@ CONFIG_MTD_MAP_BANK_WIDTH_4=y
 # CONFIG_MTD_ONENAND is not set
 CONFIG_MTD_PARTITIONS=y
 # CONFIG_MTD_PHRAM is not set
 # CONFIG_MTD_ONENAND is not set
 CONFIG_MTD_PARTITIONS=y
 # CONFIG_MTD_PHRAM is not set
-# CONFIG_MTD_PHYSMAP is not set
+CONFIG_MTD_PHYSMAP=y
+CONFIG_MTD_PHYSMAP_BANKWIDTH=2
+CONFIG_MTD_PHYSMAP_LEN=0
+CONFIG_MTD_PHYSMAP_START=0x8000000
 # CONFIG_MTD_PLATRAM is not set
 # CONFIG_MTD_PMC551 is not set
 # CONFIG_MTD_PNC2000 is not set
 # CONFIG_MTD_RAM is not set
 # CONFIG_MTD_PLATRAM is not set
 # CONFIG_MTD_PMC551 is not set
 # CONFIG_MTD_PNC2000 is not set
 # CONFIG_MTD_RAM is not set
-CONFIG_MTD_RDC3210=y
-CONFIG_MTD_RDC3210_ALLOW_JFFS2=y
-CONFIG_MTD_RDC3210_BUSWIDTH=2
-# CONFIG_MTD_RDC3210_FACTORY_PRESENT is not set
-CONFIG_MTD_RDC3210_SIZE=0x400000
-# CONFIG_MTD_RDC3210_STATIC_MAP is not set
+# CONFIG_MTD_RDC3210 is not set
 # CONFIG_MTD_REDBOOT_PARTS is not set
 # CONFIG_MTD_ROM is not set
 # CONFIG_MTD_SC520CDP is not set
 # CONFIG_MTD_REDBOOT_PARTS is not set
 # CONFIG_MTD_ROM is not set
 # CONFIG_MTD_SC520CDP is not set
@@ -215,6 +215,7 @@ CONFIG_MTD_RDC3210_SIZE=0x400000
 # CONFIG_NATSEMI is not set
 # CONFIG_NE2K_PCI is not set
 # CONFIG_NET_VENDOR_3COM is not set
 # CONFIG_NATSEMI is not set
 # CONFIG_NE2K_PCI is not set
 # CONFIG_NET_VENDOR_3COM is not set
+CONFIG_NF_CONNTRACK=y
 CONFIG_NLS_ISO8859_2=m
 CONFIG_NOHIGHMEM=y
 CONFIG_NO_HZ=y
 CONFIG_NLS_ISO8859_2=m
 CONFIG_NOHIGHMEM=y
 CONFIG_NO_HZ=y
diff --git a/target/linux/rdc/config/profile-ar525w b/target/linux/rdc/config/profile-ar525w
new file mode 100644 (file)
index 0000000..2fb8e7d
--- /dev/null
@@ -0,0 +1,6 @@
+CONFIG_MTD_RDC3210=y
+CONFIG_MTD_RDC3210_ALLOW_JFFS2=y
+CONFIG_MTD_RDC3210_BUSWIDTH=2
+# CONFIG_MTD_RDC3210_FACTORY_PRESENT is not set
+CONFIG_MTD_RDC3210_SIZE=0x400000
+# CONFIG_MTD_RDC3210_STATIC_MAP is not set
diff --git a/target/linux/rdc/config/profile-wl153 b/target/linux/rdc/config/profile-wl153
new file mode 100644 (file)
index 0000000..a532c20
--- /dev/null
@@ -0,0 +1,6 @@
+CONFIG_MTD_RDC3210=y
+CONFIG_MTD_RDC3210_ALLOW_JFFS2=y
+CONFIG_MTD_RDC3210_BUSWIDTH=2
+# CONFIG_MTD_RDC3210_FACTORY_PRESENT is not set
+CONFIG_MTD_RDC3210_SIZE=0x200000
+# CONFIG_MTD_RDC3210_STATIC_MAP is not set
diff --git a/target/linux/rdc/profiles/AMIT.mk b/target/linux/rdc/profiles/AMIT.mk
new file mode 100644 (file)
index 0000000..2e3d873
--- /dev/null
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/amit
+  NAME:=Devices from AMIT
+  PACKAGES:=kmod-r6040 kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+$(eval $(call Profile,amit))
+
diff --git a/target/linux/rdc/profiles/G-570S.mk b/target/linux/rdc/profiles/G-570S.mk
new file mode 100644 (file)
index 0000000..4cb9bd9
--- /dev/null
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/g570s
+  NAME:=ZyXEL G-570S
+  PACKAGES:=kmod-madwifi kmod-r6040
+endef
+$(eval $(call Profile,g570s))
+