[package] add serial and usb version of the digitemp package (#4717)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 26 Jul 2009 17:59:49 +0000 (17:59 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 26 Jul 2009 17:59:49 +0000 (17:59 +0000)
SVN-Revision: 17020

utils/digitemp/Makefile

index 0a4ba64882f32cdd22c136702f77606545b80d1e..d5ca41ff05886373e2cecee5b1c3cf3de3250ad5 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=digitemp
 PKG_VERSION:=3.6.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.digitemp.com/software/linux
@@ -18,21 +18,48 @@ PKG_MD5SUM:=9be2e48db37920f21925ae6e88f83b84
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/digitemp
+define Package/digitemp/Default
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=DigiTemp is a simple to use program for reading values from 1-wire devices.
-  DEPENDS:=+libusb
   URL:=http://www.digitemp.com
 endef
 
-define Package/digitemp/description
+define Package/digitemp/Default/description
        DigiTemp is a simple to use program for reading values from 1-wire devices.
        Its main use is for reading temperature sensors, but it also reads counters,
        and understands the 1-wire hubs with devices on different branches of the network.
 endef
 
+define Package/digitemp
+$(call Package/digitemp/Default)
+  TITLE += (serial version)
+endef
+
+define Package/digitemp/description
+$(call Package/digitemp/Default/description)
+       This package is build without USB support.
+endef
+
+define Package/digitemp-usb
+$(call Package/digitemp/Default)
+  TITLE += (USB version)
+  DEPENDS += +libusb
+endef
+
+define Package/digitemp-usb/description
+$(call Package/digitemp/Default/description)
+       This package is build with USB support.
+endef
+
 define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) -DLINUX $(TARGET_CPPFLAGS) \
+                       -I./src -I./userial" \
+               LIBS="$(TARGET_LDFLAGS) -lusb -lm" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               ds9097
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -DLINUX $(TARGET_CPPFLAGS) \
@@ -44,7 +71,13 @@ endef
 
 define Package/digitemp/install        
        mkdir -p $(1)/usr/bin/
-       $(CP) $(PKG_BUILD_DIR)/digitemp_DS2490 $(1)/usr/bin/
+       $(CP) $(PKG_BUILD_DIR)/digitemp_DS9097 $(1)/usr/bin/
+endef
+
+define Package/digitemp-usb/install    
+       mkdir -p $(1)/usr/bin/
+       $(CP) $(PKG_BUILD_DIR)/digitemp_DS9097 $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,digitemp))
+$(eval $(call BuildPackage,digitemp-usb))