oxnas: fix gpio-fan on kd20
authorJohn Crispin <john@openwrt.org>
Sat, 13 Dec 2014 08:04:54 +0000 (08:04 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 13 Dec 2014 08:04:54 +0000 (08:04 +0000)
define speed-map and include kmod-hwmon-gpiofan in kd20 profile

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
SVN-Revision: 43678

target/linux/oxnas/files/arch/arm/boot/dts/ox820-kd20.dts
target/linux/oxnas/profiles/100-Generic.mk

index 9375748b91bd30869f84cdf6d48fb0418dfa09b0..217d812b96371d69f740b2ee07c58f1c5715f47b 100644 (file)
        gpio-fan {
                compatible = "gpio-fan";
                gpios = <&GPIOA 2 1>;
+               gpio-fan,speed-map = <0    0
+                                     3000 1>;
        };
 
        gpio-poweroff {
index 6681c23cb9f19ec34acd146e283d4cb568a832aa..5304839754df0a105924366efb4b4124b01ce17c 100644 (file)
@@ -35,7 +35,7 @@ define Profile/KD20
   NAME:=Shuttle KD20
   PACKAGES:= \
        kmod-usb3 kmod-usb-storage kmod-i2c-gpio kmod-rtc-pcf8563 \
-       kmod-gpio-beeper
+       kmod-gpio-beeper kmod-hwmon-core kmod-hwmon-gpiofan
 endef
 
 define Profile/KD20/Description