fix elinks, add MD5SUM, explicitely disable what seems not required,
authorNicolas Thill <nico@openwrt.org>
Mon, 27 Mar 2006 21:18:37 +0000 (21:18 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 27 Mar 2006 21:18:37 +0000 (21:18 +0000)
standardize.

SVN-Revision: 3511

openwrt/package/elinks/Makefile
openwrt/package/elinks/patches/01-missing_decl_for_off_t.patch [new file with mode: 0644]

index 07fc51606c922766c6a4143d91809f27ada319d8..d06b3ebb3a995157553890221aed0d899670a923 100644 (file)
@@ -5,6 +5,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=elinks
 PKG_VERSION:=0.11.1
 PKG_RELEASE:=1
 PKG_NAME:=elinks
 PKG_VERSION:=0.11.1
 PKG_RELEASE:=1
+PKG_MD5SUM:=c09d726075e4b5810fa07f8654088755
 
 PKG_SOURCE_URL:=http://elinks.or.cz/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 
 PKG_SOURCE_URL:=http://elinks.or.cz/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -19,28 +20,54 @@ $(eval $(call PKG_template,ELINKS,elinks,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
 
 $(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
-               x=`echo ac_cv_file_$(PKG_BUILD_DIR)/features.conf | tr [:blank:]-/. _` && export $${x}=yes && \
+                x=`echo ac_cv_file_./features.conf | tr [:blank:]-/. _` && export $${x}=yes && \
+                x=`echo ac_cv_file_$(PKG_BUILD_DIR)/features.conf | tr [:blank:]-/. _` && export $${x}=yes && \
                $(TARGET_CONFIGURE_OPTS) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
-               ac_cv_c_bigendian=no \
-               ac_cv_sizeof_off_t=8 \
-               ac_cv_file___features_conf=yes \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                ./configure \
                ./configure \
-               --target=$(GNU_TARGET_NAME) \
-               --host=$(GNU_TARGET_NAME) \
-               --build=$(GNU_HOST_NAME) \
-               --disable-largefile\
-               --disable-formhist\
-               --disable-mailcap\
-               --disable-data\
-               --disable-uri-rewrite\
-               --enable-256-colors\
-               --disable-backtrace\
-               --enable-small\
-               --without-spidermonkey\
-               --without-x\
-               --disable-ipv6 \
-               $(DISABLE_NLS) \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-small\
+                       --enable-256-colors\
+                       --disable-backtrace\
+                       --disable-data\
+                       --disable-formhist\
+                       --disable-leds \
+                       --disable-mailcap\
+                       --disable-mouse \
+                       --disable-smb \
+                       --disable-uri-rewrite\
+                       --disable-xbel \
+                       --without-bzlib \
+                       --without-gpm \
+                       --without-idn \
+                       --without-gnutls \
+                       --without-libiconv \
+                       --without-lua \
+                       --with-openssl="$(STAGING_DIR)/usr" \
+                       --without-spidermonkey\
+                       --without-x\
+                       --without-zlib \
+                       --disable-ipv6 \
        );
        touch $@
 
        );
        touch $@
 
diff --git a/openwrt/package/elinks/patches/01-missing_decl_for_off_t.patch b/openwrt/package/elinks/patches/01-missing_decl_for_off_t.patch
new file mode 100644 (file)
index 0000000..4393e31
--- /dev/null
@@ -0,0 +1,11 @@
+diff -ruN elinks-0.11.1-old/src/util/time.h elinks-0.11.1-new/src/util/time.h
+--- elinks-0.11.1-old/src/util/time.h  2006-01-29 14:10:39.000000000 +0100
++++ elinks-0.11.1-new/src/util/time.h  2006-03-27 23:09:08.000000000 +0200
+@@ -1,6 +1,7 @@
+ #ifndef EL__UTIL_TIME_H
+ #define EL__UTIL_TIME_H
++#include <sys/types.h>
+ #ifdef HAVE_SYS_TIME_H
+ #include <sys/time.h>
+ #endif