lantiq: move esi calls to dsl_cpe_control scripts to fix ordering wrt. loading vr9...
authorFelix Fietkau <nbd@openwrt.org>
Fri, 4 Dec 2015 17:42:51 +0000 (17:42 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 4 Dec 2015 17:42:51 +0000 (17:42 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47764

package/network/config/ltq-adsl-app/files/dsl_control
package/network/config/ltq-vdsl-app/Makefile
package/network/config/ltq-vdsl-app/files/vdsl_cpe_control_wrapper
target/linux/lantiq/base-files/etc/init.d/esi [deleted file]
target/linux/lantiq/xrx200/target.mk
target/linux/lantiq/xway/target.mk

index cece347b85dc04690a0445f16e99bd345aef9b56..0c7221c24fe4bf353df196ec3cf862649b2f7bba 100644 (file)
@@ -44,6 +44,8 @@ start() {
                return 1
        }
 
+       esi $(printf '%012X' $((1+0x$(tr -d : </sys/class/net/eth0/address))))
+
        service_start /sbin/dsl_cpe_control -i${xtu} \
                        -n /sbin/dsl_notify.sh \
                        -f ${firmware}
index 51c2aff9a1ff482a67d874cd85be504f82751215..db4e0bbd4e580c6cad33bc13c559e4e99f7871dd 100644 (file)
@@ -26,7 +26,7 @@ define Package/ltq-vdsl-app
   CATEGORY:=Network
   TITLE:=Lantiq VDSL userland tool
   URL:=http://www.lantiq.com/
-  DEPENDS:=@TARGET_lantiq_xrx200 +libpthread +librt
+  DEPENDS:=@TARGET_lantiq_xrx200 +libpthread +librt +atm-esi
 endef
 
 define Package/ltq-vdsl-app/description
index 8e7c1cb4b8ff0adeb3853bafb728ba47392b6b7d..cc127f7779c9639fdd4d1d79426f7275d6d94fcc 100644 (file)
@@ -7,4 +7,5 @@ for mod in $LOAD; do
        grep -q "$mod " /proc/modules || insmod "$mod"
 done
 
+esi $(printf '%012X' $((1+0x$(tr -d : </sys/class/net/eth0/address))))
 exec /sbin/vdsl_cpe_control "$@"
diff --git a/target/linux/lantiq/base-files/etc/init.d/esi b/target/linux/lantiq/base-files/etc/init.d/esi
deleted file mode 100755 (executable)
index ca79070..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2013 OpenWrt.org
-
-START=19
-start() {
-       esi $(printf '%012X' $((1+0x$(tr -d : </sys/class/net/eth0/address)))) 2>/dev/console || :
-}
index a2350158ab713ba6e442f636eab4f73dfe80fe92..059b93e142046de636835da6bc9a303979022d1b 100644 (file)
@@ -15,8 +15,7 @@ DEFAULT_PACKAGES+=kmod-leds-gpio \
        kmod-ltq-deu-vr9 \
        ltq-vdsl-app \
        ppp-mod-pppoa \
-       swconfig \
-       atm-esi
+       swconfig
 
 define Target/Description
        Lantiq XRX200
index 9434cc93e7531b89363571ccf9d493d08f3bcb53..b9d4a0ff5b144d25203ba5fe1e17a6475c957a4d 100644 (file)
@@ -5,7 +5,7 @@ FEATURES:=squashfs atm mips16 nand ubifs ramdisk
 CPU_TYPE:=34kc
 CPU_SUBTYPE:=dsp
 
-DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug atm-esi
+DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug
 
 define Target/Description
        Lantiq XWAY