[packages] pcre: update to 8.02
authorRaphaël Huck <rhk@cksum.org>
Mon, 22 Mar 2010 14:25:18 +0000 (14:25 +0000)
committerRaphaël Huck <rhk@cksum.org>
Mon, 22 Mar 2010 14:25:18 +0000 (14:25 +0000)
SVN-Revision: 20368

libs/pcre/Makefile
libs/pcre/patches/750-pcre_config_cross.patch

index a8368a01c47cd91d959f5808bd2b0442267fd3ca..fe3233ab806d06b0418c8e35935ce1c188037224 100644 (file)
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pcre
-PKG_VERSION:=8.01
-PKG_RELEASE:=2
+PKG_VERSION:=8.02
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/pcre
-PKG_MD5SUM:=413be1c23dabe91f637fb3770f640006
+PKG_MD5SUM:=27948c1b5f5c1eabc23cba1ebe4c316f
 
 PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,27 +30,29 @@ endef
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
-       --enable-shared \
-       --enable-static \
        --enable-utf8 \
-       --disable-cpp \
+       --disable-cpp
 
 MAKE_FLAGS += \
-       $(TARGET_CONFIGURE_OPTS) \
-       CFLAGS="$(TARGET_CFLAGS)" \
-       all \
+       CFLAGS="$(TARGET_CFLAGS)"
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/pcre-config $(1)/usr/bin/
-       ln -sf $(STAGING_DIR)/usr/bin/pcre-config $(2)/bin
-       $(CP) $(PKG_BUILD_DIR)/pcre{,posix}.h $(1)/usr/include/
-       $(CP) $(PKG_BUILD_DIR)/.libs/libpcre{,posix}.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/pcre-config $(1)/usr/bin/
+
+       $(INSTALL_DIR) $(2)/bin
+       $(LN) $(STAGING_DIR)/usr/bin/pcre-config $(2)/bin
+
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/pcre{,posix}.h $(1)/usr/include/
+
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcre{,posix}.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/libpcre/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/.libs/libpcre{,posix}.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcre{,posix}.so* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libpcre))
index a4b85bd8ebc27065b61961c75ecb89f69ba17a6c..1a5ab00650e7e72fe36eaa524257ac1d265abd52 100644 (file)
@@ -1,8 +1,6 @@
-Index: pcre-7.6/pcre-config.in
-===================================================================
---- pcre-7.6.orig/pcre-config.in       2008-02-16 11:13:56.000000000 +0100
-+++ pcre-7.6/pcre-config.in    2008-02-16 11:13:57.000000000 +0100
-@@ -21,6 +21,10 @@
+--- a/pcre-config.in
++++ b/pcre-config.in
+@@ -24,6 +24,10 @@ case `uname -s` in
    libR=" -Wl,-R@libdir@"
    ;;
  esac
@@ -13,8 +11,8 @@ Index: pcre-7.6/pcre-config.in
  
  while test $# -gt 0; do
    case "$1" in
-@@ -55,10 +59,10 @@
-       echo $includes
+@@ -58,10 +62,10 @@ while test $# -gt 0; do
+       echo $includes @PCRE_STATIC_CFLAG@
        ;;
      --libs-posix)
 -      echo -L@libdir@$libR -lpcreposix -lpcre
@@ -24,5 +22,5 @@ Index: pcre-7.6/pcre-config.in
 -      echo -L@libdir@$libR -lpcre
 +      echo $libS$libR -lpcre
        ;;
-     *)
-       echo "${usage}" 1>&2
+     --libs-cpp)
+       if test @enable_cpp@ = yes ; then