port the changes from [3155] to Kamikaze
authorImre Kaloz <kaloz@openwrt.org>
Mon, 6 Feb 2006 00:07:27 +0000 (00:07 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 6 Feb 2006 00:07:27 +0000 (00:07 +0000)
SVN-Revision: 3156

openwrt/target/linux/image/brcm/Makefile
openwrt/target/linux/package/diag/diag_led.c
openwrt/target/utils/src/motorola-bin.c

index 494450f247fba875f82a99e31fd0db61d008291f..0fe3ceeac7fb082d0e7e0981f7365ebe1c99de09 100644 (file)
@@ -89,7 +89,16 @@ $(BIN_DIR)/openwrt-wrt54g-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$
 $(BIN_DIR)/openwrt-wrt54gs_v4-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
        $(STAGING_DIR)/bin/addpattern -4 -p W54s -v v1.05.2 -i $< -o $@ -g
 
 $(BIN_DIR)/openwrt-wrt54gs_v4-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
        $(STAGING_DIR)/bin/addpattern -4 -p W54s -v v1.05.2 -i $< -o $@ -g
 
-install: $(BIN_DIR)/openwrt-wrt54g-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54gs_v4-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54g3g-$(KERNEL)-$(FSNAME).bin
+$(BIN_DIR)/openwrt-wr850g-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+       $(STAGING_DIR)/bin/motorola-bin -1 $< $@
+
+$(BIN_DIR)/openwrt-wa840g-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+       $(STAGING_DIR)/bin/motorola-bin -2 $< $@
+
+$(BIN_DIR)/openwrt-we800g-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+       $(STAGING_DIR)/bin/motorola-bin -3 $< $@
+
+install: $(BIN_DIR)/openwrt-wrt54g-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54gs_v4-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54g3g-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wr850g-$(FSNAME).bin $(BIN_DIR)/openwrt-wa840g-$(FSNAME).bin $(BIN_DIR)/openwrt-we800g-$(FSNAME).bin
 endif
 
 ifneq ($(FS),jffs2-4MB)
 endif
 
 ifneq ($(FS),jffs2-4MB)
@@ -100,12 +109,11 @@ $(BIN_DIR)/openwrt-wgt634u-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-
 $(BIN_DIR)/openwrt-wrt54gs-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
        $(STAGING_DIR)/bin/addpattern -4 -p W54S -v v4.70.6 -i $< -o $@ -g
 
 $(BIN_DIR)/openwrt-wrt54gs-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
        $(STAGING_DIR)/bin/addpattern -4 -p W54S -v v4.70.6 -i $< -o $@ -g
 
-install: $(BIN_DIR)/openwrt-wrt54gs-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wgt634u-$(KERNEL)-$(FSNAME).bin
-endif
+$(BIN_DIR)/openwrt-wrtsl54gs-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+       $(STAGING_DIR)/bin/addpattern -4 -p W54U -v v2.00.0 -i $< -o $@ -g
 
 
-$(BIN_DIR)/openwrt-motorola-$(KERNEL)-$(FS).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
-       $(STAGING_DIR)/bin/motorola-bin $< $@
-install: $(BIN_DIR)/openwrt-motorola-$(KERNEL)-$(FS).bin
+install: $(BIN_DIR)/openwrt-wrt54gs-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wgt634u-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrtsl54gs-$(FSNAME).bin
+endif
 endif
 
 ifeq ($(IB),)
 endif
 
 ifeq ($(IB),)
index 98649882573435c73fe2d37949ac2188c1e2a235..e4dc391117f118f23632a8edd4dfa64b3a9e80a5 100644 (file)
@@ -28,6 +28,7 @@
  * 2005/03/14 asus wl-500g deluxe and buffalo v2 support added
  * 2005/04/13 added licensing informations
  * 2005/04/18 base reset polarity off initial readings
  * 2005/03/14 asus wl-500g deluxe and buffalo v2 support added
  * 2005/04/13 added licensing informations
  * 2005/04/18 base reset polarity off initial readings
+ * 2006/02/07 motorola wa840g/we800g support added
  */
 
 #include <linux/module.h>
  */
 
 #include <linux/module.h>
@@ -186,6 +187,10 @@ static int __init diag_init()
                                //asus wl-500g
                                reset_gpio=(1<<6);
                        }
                                //asus wl-500g
                                reset_gpio=(1<<6);
                        }
+                       if (!strcmp(buf,"2")) {
+                               //wa840g v1 / we800g v1
+                               reset_gpio=(1<<0);
+                       }
                }
                if (!strcmp(buf,"bcm94710ap")) {
                        buf=nvram_get("boardnum")?:"";
                }
                if (!strcmp(buf,"bcm94710ap")) {
                        buf=nvram_get("boardnum")?:"";
index 476afe32f20b275bba1a8bf270ef1bdde32e16aa..acf856dde6dfe1a4ba0cd80cd076932fe7aa2eb8 100644 (file)
@@ -1,8 +1,9 @@
 /*
  * motorola-bin.c
  *
 /*
  * motorola-bin.c
  *
- * Copyright (C) 2005 Mike Baker 
- *                    Openwrt.org
+ * Copyright (C) 2005-2006 Mike Baker,
+ *                         Imre Kaloz <kaloz@openwrt.org>
+ *                         OpenWrt.org
  *
  * $Id$
  *
  *
  * $Id$
  *
  *
  */
 
  *
  */
 
+/*
+ * February 1, 2006
+ *
+ * Add support for for creating WA840G and WE800G images
+ */
+
 #include <stdio.h>
 #include <stdlib.h>
 #include <unistd.h>
 #include <stdio.h>
 #include <stdlib.h>
 #include <unistd.h>
@@ -59,29 +66,41 @@ unsigned int crc32buf(char *buf, size_t len)
 
 struct motorola {
        unsigned int crc;       // crc32 of the remainder
 
 struct motorola {
        unsigned int crc;       // crc32 of the remainder
-       unsigned int flags;     // unknown, 10577050
+       unsigned int flags;     // unknown, 105770*
        char *trx;              // standard trx
 };
 
        char *trx;              // standard trx
 };
 
+void usage(void) __attribute__ (( __noreturn__ ));
+
+void usage(void)
+{
+       printf("Usage: motorola-bin [-device] [trxfile] [binfile]\n\n");
+       printf("Known devices: 1 - WR850G | 2 - WA840G | 3 - WE800G\n");
+       exit(1);
+}
+
 int main(int argc, char **argv)
 {
        unsigned int len;
        int fd;
 int main(int argc, char **argv)
 {
        unsigned int len;
        int fd;
+       int c;
        void *trx;
        struct motorola *firmware;
 
        void *trx;
        struct motorola *firmware;
 
-       if (argc<3) {
-               printf("%s <trx> <motorola.bin>\n",argv[0]);
-               exit(0);
+       // verify parameters
+
+       if (argc!=4)
+       {
+       usage();
        }
 
        // mmap trx file
        }
 
        // mmap trx file
-       if (((fd = open(argv[1], O_RDONLY))  < 0)
+       if (((fd = open(argv[2], O_RDONLY))  < 0)
        || ((len = lseek(fd, 0, SEEK_END)) < 0)
        || ((trx = mmap(0, len, PROT_READ, MAP_SHARED, fd, 0)) == (void *) (-1))
        || (close(fd) < 0)) {
                perror("open/malloc");
        || ((len = lseek(fd, 0, SEEK_END)) < 0)
        || ((trx = mmap(0, len, PROT_READ, MAP_SHARED, fd, 0)) == (void *) (-1))
        || (close(fd) < 0)) {
                perror("open/malloc");
-               exit(-1);
+               exit(1);
        }
        
        // create a firmware image in memory
        }
        
        // create a firmware image in memory
@@ -92,11 +111,29 @@ int main(int argc, char **argv)
 
        // setup the motorola headers
        init_crc32();
 
        // setup the motorola headers
        init_crc32();
-       firmware->flags = ntohl(0x10577050);
+
+       // setup the firmware magic
+
+       while ((c = getopt(argc, argv, "123")) !=-1) {
+               switch (c) {
+                       case '1':
+                               firmware->flags = ntohl(0x10577050); // Motorola WR850G
+                               break;
+                       case '2':
+                               firmware->flags = ntohl(0x10577040); // Motorola WA840G
+                               break;
+                       case '3':
+                               firmware->flags = ntohl(0x10577000); // Motorola WE800G
+                               break;
+                       default:
+                               usage();
+               }
+       }
+
        firmware->crc   = htonl(crc32buf((char *)&firmware->flags,len+4));
 
        // write the firmware
        firmware->crc   = htonl(crc32buf((char *)&firmware->flags,len+4));
 
        // write the firmware
-       if (((fd = open(argv[2], O_CREAT|O_WRONLY,0644)) < 0)
+       if (((fd = open(argv[3], O_CREAT|O_WRONLY,0644)) < 0)
        || (write(fd,firmware,len+8) != len+8)
        || (close(fd) < 0)) {
                perror("write");
        || (write(fd,firmware,len+8) != len+8)
        || (close(fd) < 0)) {
                perror("write");