image: ensure that /dev/console exist in rootfs images
authorGabor Juhos <juhosg@openwrt.org>
Tue, 27 Aug 2013 12:02:58 +0000 (12:02 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 27 Aug 2013 12:02:58 +0000 (12:02 +0000)
Linux expects that the /dev/console node is present in
the rootfs image. Create the node in rootfs images, in
order to make std{in,out,err} usable even in early init
process.

Note: tar.gz and cpio.gz images are not handled yet.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 37847

include/device_table.txt [new file with mode: 0644]
include/image.mk

diff --git a/include/device_table.txt b/include/device_table.txt
new file mode 100644 (file)
index 0000000..f45b158
--- /dev/null
@@ -0,0 +1,5 @@
+# minimal device table file for OpenWrt
+
+#<name>                <type>  <mode>  <uid>   <gid>   <major> <minor> <start> <inc>   <count>
+/dev           d       755     0       0       -       -       -       -       -
+/dev/console   c       600     0       0       5       1       0       0       -
index 09eda736af104293db119fcac75c922d19afe1db..e81ce4de2cb731466f557c9cd02364748d8e8054 100644 (file)
@@ -17,6 +17,8 @@ KDIR=$(KERNEL_BUILD_DIR)
 
 IMG_PREFIX:=openwrt-$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))
 
 
 IMG_PREFIX:=openwrt-$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))
 
+MKFS_DEVTABLE_OPT := -D $(INCLUDE_DIR)/device_table.txt
+
 ifneq ($(CONFIG_BIG_ENDIAN),)
   JFFS2OPTS     :=  --pad --big-endian --squash-uids -v
 else
 ifneq ($(CONFIG_BIG_ENDIAN),)
   JFFS2OPTS     :=  --pad --big-endian --squash-uids -v
 else
@@ -26,7 +28,7 @@ endif
 ifeq ($(CONFIG_JFFS2_RTIME),y)
   JFFS2OPTS += -X rtime
 endif
 ifeq ($(CONFIG_JFFS2_RTIME),y)
   JFFS2OPTS += -X rtime
 endif
-ifeq ($(CONFIG_JFFS2_ZLIB),y) 
+ifeq ($(CONFIG_JFFS2_ZLIB),y)
   JFFS2OPTS += -X zlib
 endif
 ifeq ($(CONFIG_JFFS2_LZMA),y)
   JFFS2OPTS += -X zlib
 endif
 ifeq ($(CONFIG_JFFS2_LZMA),y)
@@ -42,8 +44,11 @@ ifneq ($(CONFIG_JFFS2_LZMA),y)
   JFFS2OPTS += -x lzma
 endif
 
   JFFS2OPTS += -x lzma
 endif
 
+JFFS2OPTS += $(MKFS_DEVTABLE_OPT)
+
 SQUASHFS_BLOCKSIZE := 256k
 SQUASHFSOPT := -b $(SQUASHFS_BLOCKSIZE)
 SQUASHFS_BLOCKSIZE := 256k
 SQUASHFSOPT := -b $(SQUASHFS_BLOCKSIZE)
+SQUASHFSOPT += -p '/dev d 755 0 0' -p '/dev/console c 600 0 0 5 1'
 SQUASHFSCOMP := gzip
 LZMA_XZ_OPTIONS := -Xpreset 9 -Xe -Xlc 0 -Xlp 2 -Xpb 2
 ifeq ($(CONFIG_SQUASHFS_LZMA),y)
 SQUASHFSCOMP := gzip
 LZMA_XZ_OPTIONS := -Xpreset 9 -Xe -Xlc 0 -Xlp 2 -Xpb 2
 ifeq ($(CONFIG_SQUASHFS_LZMA),y)
@@ -110,7 +115,7 @@ endif
 ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
     define Image/mkfs/ubifs
                $(CP) ./ubinize.cfg $(KDIR)
 ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
     define Image/mkfs/ubifs
                $(CP) ./ubinize.cfg $(KDIR)
-               $(STAGING_DIR_HOST)/bin/mkfs.ubifs $(UBIFS_OPTS) -o $(KDIR)/root.ubifs -d $(TARGET_DIR)
+               $(STAGING_DIR_HOST)/bin/mkfs.ubifs $(UBIFS_OPTS) $(MKFS_DEVTABLE_OPT) -o $(KDIR)/root.ubifs -d $(TARGET_DIR)
                $(call Image/Build,ubifs)
                (cd $(KDIR); \
                $(STAGING_DIR_HOST)/bin/ubinize $(UBINIZE_OPTS) -o $(KDIR)/root.ubi ubinize.cfg)
                $(call Image/Build,ubifs)
                (cd $(KDIR); \
                $(STAGING_DIR_HOST)/bin/ubinize $(UBINIZE_OPTS) -o $(KDIR)/root.ubi ubinize.cfg)
@@ -136,7 +141,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_EXT4FS),)
 
   define Image/mkfs/ext4
 # generate an ext2 fs
 
   define Image/mkfs/ext4
 # generate an ext2 fs
-       $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext4 -m $(CONFIG_TARGET_ROOTFS_RESERVED_PCT)
+       $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext4 -m $(CONFIG_TARGET_ROOTFS_RESERVED_PCT) $(MKFS_DEVTABLE_OPT)
 # convert it to ext4
        $(STAGING_DIR_HOST)/bin/tune2fs -O extents,uninit_bg,dir_index $(KDIR)/root.ext4
 # fix it up
 # convert it to ext4
        $(STAGING_DIR_HOST)/bin/tune2fs -O extents,uninit_bg,dir_index $(KDIR)/root.ext4
 # fix it up