Fix rtorrent dependency against libsigcxx
authorFlorian Fainelli <florian@openwrt.org>
Wed, 12 Nov 2008 02:21:47 +0000 (02:21 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 12 Nov 2008 02:21:47 +0000 (02:21 +0000)
SVN-Revision: 13191

net/rtorrent/Makefile

index 2c411a5662243f36fbdd357c4e2250395d3493a8..1048208c9b3bca70cd1ca03cb7064b09005ac36c 100644 (file)
@@ -26,7 +26,7 @@ define Package/rtorrent
   CATEGORY:=Network
   TITLE:=BitTorrent client for ncurses
   URL:=http://libtorrent.rakshasa.no/
   CATEGORY:=Network
   TITLE:=BitTorrent client for ncurses
   URL:=http://libtorrent.rakshasa.no/
-  DEPENDS:=+libcurl +libtorrent +libncurses
+  DEPENDS:=+libcurl +libtorrent +libncurses +libsigcxx
 endef
 
 define Package/rtorrent/description
 endef
 
 define Package/rtorrent/description
@@ -42,7 +42,7 @@ CONFIGURE_ARGS+= \
        --disable-debug \
 
 CONFIGURE_VARS += \
        --disable-debug \
 
 CONFIGURE_VARS += \
-       LIBS="-lm" \
+       LIBS="-lm -luClibc++" \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \