[PATCH v2] rsyncd: Add description and conffiles entry
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Jun 2011 22:52:19 +0000 (22:52 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Jun 2011 22:52:19 +0000 (22:52 +0000)
Add description and conffiles entry for rsyncd to rsync's Makefile.
Signed-off-by: Ian Leonard <antonlacon@gmail.com>
SVN-Revision: 27238

net/rsync/Makefile

index 6548144a9f0bc35a189fc384316002805c36a716..46670e57610486b0e0b07d346dc2d0cd192ee22e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rsync
 PKG_VERSION:=3.0.8
 
 PKG_NAME:=rsync
 PKG_VERSION:=3.0.8
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://rsync.samba.org/ftp/rsync/src
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://rsync.samba.org/ftp/rsync/src
@@ -61,6 +61,16 @@ define Package/rsync/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
 endef
 
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
 endef
 
+define Package/rsyncd/description
+       rsyncd is a configuration file and initscript to
+       utilize rsync as a daemon. It uses the same binary
+       as rsync.
+endef
+
+define Package/rsyncd/conffiles
+/etc/rsyncd.conf
+endef
+
 define Package/rsyncd/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/rsyncd.conf $(1)/etc/
 define Package/rsyncd/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/rsyncd.conf $(1)/etc/