Added support for USB_SERIAL_VISOR, closes #180
authorFlorian Fainelli <florian@openwrt.org>
Fri, 6 Jan 2006 11:50:47 +0000 (11:50 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 6 Jan 2006 11:50:47 +0000 (11:50 +0000)
SVN-Revision: 2844

openwrt/target/linux/Config.in
openwrt/target/linux/control/kmod-usb-serial-visor.control [new file with mode: 0644]
openwrt/target/linux/linux-2.4/Makefile
openwrt/target/linux/linux-2.4/config/brcm

index 9ccb11bad945bd0246481a5f8dcab2f1c03e4e18..a0fc80413aad37c822389da9e2fbc84810382fbc 100644 (file)
@@ -750,6 +750,12 @@ config BR2_PACKAGE_KMOD_USB_SERIAL_PL2303
        default m
        depends BR2_PACKAGE_KMOD_USB_SERIAL
 
+config BR2_PACKAGE_KMOD_USB_SERIAL_VISOR
+       prompt   "kmod-usb-serial-visor.......... Support for Handspring Visor / Palm m50x / Sony Clie Driver"
+       tristate
+       default m
+       depends BR2_PACKAGE_KMOD_USB_SERIAL
+
 config BR2_PACKAGE_KMOD_USB_STORAGE
        prompt "kmod-usb-storage.................. Support for USB storage devices"
        tristate
diff --git a/openwrt/target/linux/control/kmod-usb-serial-visor.control b/openwrt/target/linux/control/kmod-usb-serial-visor.control
new file mode 100644 (file)
index 0000000..7b993be
--- /dev/null
@@ -0,0 +1,7 @@
+Package: kmod-usb-serial-visor
+Priority: optional
+Section: sys
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: buildroot internal
+Description: Kernel Support for Handspring Visor / Palm m50x / Sony Clie
+Driver
index 405d1b3ffbb418e76084d3e8465dd4f94c3f64f7..3d668fa95e11b162a01f00b617b4cbfe120334dd 100644 (file)
@@ -346,6 +346,10 @@ $(eval $(call KMOD_template,USB_SERIAL_PL2303,usb-serial-pl2303,\
        $(MODULES_DIR)/kernel/drivers/usb/serial/pl2303.o \
 ,CONFIG_USB_SERIAL_PL2303,kmod-usb-serial,61,pl2303))
 
+$(eval $(call KMOD_template,USB_SERIAL_VISOR,usb-serial-visor,\
+       $(MODULES_DIR)/kernel/drivers/usb/serial/visor.o \
+,CONFIG_USB_SERIAL_VISOR,kmod-usb-serial,61,visor))
+
 $(eval $(call KMOD_template,USB_STORAGE,usb-storage,\
        $(MODULES_DIR)/kernel/drivers/scsi/*.o \
        $(MODULES_DIR)/kernel/drivers/usb/storage/*.o \
index 7c011b21d83e797799a1526c3a504d4d67e9035c..bc375e0edea454a54ecb01bb9bcb7696fea9b6ae 100644 (file)
@@ -1289,7 +1289,7 @@ CONFIG_USB_SERIAL_BELKIN=m
 # CONFIG_USB_SERIAL_DIGI_ACCELEPORT is not set
 # CONFIG_USB_SERIAL_EMPEG is not set
 CONFIG_USB_SERIAL_FTDI_SIO=m
-# CONFIG_USB_SERIAL_VISOR is not set
+CONFIG_USB_SERIAL_VISOR=m
 # CONFIG_USB_SERIAL_IPAQ is not set
 # CONFIG_USB_SERIAL_IR is not set
 # CONFIG_USB_SERIAL_EDGEPORT is not set